"Your browser does not support the video tag"

  1. I'm getting an "Your browser does not support the video tag" tag in place of where my video should be in my post. Here's what I've done:

    In the "Write" post screen
    Clicked the video reel
    Add Video from Library
    Selected the Video I want to upload
    Clicked "Choose"
    Waited from compression
    Waited for video to upload in the "Media" screen (the video's only 8MB after compression)
    Under the video it then says "00:00:00 8.36 MB"
    Clicked the uploaded video thumbnail
    Clicked the right arrow button
    Inserted video "Above Content"
    Clicked update

    When I go into edit the post, this is when I see the "Your browser does not support the video tag" with
    br /> after. I imagined this is where the video is supposed to be. Why am I only getting this tag?

    On a side note, using FileZilla I'm able to see that the video was uploaded successfully to the wp-content/uploads folder.

    Any suggestions?

  2. First, what browser are you using? I'd really recommend an upgrade.

    You can go to the > WordPress and change "Video Content" and see if it helps
    Another option would be using VideoPress

  3. I'm using whatever version of Safari comes with the new iPhone 4s. I'm using the newest version of the Wordpress for iPhone app as well.

    I made the switch to HTML4 with no luck.

    The code for the video displays in the edit view. After the update the site, the code disappears with nothing left but the

    Thanks Jorge

  4. Can you post a link to the post if it's public? Or maybe do a password protected post with a video so I can check out what's wrong?

  5. I am having the same problem... I record a video on my iphone 4s using the wordpress app and go to publish it but in the code has 'your browser does not support the video tag'

    Would love a solution, thanks

  6. @jamieblog - Did you try the HTML 4 option in the app's settings?

  7. Thanks so much! That has worked, wonder why HTML 5 isn't working?

  8. Hi,

    I am having the same problem. I have the latest version of Wordpress installed, the lastest version of the app and the last version of Safari and Google Chrome. I have tried changing the app settings to HTML 4. It puts the code in, then when I go back to the post the code seems to remove itself and leave only

  9. Ok, so I have got this far. I have two self-hosted Wordpress multisites. When I add any of the subsites from to the Wordpress app on my ipad and try and upload a video, it seems to upload and adds the video tags in the post but when I go to view it I just get "Your browser does not support the video tag". In fact when I go out and back into the post in Wordpress it seems to remove the tags (and the same is true when I go into the post via an Internet browser - the video tags have dissapeared) and therefore no video. If I enter the tags in via the Internet browser the video is embedded and plays fine so it can't be a browser issue.


    when I add a site from the other multisite in the same Wordpress app on my ipad the tags stay and the video works!

    According to the network admin both sites have the latest version of Wordpress installed. I have tried different themes to see if this is the problem but this doesn't seem to make a difference....


  10. For what it is worth, I am experiencing the same problem.

  11. I figured out how to change the app settings to HTML 4. This is getting me a better result. The video now appears in my post, but with no controls, including a play button. Go to the main settings app on iPhone. Scroll past the list of core apps and to the list of user installed apps to find Wordpress. There is a setting attribute for "Video Content" and the default is HTML5 and you can select HTML4.

Topic Closed

This topic has been closed to new replies.

About this Topic