Forums

XML-RPC service

  1. I am still getting the "We could not find the XML-RPC service for your blog. Please check your network connectiong and try again." message.

    I have done everything on the FAQ page and it all SHOULD be working. is there something i am missing?

    My page is selfhosted at http://www.kretzu.com/blog

    when i tried to "add blog" i used "kretzu.com/blog" for the url, and used my admin name and password.

    is that right?

    ~c

  2. @kretzu --

    have you taken a look at the Known Issues list as well ? http://iphone.forums.wordpress.org/topic/known-issues?replies=1

  3. You actually need to use http:// in your URL. It's a stupid error consider the example they give (example.wordpress.org) doesn't include the http://.

    Hope that helps. That did the trick for me!

  4. I had this same problem and the issue was that it was going to my blog at example.com and it seemed to be looking for the index.php so it could tell where the xml-rpc file was.

    The problem was, my blog wasn't live yet at example.com because I had a default index.html file that loaded first showing my placeholder page.

    When I deleted the placeholder page so the index.php page loaded first, the error went away and it authenticated right away.

    I would think that the script would look for the xmlrpc.php at the URL you enter instead of the index.php file, but hopefully this helps someone else :)

  5. @esm723 --

    the "http://" portion isn't required, but I have seen a few mentioned of this, and I'm wondering if it's somehow related to a redirect bug http://iphone.trac.wordpress.org/ticket/107 or some variation of it.

    @rodneyb. Glad it's working for you. For clarification, the app looks for the xmlrpc.php file based on the RSD line in your theme. So I would double check the theme, it may be pointing to a different place.

  6. I'm posting this in case it adds to the general sum of knowledge and helps someone.

    I was trying to two Wordpress blogs editable from the iPhone, but only one succeeded.

    The one that didn't work failed on iPhone with the apparently well-known “XML-RPC Service for you blog cannot be found” error. I read this page and the FAQs at http://iphone.wordpress.org/faq/

    I checked with the W3C validator, and I didn't have the "… one or more bytes that I cannot interpret as UTF-8?" error message.

    The source for the blog did not have an RDS meta tag, which I suppose is why it was happening. I don't know why that was the case.

    In Settings > Writing > XML-RPC, the checkbox for "Enable the WordPress, Movable Type, MetaWeblog and Blogger XML-RPC publishing protocols." is checked.

    On the problem blog, which was http://www.topicscape.com/blog/ I found that http://www.topicscape.com/blog/xmlrpc.php?rsd resolved to a valid XML file and http://www.topicscape.com/blog/xmlrpc.php showed, as I understand it should, "XML-RPC server accepts POST requests only."

    I am using Wordpress 2.7.1 and have a modified theme. I don't know where to look for RSD line in my theme, but @raanan's mention of themes led to the solution.

    I 'solved' the problem (meaning I made it go away) by switching back to the Wordpress default theme, set up the iPhone and found that it connected OK, then switched back to my own theme. And it still seems to be OK.

    Roy

  7. ok I am a beginner at this but i installed WP first time yesterday and after 3 times I kind of got what I wanted but I need the IPhone integration for an upcoming roadtrip.

    Everytime I tried I got the dreaded XML-RPC message but I went back in themes etc nothing helped.
    Then I saw his notice about a bug fix for slow loading RDS but I got nothing , just a dead page so then someone had mentioned an update in functions.php (i am no linux/php guy) but I tried to copy it over but I failed.

    I then saw this function to compare relases so I comared the bug fix with the earlier one and this row 2621 is changed:

    2621         curl_setopt($ch, CURLOPT_CONNECTTIMEOUT, 5);

    so I basically added that to my functions.php in wp-includes directory. Not the row number just the curl....etc

    It solved my problem !!!

    just my 2 cents

    /Kenneth (working blog @ http://www.stenlund.com/blog.kenneth )

  8. Thanks RoyGrubb, that was super helpful and solved my problem.

  9. Sweet! Thanks!

Topic Closed

This topic has been closed to new replies.


About this Topic

Tags