Forums

xml-rpc iPhone & iPad

  1. When I use

    Error: XML -RPC services are disabled on this site.

    My blog is SpeciousArgument at http://speciousargument.com/blog/
    Version of WordPress: 3.8.2
    WordPress for iOS: 4.0.1

    I have a lengthy log file from WordPress for iOS. I am not sure if it contains sensitive data, but I am willing to send it.

  2. We'd love to see the log file. You can email it to 'mobile-support at automattic dot com' and mention this forum post.

    This is curious. When I test your blog's XML-RPC endpoint for the 'demo.sayhello' method it works fine. If XML-RPC was blocked for some reason it should fail. Hopefully the log will tell us what's going on.

  3. I sent the log file yesterday. And, I just resent it again a moment ago. Please let me know if you don't receive it.

    Thank you for your attention.

  4. In the mean time you might try temporarily disabling plugins on your blog to see if one of them is creating a conflict.

  5. The plugins that I am using are as follows:

    • Akismet
    • Jetpack by WordPress.com
    • VaultPress
    • Wordfence Security

    I am also using Thesis 2.1 theme.

    I first disabled Wordfence. Problem disappeared. I reactivated Wordfence. Problem reappeared sporadically. Disabled again, and problem disappeared. Activated a final time and can't get the problem to reappear.

    Thank you for your follow-up.

  6. That's great you were able to find the culprit. And thank you so much for letting us know which one it was! This gives us a chance to work with the developers to get it fixed.

  7. Thank you for your prompt attention.

    I find the folks at Wordfence are excellent. So I am sure that they'll be receptive.

  8. I am having the same issue with mine and the same thing happened when I disabled/enabled word fence so it's obviously conflicting- did you find a solution to this? I just have the free version so I don't think I can ask on their support forums.

  9. I just cycled deactivate and activate several times and now it seems to function. However, I have not created any new posts yet. Perhaps once I do, I will need to start over again with cycling deactivate and activate.

    I have the premium version and have alerted them to this issue. I haven't received any response as yet.

    In looking at their forum, which you can post to, they have acknowledged the error. Please see here:
    http://wordpress.org/support/topic/wordfence-and-xml-rpc?replies=6

    So, perhaps in the next version we'll have the option to enable or disable xml-rpc.

Topic Closed

This topic has been closed to new replies.


About this Topic