Forums

XML-RPC error 5... Once again...

  1. Communication Error
    Operation could not be completed. (NSXMLParseErrorDomain error 5.)

    Blog: MaxT.dk
    Software: Wordpress 2.7.1
    XML-RPC Remote Publishing: Enabled (.../options-writing.php)
    EditURI: Presented (see source)
    XML-RPC request: Proper (http://maxt.dk/xmlrpc.php)
    XML-RPS RSD XML: Proper (http://maxt.dk/xmlrpc.php?rsd)
    Plugins: http://maxt.dk/plugins/
    Tried to disable all plugins: Yes
    Tried to use another theme(s): Yes
    Have read "Known Issues": Yes
    Used encoding for pages and feeds: iso-8859-1

    Tried solutions:

    Given up on getting it running: Close to...

    Help: Appreciated

  2. Thanks for trying all the various approaches.

    Are you running the latest version of the app and the iPhone OS ?

    Which alternate theme did you try it with ?

    Anything in your .htacess file that may be preventing logins ?

    Could you try adding a WordPress.com blog and seeing if that works. Just want to rule out some issue on the device itself.

    Also seeing a few XML validation issues that may be to blame: http://validator.w3.org/check?uri=http%3A%2F%2FMaxT.dk

  3. WordPress for iPhone app version: 1.21
    iPhone OS: 2.2.1 (5H11)
    Different themes: Default and Classic (shipped with WP 2.7.1)
    Current .htaccess: http://maxt.dk/htaccess.txt

    Created http://maxthrane.wordpress.com/, tested, works: http://maxthrane.wordpress.com/iphone/

    Most XML errors has been fixed, the rest I have no idea how to fix :x

    I've also tried to change the encoding on my blog from iso-8859-1 to UTF-8, but that didn't brought any positive results :|

  4. I'm having the same issue with no luck resolving.

    Wordpress Version 2.7.1
    iPhone 3G with latest iPhone OS

    Originally tried with a theme I created using artisteer. Changed to 'default' WP theme and same error:
    Communication Error
    Operation could not be completed. (NSXMLParseErrorDomain error 5)

  5. I'm still struggling with this. I've been searching the forums and not coming up with any luck yet. Can anyone tell me if I missed something? Thanks

    - Wordpress Version 2.7.1
    - Settings/Writing/XML-RPC is checked
    - Set to DEFAULT theme
    - iPhone OS: 2.2.1
    - WP App: 1.21
    - http://8r14n.com/xmlrpc.php?rsd is working
    - Updated my .htaccess file like MaxT.dk above

  6. XML validation is fine http://validator.w3.org/check?uri=http%3A%2F%2F8r14n.com

    and added the following to me .htaccess:

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>
  7. Operation could not be completed. (NSXMLParseErrorDomain error 5)

    Sorry for so many posts. I see others having the same issue and no resolution. I've tried every suggestion I could find. For clarity and hopes someone can help figure this out...

    - I deleted my .htaccess file with no new success. The IfModule code above seem to create a new error for me so I got rid of it. I do not have a .htaccess file on my site now.
    - I'm not running the Resize At Upload plugin. I was using a social media bookmarking plugin. I deactivated it. I'm not running any plugins right now. Still no luck.
    - I created a test account at WordPress.com and CAN post to it with no problem. I CAN also edit existing pages and post successfully with the iPhone app: http://mbcz.wordpress.com/
    - I double-checked the known issues list. I do not have a custom uploads directory, password protected directories, or any of the other known issues listed.
    - I even unchecked and rechecked the RPC setting: Settings/Writing/XML-RPC
    - I also tried with and without 'http://' in the blog address inside the app
    - I also tried with and without the resize photos option inside the app, still no success

    My site it http://8r14n.com. I hope someone can shed some light. I really want this to work.

  8. I may have stumbled upon a clue to this friggin' NSXMLParseErrorDomain error 5 problem. I have no idea what that error means but I'm determined to beat it. I suspect something in my php.ini file was causing the problem but really don't know. Below is the contents, it's really for php 4. Since I'm running php 5 and mySQL 5, I don't need it and deleted it.
    .
    register_globals = off
    allow_url_fopen = off

    expose_php = Off
    max_input_time = 60
    variables_order = "EGPCS"
    extension_dir = ./
    upload_tmp_dir = /tmp
    precision = 12
    SMTP = relay-hosting.secureserver.net
    url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="

    [Zend]
    zend_extension=/usr/local/zo/ZendExtensionManager.so
    zend_extension=/usr/local/zo/4_3/ZendOptimizer.so
    '
    Frustrated I decided to start from scratch. I deleted everything from my server, created a new DB and reinstalled a new instance of WP on my server, this time with no php.ini file, and EVERYTHING WORKS!

    To test I re-uploaded the php.ini file and got error 5 again. I deleted the php.ini file, expecting things to work again, but nothing did - Same error 5 again. I tried everything. I deleting the app and reloaded onto my phone. I tried uploading a blank php.ini file... Very frustrated I deleted everything and resetup the phone and my server from scratch with no php.ini file again. It worked again. This really pissed me off. I’m not testing anything else and calling it a day.

  9. Spoke too soon. Nothing working again. Same friggin' error. I'm about to delete this app from my phone for good.

  10. Heh... Frustrations, frustrations... I've given up for now... The app is not deleted from the phone yet... I'll see if there will be a new update which might address this issue... Sad situation...

  11. A solution that worked for me here.

  12. I can't really see a solution there, sorry... Specially when the link to the forumpost they're linking to is broken...

  13. Brian Charlonis
    Inactive
    May 5, 2009, 9:59 AM

    Tim, can you repost? The link doesn't work.

    Where are the help or comments from the developers? Is this a known issue with the application? Is it being addressed? A little commentary goes a long way.

  14. I see that your blog site is using the default theme... The first assumption is that it's something in the service you're using or some other thing unique to the site or server...

    To validate that would you be willing to take a moment and build a similar site on wordpress.com?

    Who is your host and what OS are they hosting on?

  15. Host: GoDaddy

    OS: Linux with PHP 5.2.3

    FROM ABOVE: - I created a test account at WordPress.com and CAN post to it with no problem. I CAN also edit existing pages and post successfully with the iPhone app: http://mbcz.wordpress.com/

  16. Heres' the link from Timmerritt's post above: . It did not solve my problem.

  17. I made the change to my XMLRPC.php file like described in timmeritt's link with no luck. I changed it back to the original, default and reuploaded. One post has worked successfully from my iPhone. I made a back up of my local file and dowloaded the version on the server... no changes to my XMLRPC file that I can notice. I'll give the app a few more test. It's worked for a few tests before and then started ti mysteriously stop working.

  18. @JosephScott

    I'm not sure what causes changes to the xmlrpc.php file. According to the link above from timmerritt LINK, apparently his file was revised. Not sure if this is done as part of the application setting itself up or maybe by a setting in WordPress (Admin’s Settings; Writing; Remote Publishing and checkign the XML-RPC box). The revisions are below.

    if ( isset($HTTP_RAW_POST_DATA) )
    $HTTP_RAW_POST_DATA = trim($HTTP_RAW_POST_DATA);
    
    became
    
    if ( isset($HTTP_RAW_POST_DATA) )
    $HTTP_RAW_POST_DATA = mysql_escape_string(trim($HTTP_RAW_POST_DATA));

    I didn't check to see what was live on my server. I just modified my xmlrpc.php file with the revised version above and had no success. I modified it again to be the default install xmlrpc.php file and everything works. I wonder if my xmlrpc.php was was modified before I started.

  19. You might want to check the rest of your WordPress install, it looks like in at least some of the cases this change was also associated with other bad things: http://eric.clst.org/mystery/archives/693

Topic Closed

This topic has been closed to new replies.


About this Topic