Forums

XML-RPC Error

  1. Running self hosted Wordpress 2.8 my only plugin is Spam Karma 2. Upgraded to iPhone OS 3.0 and the wordpress app hung. I removed it and reinstalled it. When trying to configure for my site I get the RPC-XML error. I read the FAQ's and everything seems to be ok. I checked that I had XML-RPC enabled in Settings > Writing. It was set so I turned it off and back on. No luck.

    The Blog URL is http://southofdallas.com

    All clues appreciated.

  2. I took a quick look at your site and didn't see anything obvious that would cause problems from the app.

    Two things to try, first, switch to the default theme and see if the app works. If it does then there's something in your theme that is throwing it off.

    If it still doesn't work disable all plugins and try the app again. If it works at that point then one of the plugins is causing a problem.

  3. I have a fix for this that works consistently for me. I have uninstalled and reinstalled this app a few times for other reasons (to fix non-functioning local drafts folder) and every time I can re-create the xml-rpc set-up problem and then fix it the same way.
    I use an address redirect for my self-hosted blog (which is private at present) at http://www.sjlemon.com. If I use this address in my web browser fine. If I use it in the Wordpress iPhone app then I get the rpc-xml error. However, the actual web address of my blog is something completely different, i.e. ending with /wordpress/. In my case it is http://amcl-pty.homeip.net/wordpress/ . If I use the full address with the folder containing wordpress, then my the iPhone set-up works everytime.
    Maybe this will help someone else...

  4. I'm having the same issue with http://stevenmcnally.net/wordpress I used to be able to connect with my iPhone without any issues.

  5. I had the same issue on a self hosted blog running Wordpress 2.8. I was running wordpress for the iphone without issue and then got stuck when I upgraded to the 3.0 compatible iphone software. I logged in on the computer, changed to the default theme, and then set up my iphone software - it worked perfectly. After the initial setup I was able to restore my theme via the computer and the iphone software still works. Oddly enough it even works if I ask the iphone to preview a post (still shows it with my custom theme). It seems like the updated iphone software is a bit picky at setup but I am glad to have it working now.

    Maybe this fix will work for others.

    Note: I never had to disable my plugins but the technique above might also apply if plugins are the snag.

    Good luck!

  6. I'm having the XML-RPC error on my site as well, but have never been able to get this app to work with it. I have XML-RPC enabled, and can use other blog editing tools (like MarsEdit) with no problem. I really want to use and like this app, but can't figure out what is wrong. http://fundamentallysound.org/wordpress/

Topic Closed

This topic has been closed to new replies.


About this Topic