Forums

XML-RPC Error

  1. I can't seem to get things working with the latest version of the iPod app and my self installed blog, ver 2.71.. I followed the directions in the FAQ

    MYBlogURL: http://www.noelsblog.org/
    http://www.noelsblorg.org/xmlrpc.php , produces the "XML-RPC server accepts POST requests only."-message.
    http://www.noelsblorg.org/xmlrpc.php?rsd , produces a valid XML-file

    And, I checked for invalid characters: nada.

    Any help greatly appreciated.

  2. ooops, type above. The correct URL for my blog is http://www.noelsblog.org.

    It should have read: http://www.noelsblog.org/xmlrpc.php produces the "XML-RPC server accepts POST requests only."
    and

    http://www.noelsblog.org/xmlrpc.php?rsd , produces a valid XML-file

    Sorry about that.

  3. @noels - have you looked through the list here of known issues: http://iphone.forums.wordpress.org/topic/known-issues ?

    And did the app work in earlier versions for you ?

    And lastly, have you tried it with a basic theme ?

  4. Hey, I'll join in in this thread if I may. I'm doing the FAQ to resolve this XML-RPC error on http://www.holbrooksfilms.com. I've veiwed the source and found the line, and got the 'accepts posts only' line... But I don't get the resolves in an XML. Which would be fine if the FAQ told me what to do if an XML doesn't come up! :D
    So, how do I fix it if the XML doesn't come up?
    Thanks!
    Dan

  5. @daninksi --

    Your RSD URI doesn't load as you mentioned: http://holbrooksfilms.com/xmlrpc.php?rsd. Please review this http://josephscott.org/archives/2009/03/slow-loading-rsd-urls-in-wordpress/, and then contact your hosting provider if you are still stuck.

Topic Closed

This topic has been closed to new replies.


About this Topic

Tags