Forums

XML-RPC Endpoint error on image upload

  1. I've bumped into an issue when I upload images to my blog. Specifically, the error is:

    Sorry, upload failed
    Parse Error. Please check your XML-RPC endpoint.

    I read several forum threads here about XML-RPC difficulties and have made a few adjustments but nothing has solved the image upload problem. Here's some supporting data points for this issue:

    • WordPress for iOS 2.7.2
    • WordPress version 3.1.1
    • iPhone 4 running iOS 4.3.2
    • WordPress blog self-hosted on a 1and1.com site
    • XML-RPC is enabled in "Settings"
    • Site address: http://www.ghostcruises.org/blog
    • http://www.ghostcruises.org/blog/xmlrpc.php?rsd responds with a valid XML file where the apiLink attribute for the WordPress api elements points to the correct address.
    • http://www.ghostcruises.org/blog/xmlrpc.php responds with the correct "XML-RPC server accepts POST requests only." message.
    • From the iPhone, I can view and add posts, view and create new pages, and view and edit comments.
    • When adding an image, image selection is successful and the upload process counts up to 100%. Then there is a delay and eventually the error appears.
    • Image upload from the Web UI on a PC works fine.

    It doesn't seem like anybody else has this problem (or at least they aren't posting about it). Any idea what I'm doing wrong?

    Thank you for your help.

    Best regards,

    Paul

  2. did you add the following line to your .htaccess file?

    php_value memory_limit 128M
    php_value upload_max_filesize 128M
    php_value post_max_size 128M
    php_value max_execution_time 120

  3. I had not modified .htaccess yet, so I tried that, and tried, and tried, and tried. Each time I uploaded the modified .htaccess to the root of my WP folder, I'd get a 500 error when I tried to access the blog (from the web, not the iPhone). Since the blog is hosted on a 1and1 site, I don't have the keys to Emerald City with regard to access. I even tried selectively commenting out the lines so only one of them was active at a time; still got the 500 error every time.

    I did, however, rig up a phpinfo() query and discovered that the global values for these items are as follows:
    memory_limit 90M
    upload_max_filesize 40M
    post_max_size 8M
    max_execution_time 50000

    One thing I did learn is that 1and1 runs in php4 by default but supports php5. So I added the following line:
    AddType x-mapp-php5 .php

    I don't know why this would make any difference, but now I can post photos in small, medium, and large sizes. I tried the "original" size on a very large photo and that failed but with a "check the configuration of your blog" message. A custom sized image uploaded successfully.

    Summary: my problem appears to be solved, but I'm not sure why. I guess ignorance is bliss.

Topic Closed

This topic has been closed to new replies.


About this Topic