Forums

XML-RPC

  1. Have installed and now tried 4 times to key in the details of my blog but keep getting this error:

    We could not find the XML-RPC service for your blog ....etc.

    What do I do now?

    C

  2. PS - have now read through the details on your FAQ and tried to follow the suggestions - but its so vague it doesn't help...

    Locate your RSD meta tag by viewing-source on your blog. It will look similar to this:
    <link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://example.com/xmlrpc.php?rsd" />

    On which page / post of my blog is this meta tag meant to be? I can't find anything like this in the xmlrpc.php document.

    Now what am I meant to do?

    Next, follow the link, http://example.com/xmlrpc.php?rsd, and make sure it resolved to an XML file.

    I followed this link and all I get is ACCESS DENIED

    Locate the WordPress API item: http://example.com/xmlrpc.php. And lastly, load that apiLink value into your browser.

    HUH?

    A: Check with your hosting provider or system administrator to see if permissions or other issues are causing the error.

    Are you serious? I work alone so its ME - no one else to ask. Also what ARE the permissions MEANT to be anyway? Mine appear to be 660 is this correct?

    I AM TOTALLY UNDERWHELMED WITH THIS APP. SURELY THERE MUST BE A WAY TO GET THE BLASTED THING TO WORK WITHOUT ALL THIS HASTLE?

  3. >On which page / post of my blog is this meta tag meant to be? I can't find anything like this in the xmlrpc.php >document.

    It should be on your main index page -- just view source. If it's not there, then you are running a theme that is missing necessary pieces. Either try running a different theme, or take a look at this: http://josephscott.org/archives/2009/04/wordpress-theme-authors-dont-forget-the-wp_head-function/

    You may also need to activate XML RPC on your blog. Go to Admin’s Settings; Writing; Remote Publishing and check the XML-RPC box.

    Hope that helps.

  4. Hi Raanan: I've also been having a problem with this and have tried the various trouble-shooting tips. Worked fine before, but had to swap out my Iphone last week because the ringer button broke and ever since, I've been unable to set up my self-hosted blog via Iphone. XML-RPC box is checked in my settings and nothing else has changed other than the actual phone, so not sure what's going on. Should add that changing theme is not really an option.

  5. Just a quick follow-up that I was able to resolve this by removing the app and reinstalling it, so if all else fails, you might want to try that.

  6. Perhaps another hint:
    I have a plugin called Maintance Mode installed and acitvated, so noone can access my site till i finish my work on themes plugins and other adjustments.
    Iphone app could not find the service when this plugin is activated what is a pity cause I cannot prepare some articles in the meantime. I will contact plugin designer, if he can solve this...

  7. I have the same issue and fullfill every option in the FAQ and still get the "We could not find ....".
    I have tried another app "BlogWriterLite" and everything is well, so I am puzzled.

Topic Closed

This topic has been closed to new replies.


About this Topic

Tags

No tags yet.