Forums

WP 2.6.1 old bugs and some more

  1. On my iPhone 3GS with iOS 4.1, both self-hosted and wordpress.com blog, app 2.6.1

    Can't post images. On wordpress.com they don't get added in the post at all (just

    ).
    On self-hosted blog the file can't be found when visiting the blog.
    Self-hosted blog uploaded image from latest app:
    http://www.nannica.se/wp-content/uploads/2010/10/20101014-213258.jpg

    Can't write in landscape mode

    The text "Tap here to begin writing" gets published if I don't write a text (have only-photos blog on wordpress.com)

    App crash randomly when publishing post

    -After re-insallting the app I get Communication Error (NSXMLParserErrorDomain error 4) on my self-hosted blog. Only when trying to reload the posts-page, publishing a new post works (but not adding media).

  2. Hi MissComaDoll --

    Thanks for all the feedback.

    Re: your WordPress.com blog -- I think you message got cut off "(just)". Could you continue explaining that issue a bit more ?

    Re" landscape -- what doesn't work for you exactly ?

    For your self-hosted blog, what version of WordPress are you running ? Where is it hosted ? And what's the URL of the site ?

    Thanks.

  3. after "just" i wrote:

    <br /> <br />

    When I try to write in landscape mode I can only see the fields for post-name, tags, category etc. and I can't scroll down to the entry-field.

    On my self-hosted blog I use version 3.0.1. It's hosted at a webhotel called Manufrog. The URL is: nannica.se

  4. Hey there, we're aware of the landscape issue and have a fix that will be pushed out in 2.6.2. For the crash on publish issue - does it seem to happen as soon as you hit Save or Publish, or does it seem to happen while that process is going on?

  5. I would say that it's very random. Sometimes when I hit Save, sometimes when I launch the app... mostly while some process is going on like Save, add media to post etc.

  6. For me the publish/crash issue happens when I have done a new post and without saving it I change the status to published, tap save, then it crashes without publishing.

  7. I've created a new post, A. With a pic on it.

    I've created a new post, B. I change the status to published, it crashed.

    Now the app shows the A post, with its actual content but with the post B's title.

  8. Having the same problem of carvay.

  9. Could all of you try a test for me? Could you go to your Settings app, open up the WordPress section, and turn off Autosaves, and then tell me if you see the same issue?

  10. @Chris Boyd

    Yes! That worked! No crash.

    It still has the future date issue but that is known. Hopefully that helps.

  11. Here we go :)

    1.- Change the configuration in Settings as required.

    2.- Create new post; put a short text on it and 'bum!', the app crashes.

    3.- Try to add a pic (from Library). 'Bum!'.

    4.- Try again with the same pic. 'Bum!' again.

    5.- Try with a pic I've used in a post yesterday; it's yet reduced (132Kb)

    6.- Post published.

    7.- Create post B. Click in 'Save'.

    8.- Try to add a pic (from Library). A different one. 'Bum!'. It crashes.

    9.- Try to add a pic (from Library). Yet a different one. 'Bum!'.

    10.- Just to give a try, I switch again the AutoSaves parameter to ON. 'Bum!' again.

    By the way, I have a iPhone 3GS and a self hosted Wordpress 3.0.1.

    If you need more info and/or more testing, just ask.

    How I miss just to take a look in some log files :)

  12. dsmasters - Sweet. Glad it's working for you. We'll have a fix for this in 2.6.2.

    carvay:

    2.- Create new post; put a short text on it and 'bum!', the app crashes.
    So the app crashes for you as soon as you type text in the content area? And this is with Autosaves off, correct?

  13. Yes, that's correct.

    I'll try again, just to make sure. So it can work well this time and we get mad :)

  14. Just to clarify I did not try any images or video. These are the steps that I went through that did not cause it to crash.

    1. Tapped icon for new post

    2. Entered Title, Category, and 2 sentences in body of post

    3. Clicked the save button to save it as a local draft

    4. Opened the draft of the post, selected "Published" under status and tapped "Save"

    This was on a WordPress.com blog.

    Unfortunately I just tried it on my WordPress blog that I host myself on 3.0.1 and it still crashes when I do the same steps above at step 3. This is at least a tiny step forward as it used to crash on both.

    Sorry for the false hope there.

  15. 1.- Delete posts A and B.

    2.- I still can see on iPhone both posts, as drafts *and* as post.

    Maybe all this needs a cleaning. I'm gonna recreate the profile, just to make sure there is no garbage over here.

  16. Well.

    I can create and publish the two posts without a problem. Without being 'Local Draft'. Just type and publish.

    After publishing I can add pics from Library, but there's something strange. I can add a pic in wathever size without problem, but with other pics I just can't. The app crashes.

    I can't figure out the logic of this.

    Anyway, I can post stuff if I type and post it without saving as Local Draft if the AutoSave in Settings is OFF.

    Hope it helps.

  17. 1.- Delete posts A and B. Put the Local Drafts as Drafts and delete them using the laptop. No traces of posts A neither B

    2.- That said, I see in my iPhone two Local Drafts (A and B) and four posts I've previously deleted: A, A, B and B.

    Maybe if I delete Wordpress from the iPhone and make a fresh install the cache will be perfectly clean.

  18. Nope :(

    I still see two local drafs (A and B), two versions of post A and B as drafts, and two more A and B as posts. Tell me about it :)

    None of them actually exist in the web served Wordpress, of course.

    Well, it's 1:38am here, and I have had enough poltergeist and too much lack of a log file, grep, tail and such.

    Let me know if you need me to do something. I'll be glad to help.

  19. I had something similar with these ghost drafts.

    I deleted my account in the iPhone app for my self hosted blog because all of a sudden it was telling me that the username and/or password were incorrect. After I manually killed the app and recreated the account the local draft from before was still there.

    For whatever reason deleting the account did not delete all the info from the account.

  20. I have a similar problem but obviously not quite the same. Whenever I save changes to a post in draft, the app doesn't crash, it just ignores them. This doesn't happen in Local Draft.

    I'm on a 3GS with version 2.6.2, autosave on or off, WP 3.01

Topic Closed

This topic has been closed to new replies.


About this Topic

Tags