Forums

Works over data but not WiFi

  1. I’m having an issue where the WordPress app will work fine over mobile data, but not over WiFi. The issue is not only at a specific WiFi location, but at all I have tried.

    On data, the app works as expected. However, on WiFi it will log on to the site, when you enter an area like “posts”, “pages”, or “media”, you will only see some of the items (I believe cached) and it will not load any new items. It just sits loading indefinitely. Switching off WiFi and a refresh immediately loads all the missing items.

  2. Hi there!

    This sounds like some sort of restriction on your WiFi connection if the app is working as expected when you navigate from data.

    If you try to navigate to WordPress.com from a desktop over the same connection, do you run into any issues there?

    What type of local network are you using? For example, are you in an office building or a cafe? You could try connecting from a different WiFi connection to see if the issues continue from other locations in the same way.

    I would suggest reaching out to your network provider to see if they can confirm any possible blocks that would be causing this.

    Thank you!

  3. Hi Rezzap,

    I have already tried over different WiFi connections from different ISPs with different router hardware. The results are the same. However, I should add that desktop connections to wordpress sites work perfectly.

    Here’s the really strange part. Using a web browser on the phone over WiFi works as expected. However the app has the issue as described in my first post. This leads me to believe the issue is not with the WiFi at all. Perhaps its a permissions issue with the app. But then its strange how its ok to create the accounts and log on to the sites, but has issues doing anything else. Does the app use different ports for this?

    Thanks,

    Darren

  4. Hi Darren,

    Can you share your site address with me and confirm how it is connected (self-hosted, Jetpack, WordPress.com)? Can you also confirm the version of the app you are using?

    If you're not comfortable sharing this in the forums feel free to reach out to us directly from the app under ME > Help & Support > Contact Us.

    Thank you!

  5. Hi Rezzap,

    All the sites are self-hosted and I am using ios app version 14.1. A couple of the sites where this happens are https://www.mrd-rc.com and https://www.meatfreecarnivore.com. Those sites are on the same host, but I have another on a different host which has the same result.

    Thanks,

    Darren

  6. I have noticed this in the logging, but it seems to be happening everywhere.

    2020-02-29 08:46:43:284 Failed updating plans: (null)
    2020-02-29 08:46:43:285 Failed checking domain credit for site
    https://www.mrd-rc.com:
      Error Domain=PlanService Code=0 "Unable to update plan prices.
        There is a problem with the supplied blog."
      UserInfo={NSLocalizedDescription=Unable to update plan prices.
        There is a problem with the supplied blog.}
  7. Hi Darren,

    Those errors are coming up because you are not connected to a WordPress.com account. It isn't part of the problem you are seeing.

    I did check both sites and I'm not seeing anything that would cause communication issues in the app. Self-hosted sites that are connected in the app do use XMLRPC to communicate with your site and maybe there is a security setting somewhere that is blocking this. It would explain why some functions work, but others fail.

    Do you use any security apps or have any plugins installed on your site that could cause this type of block?

    It would be great if you could send a full set of logs to us by reaching out through the app so we can troubleshoot further.

    To share the logs from your device, navigate to the Me section then "Help & Support". From there, tap "Application Log" and choose the clipboard icon to the upper right to copy the logs to your device's clipboard. You can then paste them in your reply under contact us with details or a link to this thread.

    Thank you!

  8. I also forgot to mention here that you should try updating your app to version 14.2 to see if that makes any difference.

    Thanks!

  9. I can confirm that this is an issue, as I cannot connect to either of my blogs when on WiFi, but can do so when I switch over to data. This is the only app that cannot connect to the same content using both connection methods. Confirmed on two devices using 14.4.1 on an iPhone 6S as well as iPad Pro. Have also attempted to connect over different WiFi connections to no avail.

  10. I can also confirm this is an issue for me (iOS 13.3.1, iPhone SE Wordpress iOS app version 14.5).

    When on WiFi I cannot sync or upload and the Wordpress app log indicates:

    Error Domain=WordPressKit.WordPressOrgXMLRPCApiError Code=0 "(null)" UserInfo={WordPressOrgXMLRPCApiErrorKeyStatusCode=429, WordPressOrgXMLRPCApiErrorKeyDataString=<html><body><h1>429 Too Many Requests</h1>
    You have sent too many requests in a given amount of time.
    </body></html>

    The server log shows the XML-RPC request arriving when the phone is on data, but does not show the request arriving at the server when the iPhone is on WiFi, i.e. the 429 error does not seem to be returned by my hosting server (Namecheap)..

  11. @bsouza thanks for including the error for your case. Since dmharris did not mention finding a 429 error, your case may actually sound similar but have a different root cause. In your case, it really does sound like the web server you are using is configured in a way that is not compatible with the app for some reason. In your case, are you able to post from a web browser on your device using WordPress.com/posts/{your-site-name} while connected via WiFi?

    An error such as a 429 is definitely returned by your web server, that's a web server error. What you'll want to try to find out though is why your server is returning a 429 error. Most likely, a 429 error is a security measure and sometimes web servers are configured with security settings that are too restrictive for an app or service and it's possible that's what's going on here. Have you contacted Namecheap already and they told you it's not a problem with the hosting after you described the problem? If you haven't already, would you mind contacting Namecheap and asking them what security measures are in place for your site's web server that could be triggering a 429 Too Many Requests error when trying to access the site back end using the official WordPress for Android app?

    I test our apps constantly as part of my work, and I haven't found any recent problems with posting over WiFi, although I haven't tested from a Namecheap-hosted web server.

    For anyone else experiencing this issue, it would be helpful to note the following:

    * Exact error message
    * Web host
    * Type of site (WP.com, Jetpack, Self-hosted with no Jetpack)
    * Are you able to post from WordPress.com/posts/YOUR_SITE_NAME while connected to WiFi?

    Thanks for including those details if you have already!

  12. > Are you able to post from WordPress.com/posts/YOUR_SITE_NAME while connected to WiFi?

    This is for WordPress.com or Jetpack sites.

    For a self-hosted site without Jetpack, you would want to check from YOUR_SITE_NAME/wp-admin/edit.php.

  13. Hi,

    Thanks for your response designsimply. I spent about an hour in chat with Namecheap. Eventually they said that they don't specifically limit xmlrpc, but they do limit HTTP requests in general. And in fact I can generate a 429 response by accessing /xml-rpc.php URL repeatedly from a browser. Sometimes. They seem to do the rate limiting per-url, and perhaps per (url, ip).

    Posting from a browser works fine via either the self-hosted url or via wordpress.com if I enable jetpack.
    Posting from a the Wordpress Windows app works fine.

    From the iPhone app (on iOS, not Android) I can only sync my posts if I turn off WiFi. And I cannot post at all.

    The app used to work on this website some time ago (sorry, I don't have a more specific timeframe, but it was pre-Gutenberg), but I didn't use it much. The app makes more sense for me with the richness of Gutenberg, so I thought I would give it a try.

    The site is https://shepherdspantry.net and Wordpress is installed in a subdirectory; perhaps that matters.

  14. Thanks for the extra detail! I'll look into it to see what else I can find out!

  15. Following up, it appears that some hosts have strict security rules in place that could block normal usage by the app. The best thing to do in this case is to contact your web host, explain the problem, and ask if it would be possible to relax the security rule in a way that's still secure but also allows the app to work.

    When talking with your web host, some good information you can provide is:

    - steps to reproduce the problem
    - web server logs from a time when the problem was happening
    - details such as the problem only happening over WiFi and when using an app (in other words, note whether the app works normally over a data connection and whether posting works normally in a mobile web browser separate from the app)
    - note that the XMLRPC API is used by the WP mobile apps to communicate with a WordPress self-hosted site and a normal security limit for other cases may be too strict for this use case

    The following quote is from 2016 but still applies:

    We must query the XMLRPC API for a bunch of things to get infos and make the app work. This is not an issue with the app, it's an issue with your host. Ask them to update their firewall configuration and be less strict.

    On a 5 minutes sample with and excessive usage (moderated and then deleted a bunch of comments), it's around ~40 requests/minute. So tell them 100 requests/minute, I don't think you can ever hit that with a normal usage of the app.

    Source: https://github.com/wordpress-mobile/WordPress-Android/issues/4494#issuecomment-262173052

    And this issue describes a similar problem which they traced back to a strict ModSecurity rule on the server side and shows an example of one type of web server logs to look for:

    https://github.com/wordpress-mobile/WordPress-Android/issues/11424

Leave a Reply

You must log in to post.


About this Topic