Forums

Wordpress App for Ipad

  1. My issue is whenever I edit or publish a post it says fail but it still publish and saves what I edit. Why is this happening. I delated the app and reinstall it. And also when Ever I try to put a feature image it crushes. When I use a keyboard and try to put an image it crushes. Thanks for the help

  2. Hi

    My issue is whenever I edit or publish a post it says fail but it still publish and saves what I edit

    There is another thread where we've been discussing this issue over here:
    https://ios.forums.wordpress.org/topic/media-upload-failure-and-not-posting/page/2?replies=43#post-13386

    also when Ever I try to put a feature image it crushes. When I use a keyboard and try to put an image it crushes

    I don't recall hearing about this before. If you're prompted to send crash reports, please do so we can take a look at them. Something else you might do is go to Me > Settings > Support and enable Extra Debug. After doing this, try to post another featured image to recreate the crash. With that done, go to Me > Settings > Support > Activity Logs and send us the most recent logs. You can email them to "mobile+support at automattic dot com", and please mention this forum thread in the email. This will help us troubleshoot and fix the cause of the crash.

    Thanks!

  3. Here is an excerpt of the Extra Debug. I have the same issue.

    It is at the very end "2015/02/11 16:28:13:304 post failed: Ung├╝ltige Anhang-ID."
    It does only occur when saving articles, not pages.
    It does only occur using one specific blog, it does not occur with all blogs.
    WP Version: 4.1 (on all blogs)
    iOS Version: 8.1.3 on iphone6
    WP-App Version: 4.7.1

    If appreciate any help.
    Thnx in advance,
    Knut
    LiveKnut<at>gmx.de

    0x13d62ad20> savePost:
    2015/02/11 16:28:11:458 Copying attribute author
    2015/02/11 16:28:11:458 Copying attribute content
    2015/02/11 16:28:11:458 Copying attribute date_created_gmt
    2015/02/11 16:28:11:458 Copying attribute mt_excerpt
    2015/02/11 16:28:11:458 Copying attribute mt_text_more
    2015/02/11 16:28:11:458 Copying attribute password
    2015/02/11 16:28:11:458 Copying attribute permaLink
    2015/02/11 16:28:11:458 Copying attribute postID
    2015/02/11 16:28:11:458 Copying attribute postTitle
    2015/02/11 16:28:11:458 Copying attribute post_thumbnail
    2015/02/11 16:28:11:458 Copying attribute remoteStatusNumber
    2015/02/11 16:28:11:458 Copying attribute status
    2015/02/11 16:28:11:458 Copying attribute wp_slug
    2015/02/11 16:28:11:458 Copying attribute authorAvatarURL
    2015/02/11 16:28:11:458 Copying attribute geolocation
    2015/02/11 16:28:11:458 Copying attribute latitudeID
    2015/02/11 16:28:11:458 Copying attribute longitudeID
    2015/02/11 16:28:11:459 Copying attribute postFormat
    2015/02/11 16:28:11:459 Copying attribute publicID
    2015/02/11 16:28:11:459 Copying attribute tags
    2015/02/11 16:28:11:459 Copying relationship blog
    2015/02/11 16:28:11:459 Skipping relationship original
    2015/02/11 16:28:11:459 Skipping relationship revision
    2015/02/11 16:28:11:459 Copying relationship comments
    2015/02/11 16:28:11:459 Copying relationship media
    2015/02/11 16:28:11:459 Copying relationship categories
    2015/02/11 16:28:13:304 post failed: Ung├╝ltige Anhang-ID.
    2015/02/11 16:29:28:040 <WordPressAppDelegate: 0x1740d8e90> applicationWillResignActive:
    2015/02/11 16:29:28:075 <WordPressAppDelegate: 0x1740d8e90> applicationDidEnterBackground:
    2015/02/11 16:31:21:309 <WordPressAppDelegate: 0x1740d8e90> applicationWillEnterForeground:
    2015/02/11 16:31:21:779 <WordPressAppDelegate: 0x1740d8e90> applicationDidBecomeActive:
    2015/02/11 16:31:21:786 View is not visible and will not check for auto refresh.

  4. Hi Knut,

    That looks like this issue which should be fixed in version 4.8:
    https://github.com/wordpress-mobile/WordPress-iOS/issues/3045#issuecomment-72886461

    If the post that is failing has a featured image, you might try removing it, publishing your edits, then adding the image back. That should work until the new version is released.

    Hope this helps.

  5. Hello Eric,
    I just emailed my Activity Log to the address you listed above b/c I'm having a similar issue with the WordPress app crashing on me on my iPad whenever I try to add a featured image to my blog posts. I have the new version. Please help! Thank you.

  6. Thanks @mona0419. I'll keep an eye out for it.

  7. Hi @mona0419

    I received your log. It doesn't tell me the exact cause of the crash but it does look like you were trying to add an image to a post from a photo stream. Images in your photo stream are stored on Apple's iCloud service. Currently the app only supports adding an image that's stored locally on your device. You might try saving the image to your phone first, then adding it to your post. Apple's Photo Stream FAQ might be helpful. https://support.apple.com/en-us/HT201317

    Hope this helps!

  8. Hello
    I'm posting here as I have the same issue : app crash when I try to upload photos. I've just sent the log to the address mentionned above.
    What is strange is that it's working fine with my iphone 5s (up to date for ios and wordpress app as well)...

  9. OK when I check the log I might know why : I import raw files from my camera to my ipad, I was sure it was converted to jpeg but it seems not. When I try on my iphone, the photos have been synched threw the photo stream and I guess this is jpegs.
    I tried to import from the ipad from the photo stream and not the album and there it worked...

Topic Closed

This topic has been closed to new replies.


About this Topic