Forums

What happened to the photo uploading? No size selector!

  1. I see that easier/quicker insertion was part of the recent update, but we can no longer see the media attached to posts nor do we get the size selector! This is not good. We're these items meant to be deleted?

    I like all my pics (generally) to be 500 wide so that was my default setting. But sometimes I want the square thumbnail and I see no way to do that now.

  2. I just tested it and it uploaded an 1878x2688 iphone photo as 364x500--when with the old system, it would have let me choose and I would have selected 500 width so it would have uploaded at 500x750.

    I haven't touched the "image quality" setting which has always been on Large for me.

  3. Same here. I too am missing the photo image size selector. I like to have diff wend sizes of pictures in my posts. I have to use other apps such as blogsy for this now

  4. Hi,

    Now you need to go to the main page, select Settings and the MEDIA>Image quality and choose from small/medium/large and original size.

    The sizes are decided inside the blog, to setting/media settings.

    Anyway, I agree it was better before, because it was faster to change from one size to another, mostly for who upload pictures all the time like me.

    Since this update I don't find the video upload anymore. Do you?

  5. My Large is set at "max width 500/max height 0" (because I always want it to be 500 wide no matter the height) but it didn't do that...it uploaded with a max 500 height.

    I guess I get to experiment now.

  6. So I changed it to max width 500/max height 2000 (just to be safe) and it still didn't work.

    I uploaded two iPhone photos. One it uploaded at 501x360 and the other it uploaded as 480x360. Granted the pics were different sizes to start, but the width should have been the same on both. And one was OVER my max listed...?

    GRRRR.

    So I changed it to a max height of 3000 (just for sh!ts and giggles) and this time, with the pics uploaded in the same exact order, it reversed the sizes--the first one was 480x360 and the second one was 501x360.

    And uploading a perfectly square photo--so it should have NO issue with figuring sizes--uploaded at 360x360.

    In case my high max height was throwing things off, I changed it to max height of 750. It still uploaded at 360x360.

    So I changed the max height to 500...and it still uploaded at 360x360.

    This is useless. I do at least 75% of my blogging from my phone--with pictures--and this just doesn't cut it.

  7. So I changed the media settings to max width 1000/max height 3000...and I STILL can't get photos to upload the correct size.

    Photo one (square) uploaded at 480x480.
    Photo two (vertical) uploaded at 364x500.
    Photo three (hotizontal) uploaded at 500x375 (finally the right size, but it should have been 1000 wide!)

  8. WendyTheWanderer
    Member
    May 19, 2014, 4:14 PM

    Also, the app no longer lets me add pics above the content. Gee, thanks for the awful update WP :-( Everything about adding pictures is a mess.

  9. You were able to do that at one point? I've never been able to add pics where the cursor was...it always added them at the bottom.

  10. WendyTheWanderer
    Member
    May 19, 2014, 4:21 PM

    There used to be a list of photos uploaded. If you clicked on one pic, it would let you put it at the top. I hate that we can't go back and randomly insert pics in the text! I used to do that on my laptop. Now I only blog on my iPhone.

  11. Ahhh. It still works that way on the laptop (which I do use sometimes).

  12. Davide Roccato
    Member
    May 20, 2014, 1:01 PM

    That's very weird, have you tried to delete the wordpress app and install it again? Or at least, delete it from the multitasking after you changed the media settings sizes inside the blog? Maybe the data are not properly updated inside the app.

    I have the large images fixed at 1000x1000px and it's working fine.

  13. New testing after force quitting the app, still using max width 500 (medium) and max width 1200 (large). Max height was set on both at 9999.

    Large:
    - A vertical photo uploaded at 375x500.
    - A horizontal photo uploaded at 500x281.

    Medium:
    - A vertical photo uploaded at 360x480.
    - A horizontal photo uploaded at 580x326.

    FAIL.

    I will next try deleting and reinstalling the app, even though it shouldn't be necessary...AND because it worked PERFECTLY before it was "enhanced."

  14. Interesting sidenote... If I go to Settings > Media, I apparently have a plugin called FancyBox running (The options in this section are provided by the plugin Easy FancyBox and determine the Media Lightbox overlay appearance and behaviour controlled by FancyBox.)

    I was trying to turn off everything photo related in case that was causing any issues. HOWEVER, even though it says it's a plugin and it's definitely appearing on the media page, it doesn't appear anywhere in my Active plugins (or my deactive plugins for that matter). WTF?

    It would make it seem like FancyBox is part of WP, then, and not a plugin?

    I'm so confused. But I can't get rid of it, so I will continue with my testing.

  15. Deleted app, rebooted phone, reinstalled app...and (EDITED) it looks like some of it is fixed...but some is not.

    Medium (500wx9999h):
    - A vertical photo uploaded at 375x500.
    - A horizontal photo uploaded at 500x281 (correct).
    - A square photo uploaded at 500x500 (correct).

    Large (1200w x 9999h):
    - A vertical photo uploaded at 900x1200.
    - A horizontal photo uploaded at 1200x900 then it scaled for my column width (correct).

    It seems that the vertical photos are the ones with issues as it's not accepting the assigned max width and is instead forcing the max height as the width.

    It "just worked" before so this is just soooo frustrating.

  16. Davide Roccato
    Member
    May 20, 2014, 4:32 PM

    Well, it's already better than before I suppose. I don't know what this fancybox is, I don't have it in wp.com or in wordpress self hosted. It might be part of another plugin you have that might interfere with the media library.

    Or maybe the height doesn't work well but I'm not sure it depends on the app. Have you uploaded a vertical picture with your computer using the large option to see if it cuts the picture there too? In that case you would know it's not the app in this case.

  17. I've never ever used the Large/Medium uploading via the computer. I always resize them first out of habit (from my last pre-WP blog where I had to do it). I guess I need to look into that to check it out.

  18. I looked and don't quickly see anywhere of how to do it. I'm self-hosted as well. I just click New Post > Add Media button > Upload Files/Select Files ... which opens up a folder on my hard drive and it uploads whatever size the photo is -there's no resizing and there's no me selecting what size.

    I guess I can live with the vertical pictures as they are, but damn it's annoying since IT WORKED FINE BEFORE.

  19. Davide Roccato
    Member
    May 20, 2014, 4:58 PM

    when you drag and drop the picture in a post, you'll have the box of the media library opening. On the right there will be all the selection. When the picture finishes to upload, it will appear a small box for the size, at the right bottom, below the LINK TO option. There you can choose the size, full or small/medium/large. And you will see the settings.

    Also, if I'm not wrong, you have to untick the (Crop thumbnail to exact dimensions (normally thumbnails are proportional)) option, if you want to insert the 0 parameter for the height.

  20. Ahhh. I've never used drag and drop--I don't even use the visual tab. I dislike change so I never thought to try any other method! I'll have to try it soon (if only to figure out whether my issue is app-related).

  21. Okay, I used the Visual tab and dragged in a picture. I got excited for a minute because the thumbnail and large sizes were correct (i.e. matched what I told it to on the Media Uploads Settings page) - 150x150 for thumbnail and 500x666 for medium...but large was wrong at 600x800...?!?!?

    Also, I remember why I only upload already resized photos--I don't need to waste space with a 2MB 2400x3600 picture when a 500x666 will do.

    So, it looks like the app might be the problem...though the drag/drop upload sizes are still wrong...so who knows.

  22. Davide Roccato
    Member
    May 20, 2014, 5:16 PM

    hmm, weird. the sizes should be the same for all of them.

  23. IMGUR links for what I'm seeing, just so you know I'm not crazy (I couldn't get them to inline):

    http://imgur.com/eOuQQuM
    http://imgur.com/h0dnYZJ

  24. Davide Roccato
    Member
    May 20, 2014, 5:40 PM

    I know you're not crazy but unfortunately I don't know how to help you further. Maybe try emptying the cache but I'm not sure it's gonna help, but you can give it a try. The cache of you blog, and then the cache of your browser and reload the browser before trying again. If it's not fixed maybe there's some plugin that interfere with the media library but I don't want to give you misleading information because I'm not sure. I hope you'll fix it.

  25. I appreciate the help. I'm just hoping that the app goes back to the way it was because it was perfect.

  26. Davide Roccato
    Member
    May 20, 2014, 6:23 PM

    yes, I'm surprised by this change too. And I don't know why they took away the possibility to upload videos. :S

  27. Well, I found where the FancyBox plugin was--it was under Network plugins and not the individual blog plugins--and deactivated it. I tried my uploads again.

    At medium settings (500w x 9999h):

    1. a horizontal pic was uploaded at 500px × 375px (correct)
    2. a vertical pic was uploaded at 375px × 500px

    So the same results as yesterday. Horizontal works, vertical doesn't.

  28. I've cross-posted a similar but updated topic here: Media Settings sizes don't correlate to actual sizes uploaded

  29. Hi folks.

    I’ve mentioned in other threads that the team was working on some improvements to media (images and video) in the post editor.

    We’d planned to release a completely revamped media feature in version 4.1. The changes would let you pick from all of the media on your phone as well as what was uploaded to your blog. There would include the ability to edit some of an image’s meta information, and include improvements to sizing and placement.

    I’m really sorry to say that things did not work out the way we’d planned. Some very talented folks spent a lot of time working on the improvements, but when it came time to add them into the app, things just weren’t where the team felt they needed to be. This was a big disappointment for us and we had to make some tough decisions about how to proceed.

    We decided to begin rolling out the improvements we could rather than no improvements at all. This was a tough call to make because it meant that some existing functionality, like the list of media attached to a post, would have to be removed as it was incompatible with the new code.

    What I can say is that we’ve laid the ground work for some very significant improvements related to media, and you should see the changes happening over the next few releases of the app.

    In the meantime we really appreciate hearing your feedback about how things currently stand. This helps us know what to focus on.

    We know this was a disruptive change, and we understand your frustration. We're working to quickly smooth out the rough spots.

  30. Davide Roccato
    Member
    May 30, 2014, 7:30 AM

    Thank you Eric for the update. Well, we hope you will be able to get things done using the new solutions you're trying to find. Media are quite important and Mobile apps even more and more.

    I'm trying to go the most Mobile I can and also trying to waste less time possible in doing it but it's not so easy yet and this could lead to prefer one platform rather than another for a lot of people I guess.

    So, keep it up, and I hope the updates will come out soon. Thanks.

Topic Closed

This topic has been closed to new replies.


About this Topic