Forums

Video showing up as sad grey box

  1. nattybumpercar
    Member
    Oct 13, 2010, 2:00 PM

    I was super-thrilled last night when I got 2.6.1 - and it let me jump right onto my blog. So - the first thing that I did was to make a tiny video. Everything worked well - I switched the AtomPub on in settings - and everything worked great.

    The video was on my site - played great in Chrome and Safari - - - BUT - - - showed up as a grey box in Firefox and as a big block of nothing in Explorer . . .

    What can I do to make sure that my little video shows up on all browsers?!

    Also - on a side note - thanks very much for all of your hard work on this app . . . it makes my little blogging life at least four times more fun.

    Seriously!

    http://www.nattybumpercar.com

  2. Glad to hear you're enjoying the new version! In 2.6.1 we decided to use the HTML 5 <video> tag for video content. This is currently not supported by Firefox.

    You could try editing the content of the post and removing the video tag and replacing it with something like this: http://www.w3schools.com/media/media_quicktime.asp

    For 2.6.2 we may decide to give the user the option of switching between the HTML 5 tag and the older embded/object tags.

  3. Giving users the option of using HTML 5 tags or the older embed tags would be a great feature to have for cross-browser compatibility. Having to edit HTML tags in a mobile app just doesn't seem like a very efficient way to get videos to display in non-HTML 5 capable browsers.

    Have you considered an option that would display the proper variant of content based on browser detection? Not knowing what would be involved with that, I don't know if it would even be possible for Wordpress, but the new version of Slideshow Pro Director does just that.

    A video can be uploaded and Director generates HTML (which can be pasted anywhere like a YouTube embed code) that will display either a Flash based player for computers or an HTML 5 player for mobile devices based on browser detection. It works great! The only caveat is that your video needs to be encoded as an H.264 MP4. It works amazingly well pasting into Wordpress posts.

    Too much info probably for the topic, but my point is that there are alot of people who will be using non-HTML 5 capable browsers for a very long time, and having to edit the HTML tags on an iPhone might not be the best solution. Just a thought..... :-)

  4. Yes, same as above, I was way excited to start using the Wordpress app to easily start uploading videos to my blog but then sad that they don't work in Firefox. It would be awesome if the next upgrade has the option to use embed tags.

    I too LOVE using the app to post to my blog! Thanks and keep up the great work.

  5. I'm still having trouble with this exact same issue, but am obviously on the newest released ios Wordpress app as this is 8 months later. Am I doing something wrong? Grey box with x only in Firefox, works fine in Safari, etc.

    Any help greatly appreciated!

  6. FYI, I just stumbled upon this plugin which completely fixed the problem after installing and activating:

    http://wordpress.org/extend/plugins/media-element-html5-video-and-audio-player/faq/

Topic Closed

This topic has been closed to new replies.


About this Topic

Tags