Forums

Ver 2.1 won't save changes on Local Drafts

  1. I can create a new local draft fine. But, when I later edit it, the changes I make on the draft (text) can't be saved. But, it is inconsistent. Sometimes it's saved. To bypass the issue, I have to copy all the text to clipboard in case the change isn't saved. I use iPhone 3G with OS 3.1.1. WordPress app is version 2.1.

  2. I can vouch for this too. Consistently occurs. First time you save it works fine. If you exit the view, go back into the post and make a change and save again, all your changes are lost.

    I have been saving as a remote draft to deal with this issue. Kind of frustrating :(

  3. Same here. For me, it seems that I'm only able to sync Draft versioned posts. Local drafts have problems. And once I published the posts, I won't be able to see the content of the post anymore.

    And if I happened to first open a draft post, then try to open another published post, it would show me the content of the draft post. Totally weird!

    And It's even weirder because I've two blogs configured in the iphone app and both blogs are running on wordpress v2.9.

    The other blog works fine. I can save local drafts, view both web drafts and published posts....

    Does anyone else here who have this problem have more than one blog configured to the iPhone app too?

  4. I have not been able to reproduce this. Is the phone jailbroken by any chance ?

  5. My iPhone is fully legit and I have this issue. If it's related I received a call whilst writing the blog and it lost all the information I had written. Occasionally it would also offer to view a recovered version of the blog post which was just like the old unedited post.

  6. We've had several people tell us about this problem, but unfortunately we can't reproduce the error ourselves.

    Spencee - if you haven't tried it, try deleting and reinstalling the app. If you can reproduce the error after a re-install of the app, please post back and I'll try to troubleshoot with you.

  7. hello,

    i've experienced this bug as well.

    i'm on an iphone 3gs, app v2.1

    here are my repro steps :

    1. from the wordpress app, create a new post.
    2. save the post
    3. open the post
    4. edit the post
    5. save the post again
    6. hit the sync button (auto sync will cause the problem too)
    7. open the post. edits from step 4 will be lost

  8. Thank you for that precise description. Was this a local draft that you saved or did you set it to publish in step 2?

  9. I have the same poblems... but I FIX IT deleting my site at the aplication and setup againt without usin the http autentification...

    I have test with the wp v 2.7 and 2.9 and is working fine :) but DONĀ“T use the http autentification...

  10. I just lost a huge post due to this bug. Here is what I did:

    1. Entered title, tags, and about 1 para of text.
    2. Clicked save, and the state was set to local draft.
    3. Exited Wordpress for iPhone 2.1 and opened Safari to copy some text.
    4. Returned to my draft post, pasted text, and wrote quite a bit more.
    5. Clicked Save (still as local draft)
    6. Clicked Preview and saw that the pos now included only my 1st paragraph!

    This isn't the first time this has happened to me when trying to write on my iPhone, and so I'll probably be deleting the app do I don't get bitten again.

  11. Thanks for the clear description Mike - I'll reproduce that series of steps and let you know what I find.

    The way I read your post, it seems that the post was never saved to the blog, but that the text you added after the first save was lost when you went to Preview, yes? I just tested and it seems that a long paragraph disappears to the right on the preview if it's a local draft... I just want to make sure the text was missing from the edit page when you went back...?

    I assume that when you went back to the edit view, the additional text was gone from there as well?

    Naturally we're sorry for the error and understand the frustration of losing an important post.

  12. The first save I made was as a local draft. Then I edited the post some more and saved again as a local draft. Hoping that maybe it was just a display bug, I then tried to publish the post even though it was only displaying one paragraph in the iPhone app. When I checked the post on my blog, I found that it only published one paragraph.

    Thanks for looking into this.

  13. Just to be sure.. What version of WP for iPhone and what version of iPhone OS?

    Can you reproduce this on a wordpress.com blog? (make one with a nonsense name and give it a try if you are willing to test...)

  14. iPhone OS 3.1.2
    Wordpress (app) 2.1

    I uninstalled the other night, but noticed there is a version 2.2 in the app store now. Maybe will give this a try.

  15. I managed to write a lengthy post in Wordpress 2.2 tonight with multiple saves to local draft, then finally publishing. I can't confirm that this bug is totally squashed, but it looks better than my last attempts.

  16. Mike- thanks for keeping us updated...

    I believe I've just identified a bug with behavior similar to your description. It happens when the more tag is included. Can you remember if you were using the more tag when these problems occured?

  17. How can I get back a very long blog I wrote the other day? Please help.

    Thanks

  18. There is a post on this forum about getting things out of the backup on iTunes. Doesn't always work. Depends on if you saved the blank post (if so, it's probably lost) Try searching for itunes + iphone or recovery + iphone...

    It's some work and you have to go digging into backup files. We're naturally very sorry for this bug and it's resolved in the latest release...

  19. unbelievable...I am joe from the u.k..i was in africa years ago on a business trip and i met a
    great spell cater that helped me out in getting my love back..my love came to me and told me that she is no longer interested a week to our marriage..i tried all my best to make her stay but she just wanna leave..her parents not in support as well..i explained what i was passing through to this man and he cast a spell for me which i was skeptical about and just gave it as trial..after 7days,my love called and apologized..Now we happily married for years now with kids..people with similar problem can contact the spell caster on adebisidamy@yahoo.co.uk .....good luck

  20. How do you create a new local draft fine ? I want to do it . But I didn't know how do it ? Please tell me ! I hope I can create it to show for my friend . Thank you very much !!!

    _________________________________
    laptop acer

  21. I am having same problem. I create a new post and it is saved as local draft. It does not show up when I go to my wordpress site.

  22. Now I see the problem (at least for my problem). For status there is draft and then there is local draft. If you make it draft then it shows up in your wordpress site as such. Local draft is only stored on the iPad or iPhone. My biggest question is when will there be an iPad version that perhaps offers a bit more function.

Topic Closed

This topic has been closed to new replies.


About this Topic

Tags