How to enable XML-RPC

  1. XML-RPC access is required in order for the app to acces your blog. Here's how you enable it:

    1. Go to your blog and log in (/wp-admin).
    2. In the sidebar, open Settings and then select Writing.
    3. Under Remote Publishing, check to make sure the XML-RPC protocol is enabled. If it's not, please enable it.
    4. Click Save Changes at the bottom of the page.

    Hopefully this should resolve your issues, let us know if not - we're working on making this experience better from within the app.

    * When adding your blog, please only use the root URL (don't apply /wp-admin).
    * JordanC has posted few more useful tips if you're experiencing problems like this.

  2. laurenpolinsky
    Dec 17, 2010, 5:21 PM

    I've clicked the XML-RPC button on my admin and I still can't log in with the app. How long should I wait for this to work?

  3. Hey folks

    thought I would throw my 2 cents in since I was whining earlier. My solution was born of reading through these forums and also by contacting my webhost.

    I was getting the XML-RPC error like many, or the thing would just hang up forever.

    After some reading from here and there I decided to try to make sure my xmlrpc was accessible. I ultimately went to my control panel on my web-host and added a .htaccess file to my WP directory.

    on the .htaccess file I used (with the assistance of the webhost)

    <IfModule mod_security.c>
    SecFilterRemove 114

    saved it then retried the app on both my iPhone4 and my iPad (both using latest IOS)

    bear in mind, I am using a default upload of wordpress to my own server and it was installed to the root directory.

    I entered in the following:

    site: ( DID NOT ADD wp-admin)

    I clicked and it did its thing quickly and boom, it said good to go

    I then hit add blog and viola, there it is.

    Now, I have yet to USE it, but I can see my blog and I can see the posts and all that jazz on both my iPhone and iPad.

    So there is my take on the problems and I hope it helps someone!!


  4. @laurenpolinsky Please try upgrading to 2.6.3 if you haven't already, post in the forums if this doesn't fix your login issues still.

    @jpme226 Thanks again for sharing your experiences!

  5. What about for those of us with .com blogs instead of .org? Same error message. Any ideas?

    Dec 31, 2010, 4:36 PM

    I am managing several self-hosted blogs.

    I too got the XML-RPC error. on one I just setup yesterday.
    The resolution for me was to (on the wordpress for Iphone app)

    PRESUMING firstly, that you have enabled XML-RPC remote publishing in the blog's control panel, then:
    Just use the URL to the root of the wordpress install (the same address a user would enter to see the blog, I DID NOT ADD THE /wp-admin, etc onto the URL)

    Then when I tried to activate it, it gave me the XML-RPC error. so I simply appended the relevant file's name to that same path, and pasted that into the XML-RPC field.


    I hope this helps.

  7. Just installed 264 and same issue 

    264 still producesberror

    I Enter blog URL user and pwd (xmlrpc is checked)

    Autheticate says ready to go and then BAD USERNAME OR PASSWORD

    I have not been able to use thus app now for months and at least the last three "updates"

    I feel like Charlie Brown hoping to kick the football

    This the worst brand experience with wordpress

    Please get it right or just stop as it's getting embarassing

  8. yeah, I just downloaded the last version, with all the bugfixes, for my iPad. But still the same annoying error: bad username/password

    I had hoped the load of bugfixes had all this fixed....

    Yes, I have all settings correct.....

  9. I downloaded latest version few hours ago - still could not upload images. Then deleted the app, loaded fresh copy and now I cannot register my self hosted blog.... Cannot autheticate...

  10. Sorry -iPhone...

  11. This is one app I would gladly pay for if I could get it to work.

    I have a blog hosted on Powweb. I have the latest version of wordpress installed.
    I have wordpress > Settings > Writing XML-RPC Enabled (I do not have Atom Pub Protcol enabled)

    From the APP Welcome screen I select Add self-hosted WordPress blog

    username: myusername
    password: mypassword

    Select enter and it tries to Authenicate

    Error Code: XML-RPC Error 500 internal server error

    Any help would be appreciated.

  12. my blog is hosted on wordpress (so it's a .com)
    I had to change my password so I went and changed it on my iPhone too. It all seemed to work fine, updated password, saved and all, but when I tried to log in I too got the Bad password... etc message.
    I checked my settings again and realized that the app had NOT saved the new password but was again stuck with the old one.
    I tried everything, deleted the app from phone and iTunes downloaded it again, reinstalled it numerous times (this should clear all previous data?) but every single time I try to write the new password it looks like it has been changed but, mysteriously, always end up going back to the old one (where is that stored?! how do I get rid of it?)

    helpp please, this is driving me mad!

  13. I have 5 .org WP sites. I use the app for 3 of them. I am having trouble with one of the three. I'd like to help debug this problem. I am an expert level programmer.

    I tried several of the suggested work arounds:
    set wp-content and all subdirectories and files to permission 777
    deleted and reinstalled the app
    set atom and xml-rpc on

    None of those work. I have reinstated my permissions to their correct level of 755.

    I have notices some interesting things. When I go into the app and change site settings, it does correctly authenticate on the one site that has the problem. It is not until it gets to the listing of all the sites that the "Communication Error" shows up.

    I am currently looking for any differences between the sites that would account for this. .htaccess for all three sites are identical - which rules that out. I next plan on doing a survey of my plugins. Either one is assumed to be there by the app or one is possibly causing the block. It wouldn't be the first time a plugin screwed up something. Oddly the site that is not functioning with the app has the least number of widgets and plugins on it.

    If you want me to be part of the beta I would be glad to help. I'd like to get this issue resolved since its annoying to a lot of folks and seems to be intermittent. I also love a challenge.

  14. I may have the answer to the problem. In experimenting I found that changing my password made the app work with the site it wasn't working with. The password had a non-alphanum in it. While it authenticated fine while setting up the site for the app, outside of setup it failed. Therefore, I would guess, your encoding of characters in passwords that are not alphanums might be problematic - either they are encoded wrong or they are not encoded and being interpreted wrong.

  15. I'm on -- the iPhone app both loaded my blogs and displayed blog posts, whereas the iPad app loaded the blogs, but gave me the invalid username/password when I attempted to display blog posts.

    I've uninstalled and reinstalled Wordpress on my iPad innumerable times, but nothing seems to help...

  16. @catknelson -- did you change your password recently? after the installation of the app on your iPad?

  17. I have a self hosted multi blog network with 4 blogs. 2 of them required a registration to view (using plugin "Authenticator"). I experienced the XML-RPC error since I installed the app in July 2010, but it seams to have no impact. The error message pops up, I click okay and then everything works fine.

    After I have updated the app to 2.6.6 I couldn't add a new blog with registration requirement. When I entered the URL of the blog it redirects to the login-page automatically and the authentication failed.

    I just tried to put in the XML-RPC manually as described by saskatoonie:

    username: myusername
    password: mypassword

    And now it works. I can add posts and so, but as before I get the error message when starting the app.

    Hope that info may help with the troubleshooting.

  18. I experienced the login issue on my wordpress.COM blog as well, but with my co-writers (for myself it was working fine on the Mac & iOS).

    I had to change their account role to at least "Author" (have it on "Editor" now and works as well).

  19. Never blogged before. On a trip, and my family requested I do that blog thing so they could follow along. Downloaded wordpress for ipad, setup my account (free hosting on and made my first posting yesterday no problems. Now, I cannot make another! Get an 'unable - check your user settings' error. Followed the FAQ link, updated my settings>writing> switched on the only thing on that page remotely mentioning XML, saved. Logged out of the site, quit the app. Went back in - same thing.

    Is THIS what bloging is about? Hours and hours of tech -trouble shooting - just trying to post simple trip updates?


  20. Thank you so much for the post it worked.

Topic Closed

This topic has been closed to new replies.

About this Topic