Forums

Upload fialed: Request Failed: request too large (413)

  1. I had an iPhone 4s and tried using this app and alqways hadd issues with uploading images, so I gave up trying and deleted the app. I now have an iPhone 5C and downloaded and upgraded to the latest version of the app. Just writing my first post using the app again and low and behold I get the same problem when trying to add images.

    I click on the image icon, select images from my camera roll. the first two images upload and then I get the follwoing error:

    Upload fialed: Request Failed: request too large (413)

    I keep trying to add images but no more images can be added, so I delete all images and try again and then no images will upload at all.

    I have no idea why this is happening, but this renders the app completely useless again and it's so irritating as I'd love to be able to update my blog on my iPhone but without being able to add images there's no point even trying.

    I've searched the forum and not found anything similar.

    Can anyone help me out here as I'd love to be able to get this app to work.

    Also when Ido add image the app automatically make them a link - is there anyway around this as I always have to spend ages selecting and deleting the tags.

  2. any new news at all on photo uploading problems?

  3. i haven't been able to update my site regularly since May. the app worked for about half a day about a month ago and now it's back to its old tricks

  4. @milomade
    Have you tried increasing the memory available to your blog as described in the FAQ?
    https://apps.wordpress.org/support/#faq-ios-6

  5. I have problems too since we can not set the image size, now it uploads full size images which takes ages :(

    Will you bring the size selector back?

    Thank you.

  6. @ Ricard Torres

    Its possible that we'll reintroduce a custom size selector at some point, for now you can upload a smaller image by selecting the Me tab, choosing Settings and switching on Optimize Images.

  7. I do have that switch turned on, still it uploads large images. I guess not as large as the original size.

    Thanks.

  8. I do have that switch turned on, still it uploads large images.

    exact same situation with me. still no solutions

  9. @Ricard Torres What size (width x height) are the images once they are uploaded? With optimization enabled they should never be larger than 2048 x 2048.

  10. the test image i have been trying stays at 2048 by 1536 - still HUGE.

  11. You're right Eric, the images are around 1936x1936, I guess the problem is they weight 1.4MB, which is too much when browsing via mobile.

  12. , I guess the problem is they weight 1.4MB, which is too much when browsing via mobile.

    Good point.

  13. do i need to start a new post to get some info on why i still can't upload photos to my website using this app?

    how do i get the images to be the right size? the app should make this easy, shouldn't it? so we don't have to retake and resize and then upload?

    i've been having people ask me why i haven't updated in months - i really need some sort of solution

  14. @dakay
    Are you still experiencing the 404 error you mentioned here:
    http://ios.forums.wordpress.org/topic/wordpress-app-image-upload-problems?replies=10#post-12472

    Were you able to capture the error in an activity log?
    http://ios.forums.wordpress.org/topic/wordpress-app-image-upload-problems?replies=10#post-12476

    Also, what is your URL? We can better diagnose a problem when we're able to run some of our own tests.

  15. i posted the log as instructed and haven't deleted anything. the HUGE pic is still there. was waiting on further orders

    http://drawingforfood.com

  16. @dakay

    Right. I should have read a little farther down that thread. Sorry.

    Regarding the size of the image: it looks like the app is doing what it was designed to do since we removed the image size options -- uploading the full size, or optimized image. While its not a bug per se, I understand that this is not the best experience for you and many others. We still have plans to improve the media experience in the app. The best way to keep up to date with where that's at is to watch the development activity on https://github.com/wordpress-mobile/WordPress-iOS/

    Regarding the 404 error: the activity log you shared does not capture the error, so there are no additional clues as to its cause. An HTTP 404 error suggests a server side issue. Your best bet would be to contact your web host for assistance determining the cause, there's not going to be much more we can do support-wise in the forums.

Topic Closed

This topic has been closed to new replies.


About this Topic