Forums

Upload failed with 4.2

  1. Hello,

    Release 4.2 was available and as usual, I installed it... however, on iOS 7.1.2 (iPad Air) and iOS 8b5 (iPhone 5S), when I try to add a picture to a post, here is the message I'm getting:

    Upload failed
    API calls to this blog have been disabled.

    I haven't change anything on my servers... this is definitely a bug that comes from this release 4.2... let me know if you need additional logs.

    Thanks,

  2. I am getting the same message when doing anything with the new app, like refresh comments or notifications.

  3. Same here. Would love to know if this is getting fixed, because the app is currently unusable!

  4. @snoop_adv @onlygators @appunwrapper

    Can you sign in to your dashboard in a web browser and check whether you have the Jetpack plugin installed? If so, make sure its the latest version and that the JSON API module is activated.

    Also, it would be super helpful if you could share which version of Jetpack you have, if the JSON API module was activated and you still saw the error.

    Please let me know if you're seeing the above error message and *did not* have Jetpack installed on your site.

  5. I activated JSON and now it seems to be working again. Thanks!

  6. Good point Eric.

    So my version of Jetpack was 3.0.1... I first updated it and got the same error. Then I activated JSON API and all the sudden, everything worked again.

    It is worth noting that within the configure panel of JSON API, I didn't tick the box "Allow remote management of themes, plugins, and WordPress via the JSON API. (More info)."

    Thanks again Eric for your quick and pertinent answer.

    S

  7. Worked for me. Thanks!

  8. Thanks everyone for replying back, and I'm glad to hear that was the fix for everyone.

    Cheers!

  9. Glad there's a fix but seriously, no one thought that might be a problem?

  10. Where the heck do I see about the JSON API stuff? That is nowhere in my Network Administration Jetpack settings that I can see (I just upgraded to 3.0.1 from 3.0).

  11. Hello,

    I have Json active. Jetpack 3.1.1.
    On my iphone have this message: "Temporary Server error - It seems your wordpress site is not accesible at this time, please try again later"

    On PC/laptop everything is ok. Site is UP.

    Thank you

  12. Hello,

    I deleted ios app from my iphone. Reinstall.
    Now i can't even log into my account/site url.

    "Sorry, we can't log you in"

    Request failed: service unavailable(503).

    ALL THAT BUGS FROM 4.2 VERSION!

    THANK YOU

  13. @Nicorel

    The mobile apps communicate with your site via a file named xmlrpc.php. When I try to view yours at http://www.stirimeteo.com/xmlrpc.php, instead of displaying the expected message about "post requests," the page tries to download. This is a good indicator that something is incorrectly configured on your site or its server.

    You can try disabling plugins to see if one of them is causing the problem. If the problem continues after disabling plugins you should contact your web host and inform them that there is a problem with your site and work with them to get it resolved.

  14. @hudson2001

    Jetpack's JSON API setting is located under Jetpack > Settings. You can see it near the bottom of the list in this screen shot.

    https://i.cloudup.com/zAuauP4Iwz.png

  15. I eventually found it. There are apparently two different places with Jetpack settings.

  16. Hi i don't have jetpack installed on my self hosted wordpress but i still get this error. Any idea? It was working fine still i've updated wordpress to the last versione. Many thanks

  17. @raizen84. Which error do you mean? A couple of different ones were mentioned in this thread. Also let us know the URL to your blog so we can take a look.

  18. Hi, I do have Jetpack installed (Jetpack 3.3, WP 4.1) and JSON API is activated ("Allow remote management of themes, plugins, and WordPress via the JSON API ..." not checked.) However, I am getting the same "Upload failed" (german: "fehlgeschlagen") message on iPhone and iPad (both iOS 8.1.3 and auto-update for apps activated), see:

    http://goo.gl/8UEwav

    But the posts seem to get updated, anyway.

    Any other idea why this might happen?

Topic Closed

This topic has been closed to new replies.


About this Topic