Forums

Upload failed from iPad2 IOS6

  1. I've trawled through the posts but not yet found a soltution.

    When I try to upload a short video (2MB MOV file) into a Page from Wordpress for IOS on my iPad 2 (IOS 6.1.3), the process runs and shows the file is uploading but when it reaches 100%, after a short pause, the error message "Upload Failed your site ran out of memory while processing this request".
    I am able to upload the same file direct to the Media library without a problem, and create a page and embed the content. I am also able to do this through Safari connection from iPad to wp-admin for the site.

    My Media limit is set to the default 64 MB.
    Wordpress 3.5.1
    Theme: Diary/Notebook 2.0.2 by Site5 however this doesn't appear to be Theme specific or site dependent as I have tried multiple configurations.
    Latest version of Wordpress for IOS.
    Logged in as admin for both Safari and Wordpres for IOS.
    Hosted on Hostgator. Baby Croc. Nowhere near the memory limits of site as far as I can see.

    I have tried altering the php_value settings shown in related post.

    Cheers for any help you can offer.

    Maurice, NZ

  2. I have checked the server memeory and cpu use. 0.1% of memory used (HostGator advise this should be <25%!). There was a sharp peak when the upload reached 100% - but only to 0.3%.

  3. Hi, can you try setting the memory limit to 256M and see if that works?

  4. Hi John

    Thanks for the reply.

    Sorry, I'm no expert but which variable shouyld I be changing.
    I have multiple domains many with WP installed under a shared hosting domain. There is a wp-settings.php file under the public_html folder and in each of the sub domains.

    Do I need to change all wp-settings.php files or just the top level?

    It appears that there are a number of settings I can define.

    // Set initial default constants including WP_MEMORY_LIMIT, WP_MAX_MEMORY_LIMIT, WP_DEBUG, WP_CONTENT_DIR and WP_CACHE.

    I have added

    define('WP_MAX_MEMORY_LIMIT', '256M');

    to the top level file but that has not fixed the problem.

    Maurice

  5. Hi John

    Thanks for the reply.

    Sorry, I'm no expert but which variable shouyld I be changing.
    I have multiple domains many with WP installed under a shared hosting domain. There is a wp-settings.php file under the public_html folder and in each of the sub domains.

    Do I need to change all wp-settings.php files or just the top level?

    It appears that there are a number of settings I can define.

    // Set initial default constants including WP_MEMORY_LIMIT, WP_MAX_MEMORY_LIMIT, WP_DEBUG, WP_CONTENT_DIR and WP_CACHE.

    I have added

    define('WP_MAX_MEMORY_LIMIT', '256M');

    to the top level file but that has not fixed the problem.

    Maurice

  6. Whoops -

    I have added the following to both the public_html\wp-settings.php file and the sub-domain\wp-settings.php file

    // Set initial default constants including WP_MEMORY_LIMIT, WP_MAX_MEMORY_LIMIT, WP_DEBUG, WP_CONTENT_DIR and WP_CACHE.
    wp_initial_constants( );
    define('WP_MAX_MEMORY_LIMIT', '256M');
    define('WP_MEMORY_LIMIT', '256M');

    but the problem persists.

  7. Hi,

    Looks like this issue may be fixed.

    This is not a multi-site installation. In addition to the above I changed the site file below.

    file: domain/php.ini

    memory_limit = 256M (from 64MB)
    post_max_size =256M (from 64MB)
    file_uploads = On (unchanged)
    upload_max_filesize = 256M (from 64MB)

    Thanks for your help Jorge...

    Maurice

Topic Closed

This topic has been closed to new replies.


About this Topic