Forums

Unable to update/edit posts

  1. I just installed WP2 today, and figured a new blog post would be a great way to start off. I started the post but wasn't ready to submit it. I saved it as a local draft and came back to it a couple hours later on my next break. After typing up a couple hundred words, it was time for me to save my progress and go back to work. Again, a couple hours later, I open up WP2 only to find that I had lost where I left off. Only thing that was there was what I had originally written hours ago. I retyped and saved 3 more times only to have the exact same result. None of my edits ever saved.

    Frustrating to say the least.

    I gave up till I got home. I went ahead and posted my local draft as a regular (server) draft and continued my writing on my desktop. I was about 90% complete, saved it as a draft and went out. I launched WP2, and found my complete edit stored as a server-side draft, just as expected. I completed the post, added another picture, and all looked perfect.

    When published, however, what came up was the original, first saved draft, from 12+ hours earlier. Gone were all the edits and pictures attached. Using WP2, I reset the published version back to a draft. When I came home, I jumped back on my desktop to find what I had expected. On the server, the draft showing was also the original edit, just one forth of the entire post. Fortunately I had half expected such a failure, and had copy/pasted the nearly complete post into notepad.

    Does WP2 not like jumping back and forth? Cache issue? i'm not sure on this one.

    server side: Wordpress v. 2.8.5 (cutline theme)
    iphone: 3GS w/ 3.1.2

  2. Hi,

    That's a complex scenario. I'm not sure I could reproduce. Are you saying that when you tried to save a local draft the app didn't save it?

    It is possible, I suppose, to get out of sync with the server in the scenario you describe, although we've implemented an "auto update" to guard against such things... It may be that the auto update didn't run if you stayed on a particular view within the app...

    We appreciate the report and if you're willing to spend some more time testing a pared-down version of this let me know and we can see if we can pin down the issue...

Topic Closed

This topic has been closed to new replies.


About this Topic

Tags