Forums

Unable to sync

  1. Good morning,
    I've been having a heck of a time with the iOS app for Wordpress. After finally getting logged in and trying a test post, I get this error:

    Unable to Sync
    The Jetpack site is inaccessible or returned an error: server error. Requested method jetpack.jsonAPI does not exist [-32601] [jetpack_error]

    I'm sure this makes some sense to someone, but I just can't seem to translate that into something I can understand.
    Thanks for any help.
    R.

  2. Same error here. A workaround ifor self hosted sites is to add the blogs one by one instead of collectively adding it through Wordpress.com account, but that obviously wouldn't work for many people.

    Any fixes?

  3. Do you have Jetpack REST turned on under help&support of the wordpress.com settings?
    Turning it off may help.

  4. That might just be the answer...Thanks for your help!
    R.

  5. You might also check to be sure you have the latest version of Jetpack installed.

    Let us know if you're still seeing error messages.

  6. Having the same problem.

    I had a problem a while ago with the jetpack plugin, which seemed to get resolved when I increased the memory allocated to PHP (as per the advice given by Jetpack support), but now I'm experiencing the errors again.

    Once again, turning off the jetpack plugin "solves" the issue, in that I no longer get the errors and the app works fine while the plugin is deactivated, but it obviously eliminates my ability to use the jetpack features that I otherwise would like to continue using (stats, etc.).

    I've followed the suggestions here - I only have one blog and it was added manually (not through my wordpress.com account) and I turned off the REST option. still no joy.

  7. I had the same error as the OP and then I got an error while trying to look at stats through WPAdmin via web:

    Site Stats Configure
    unknown_token: It looks like your Jetpack connection is broken. Try disconnecting from WordPress.com then reconnecting.

    and since I tried deleting the site from the iOS app thinking to reload it, I can't add it back either. I did finally see the REST option under the questionmark at the top of the add site page on the app, but turning it off or on makes no change.

    Jolly way to break the whole thing.

  8. an update: went through the list of known-problem plug-ins, changed theme, no change. Deleted App from phone and reloaded. it let me add the self-hosted site but when I tried to check stats it said "looks like you have Jetpack set up on your site... but when I sign in with my wordpress.com credentials it says "this site is not connected to that WordPress.com username"

  9. So after a couple days of gradually worsening the problem, here's what reconnected both my mobile app AND stats for my self-hosted site.

    Deactivate the jetpack plug-in under the list of plug-ins via wp admin page. Then reactivate it (interestingly mine said it had not been tested with the version of WP I have...)

    THAT reactivation prompts you to log back into the wordpress.com account thereby reconnecting both stats and allowing me to log back into the mobile app with the wordpress.com account.

    THAT finally fixed the posting error from iOS.

    Hope this saves someone else the time it took to figure it out.

Topic Closed

This topic has been closed to new replies.


About this Topic

Tags