Forums

unable to post Blogs since update 4.7.1

  1. hi!

    After I updated to Wordpress 4.7.1 I can't post any blogs with the iOS App.

    Before I worked. See here:
    This was in FEB 2016

    https://ios.forums.wordpress.org/topic/wordpress-app-error-message?replies=30

  2. I just got the answer from my hoster: He could see in his logfiles that Wordpress is accepting the first 5 access by xmlrpc.php.
    Thereafter Wordpress is blocking. See the logs from the hoster:

    213.221.207.xxx - - [23/Jan/2017:09:22:18 +0100] "POST /xmlrpc.php HTTP/1.1" 200 132 "-" "Mozilla/5.0 (iPhone; CPU iPhone OS 9_3_5 like Mac OS X) AppleWebKit/601.1.46 (KHTML, like Gecko) Mobile/13G36 wp-iphone/6.7" www.mg-selzach.com
    
    213.221.207.xxx - - [23/Jan/2017:09:22:19 +0100] "POST /xmlrpc.php HTTP/1.1" 200 599 "-" "Mozilla/5.0 (iPhone; CPU iPhone OS 9_3_5 like Mac OS X) AppleWebKit/601.1.46 (KHTML, like Gecko) Mobile/13G36 wp-iphone/6.7" www.mg-selzach.com
    
    213.221.207.xxx - - [23/Jan/2017:09:22:20 +0100] "POST /xmlrpc.php HTTP/1.1" 403 280 "-" "Mozilla/5.0 (iPhone; CPU iPhone OS 9_3_5 like Mac OS X) AppleWebKit/601.1.46 (KHTML, like Gecko) Mobile/13G36 wp-iphone/6.7" www.mg-selzach.com
    
    213.221.207.xxx - - [23/Jan/2017:09:22:32 +0100] "POST /xmlrpc.php HTTP/1.1" 403 280 "-" "Mozilla/5.0 (iPhone; CPU iPhone OS 9_3_5 like Mac OS X) AppleWebKit/601.1.46 (KHTML, like Gecko) Mobile/13G36 wp-iphone/6.7" www.mg-selzach.com
  3. 200 means access
    403 means access denied

  4. Hi @mogli23

    Thank you for sharing the comments from your host. Based on the logs they shared, it appears your host is only allowing a few XML-RPC requests before blocking the rest. The WordPress for iOS app relies on XML-RPC requests to communicate with your blog and it can make numerous requests within a short period of time. As long as your host is blocking requests the app will not be able to function properly.

    There are a few options you can try.

    First, I recommend contacting your host and asking if they can stop blocking XML-RPC requests from the WordPress for iOS app.

    If your host is unwilling, then you might follow the instructions in this FAQ. It might allow the app to communicate with your blog successfully but it is not guaranteed.

    Please let us know if you're able to get it sorted out.

  5. Hi Eric

    Thanks for your replay!
    Maybe I was inaccurate with my posting above.

    The hoster of the website gave me the logs in post #2. He wrote me that he already opened the firewall. And he is right. About one year ago it worked (among other things thaks to your help!! => see link in post #1)
    The man of my hoster then told me, that maybe wordpress is blocking the iOS App after 5 times.
    I remember that I edited my .htaccess. Maybe there is something wrong?

    What are the correct items in the .htaccess, xmlrpc.php and xmlrpcwp.php?
    Is there an option in Wordpress to edit xmlrpc?

    Thank you and have a nice day!

  6. Hi mogli23

    He wrote me that he already opened the firewall

    That is interesting. The 403 errors included in the log tell us that the server is denying some of the XML-RPC requests made by the app.

    Is it possible the web host has accidentally reenabled the firewall or put some other security measure in place?

    For that matter, are there any security related plugins installed to your site that might be causing a conflict? Have you tried temporarily disabling all plugins to see if the problem goes away?

    I remember that I edited my .htaccess. Maybe there is something wrong?

    What are the correct items in the .htaccess, xmlrpc.php and xmlrpcwp.php?

    I'm afraid there's not much more I can say about .htaccess beyond what was in the original post. We recommend you contact your web host for any server configuration matters. They are the experts.

    The "xmlrpc.php" file is what the app uses to communicate with your blog, but you also mentioned a file named "xmlrpcwp.php". What is "xmlrpcwp.php"?

    Cheers!

  7. Hi Eric

    Thanks for your replay! I will check again with my host!

    The xmlrpcwp.php is a file which I found in the \html directory. At the same place as the xmlrpc.php

    Cheers!

  8. Hi Eric

    I got the answer from the host! He wrote that he didn't change anything. So he think the wordpress is blocking the xmlrpc requests.

    It is really stange. It worked for a long time - until I did the update to 4.7.1

  9. I just made the update to 4.7.2

    It's the same problem :-(

  10. Hi @mogli23

    I took another look to see if I could learn anything new. Let me explain what I did and then I'll share my thoughts.

    I wanted to test whether your host was blocking XML-RPC requests after a certain number of requests were made, and I wanted to test this in a way that does not use the WordPress for iOS app.

    To make the XML-RPC request, I used a tool for macOS called XML-RPC Client. I entered the URL to your website's xmlrpc.php file, and enter the XML-RPC method "demo.sayHello".
    https://cldup.com/20ZJkhtebT.png

    I also use a tool called Charles Proxy to monitor the XML-RPC request as it is sent to the server, and what the server sends back.

    When testing, I was able to perform several XML-RPC requests in a row with out any trouble, but every request after the fifth resulted in a HTTP 403 Unauthorized error.

    https://cldup.com/hQH8TaDThR.png

    You'll notice that all this is being done outside of the WordPress for iOS app.

    What this shows is there is something configured on your website to restrict the number of XML-RPC requests that can be made. As to what that something is, I really can't say. The WordPress software does not disable XML-RPC services by default, so the issue could be due to a plugin installed on your blog, or it could be due to some other server setting defined by your web host, or perhaps a custom setting you've defined in .htaccess.

    I'm not sure what else I can suggest other than confirming that the problem persists after *all* plugins have been disabled, confirming with your host that they definitely do not have a policy to block XML-RPC requests in place, and to check any settings you've added to your site's .htaccess file.

    Wishing I had better news for you. :(

  11. Hi Eric
    Thank you for your work and your help.

    My .htaccess looks like this:

    Action php /cgi-php55/php
    AddHandler php55 .php
    
    php_value memory_limit 128M
    php_value upload_max_filesize 128M
    php_value post_max_size 128M
    php_value max_execution_time 120
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Is that correct?

  12. Hi @mogli23

    I'm really not an .htaccess expert, so I'd encourage you to check with someone with more experience than me. I can say that it *looks* correct to me, based on my limited experience, but please get confirmation from another more knowledgeable source as well.

  13. Hi Eric!

    I have good news. The service is working perfect now!

    I gave an account to the admin of my host. He did some updates in the .htaccess, updated the site to php 7 and an URL-rewriting. The new .htaccess looks like this:

    Action php /cgi-php7/php
    AddHandler php7 .php
    
    #php_value memory_limit 128M
    #php_value upload_max_filesize 128M
    #php_value post_max_size 128M
    #php_value max_execution_time 120
    
    # BEGIN WordPress
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
  14. Hi @mogli23,

    That's good news! Congrats, and thanks for letting us know. :)

    Cheers!

Leave a Reply

You must log in to post.


About this Topic

Tags

No tags yet.