Forums

Unable to log into app.

  1. @tinRobot is this the blog you're having problems with? http://tinrobot.biz/xmlrpc.php

    Looks like you're running out of memory

  2. Yes. I've tried increasing the amount of memory via my wp-config.php file (having read that this may be the cause of my problem), but it didn't help.

    I can't understand why there would be a memory problem now anyhow, considering there wasn't before, when my previous blog was up. This new blog has just replaced the previous one which had become corrupted - I'd spent so much time trying to resolve it, I just ended up starting again, deleting everything except the database and reinstalling WP from scratch.

    Apart from manually attempting to configure the amount of available memory via the wp-config.php, is there another way to do it? My cpanel doesn't give me access to change the memory. Any ideas as to what causes memory problems like this? Is there anything I can do to free-up memory?

    Thanks

  3. @tinRobot - Take a look at this FAQ entry here: http://ios.wordpress.org/faq/#faq_6

    If this doesn't help, try with the default theme and with no active plugins.

  4. Thanks!

    That actually worked, but only after I'd put those lines of code into my php.ini file. Placing them in my root .htaccess (as the link suggests) gave me some "internal 500" error (can't remember what exactly, and don't fancy replicating it) and I couldn't get back into the admin page or see my web site at all.

    Anyhow, I can now log in to Wordpress on my iPhone. Thanks very much.

  5. I just ran across the same issue using Wordpress 3.3.1 and I managed to solve it using the following steps (thanks to assistance from posts above):

    1. Rename the xmlrpc.php file via FTP (found in website root) to xmlrpc_whatever.php
    2. Through Wordpress Dashboard, click on Plugins / Add New and search for Rename XMLRPC
    3. Install Rename XMLRPC plugin but don't activate it
    4. Find Rename XMLRPC plugin in list and click 'edit'
    5. Locate the line that reads:
    $renamed_xml_rpc_filename = 'xmlrpc2.php'; //CHANGE THIS pointing to the renamed file
    6. Change the filename 'xmlrpc2.php' to 'xmlrpc_whatever.php' and click Update File
    7. Activate the plugin
    8. In the Wordpress Dashboard, go to Settings / Writing
    9. Near the bottom of the page find and tick the checkbox: Enable the WordPress, Movable Type, MetaWeblog and Blogger XML-RPC publishing protocols.
    10. From your device Wordpress App, add a self-hosted Wordpress blog and make sure the address is: http://www.yourwebsite.com/xmlrpc_whatever.php

    This worked for me.

Topic Closed

This topic has been closed to new replies.


About this Topic