Forums

Unable to log into app.

  1. Hi there,

    At the moment I am unable to log into the wordpress blog I'm running.

    The error Im getting is - “Blog returned invalid data”

    I have looked at the article in FAQ for the app and followed everything it said. I verified and corrected any errors in the code. I also deactivated all plugins and installed the default app to no avail.

    Article - I get a “Blog returned invalid data” error message. what do I do?
    1. A common issue that can cause errors with the App is invalid characters. The easiest way to check is to go to the W3C Markup Validator and type in the URL of your WordPress site. If you get a response such as “… one or more bytes that I cannot interpret as UTF-8″ that is most likely what is causing the app to have trouble with your site.
    2. You can also try with the default theme and with no active plug-in.
    (Trying it with the default theme and plugins disabled will help pin down where the problem is. If everything works then you go back and enable your theme and then try it again. If everything still works then you go back and activate each plugin one at a time until you find the one that is causing the breakage.)

    If anyone can help me with this it would be much appreciated.

    To confirm - XML-RPC is enabled.

    Thanks.

    Chris

  2. Can you please share your blog URL?

  3. Sure...

    URL - http://socialbeautify.co.uk

    Many thanks,

    Chris

  4. Looks like the xmlrpc file that the app needs to access your blog is being blocked:

    http://socialbeautify.co.uk/xmlrpc.php

    Can you change the rights of that file to allow access?

  5. Do you know how I would do that at all? Sorry I'm very new to websites/wordpress. Thanks

  6. If you can log in to your web host, hopefully they have a file manager there. You should be able to browse to the xmlrpc.php file and change the permissions of it there.

  7. Ok so I located the file xmirpc.php which was in the root directory. I couldn't see one that was in the theme directory or in wp-admin. Anyhow - I changed the permissions to 744 and that didn't work. I then changed it to 777 just to see if that would make a difference and I still got the same error message when trying to log in. I'm sorry this is on going but thanks for all your help. Any further advice would be much appreciated.

  8. Maybe try contacting your web host to see if they are blocking access to the file?

  9. Hi mrroundhill,
    I have contacted my hosting company and this is the response I got after emailing numerous people.

    "The standard xmlrpc.php script is quite commonly installed with many free blogging applications. Unfortunately, it is quite easy to exploit and often abused by amateur "hackers" and spamming groups for malicious purposes.

    However, most users that have the script on their sites don't actually use it, therefore we have decided to block access to that filename to protect those users.

    If you wish to use an XMLRPC service, simply rename the file to something like 'xmlrpc_post.php' and reference that script instead in your posting service. You will need to make sure any references to the file in your scripts now point to the new name that you have used for the file."

    Are you able to tell me where abouts those references would be. If I'm completely honest, I really wouldn't know where to start looking. Of course changing the name of the xmirpc.php file is easy. I just don't know what references to change or their location.

    Following this - do you think what they say about the xmirpc.php file being vulnerable is true? Should I be trying to secure it in further if I remove the block by renaming.

    All your help so far really appreciated and thank you for your time.

    Chris

  10. Chris, you're nearly there! All you need to do now is rename the file on your server (let's say you go with xmlrpc_post.php):

    In the app, select 'Add a self-hosted WordPress blog'.
    In the URL field, enter socialbeautify.co.uk/xmlrpc_post.php
    Enter your username and password, then tap 'Save'.

    I'm crossing my fingers that it works finally! We don't believe there is anything insecure about the xmlrpc.php file, but some webhosts are just finicky about anything that allows access to your site from outside the regular methods.

  11. Hi mrroundhill,

    I have done exactly what you have said above but it still isn't working. Is that because I need to redirect any references to the xmirpc.php file to the renamed xmirpc_XXXX.php file? If yes, what is the location of these references?

    When trying to log in I get the following error -

    "Sorry can't log in HTTP/1.1 405 Method not allowed"

    Hopefully we will get there shortly.

    Thanks

    Chris

  12. No, you shouldn't need to update any references. Do you know which version of WordPress you are running on your blog?

  13. Hi there, Apologies for the delay. I am running the latest version of wordpress - is it 3.2.5. I only installed it the other day.

  14. 3.2.1

  15. What did you rename the xmlrpc.php file to?

  16. Sorry to thread hi-jack, but I am having exactly the same issue - I have renamed the xmlrpc.php file to xmlrpc_post.php - the app now logs in, but I receive the 'Blog returned invalid data' error when selecting any other option.

    It seems that once you get past the initial login stage the app is looking for xmlrpc.php again.

  17. Was there any progress on this? I am using the same host as Chris, and have exactly the same issue.

    Should I start my own thread?

  18. I think there might be one more step involved:

    Edit the xmlrpc_post.php file, and where you see:

    <api name="WordPress" blogID="1" preferred="true" apiLink="<?php echo site_url('xmlrpc.php', 'rpc') ?>" />

    Change 'xmlrpc.php' to 'xmlrpc_post.php'.

    I'm confident this will fix it. Crossing my fingers for you.

  19. No luck unfortunately :(

    I changed all 4 variations of that section of code:-

    <api name="WordPress" blogID="1" preferred="true" apiLink="<?php echo site_url('xmlrpc_post.php', 'rpc') ?>" />
    <api name="Movable Type" blogID="1" preferred="false" apiLink="<?php echo site_url('xmlrpc_post.php', 'rpc') ?>" />
    <api name="MetaWeblog" blogID="1" preferred="false" apiLink="<?php echo site_url('xmlrpc_post.php', 'rpc') ?>" />
    <api name="Blogger" blogID="1" preferred="false" apiLink="<?php echo site_url('xmlrpc_post.php', 'rpc') ?>" />

    just in case, but still returns the same error. It logs in initially fine, but when navigating through the app the 'Blog returned invalid data' error appears, and once cleared none of the functions will actually post anything, although you can select the option to create a new page/post.

  20. Ok, I was hacking through core files to get it working when a co-worker presented a more elegant plugin solution.

    1. Rename your xmlrpc.php file to something different, but only change it before the 'xmlrpc'. Ex: wp-xmlrpc.php
    2. Install this plugin
    3. Remove the blog from the app and add it back again.

    Should work!

  21. Forgive my ignorance, but how can install that plugin? It doesn't appear when searching the Wordpress plugin directory by name or author. Do I need to just create the file and place it in the plugin folder with the code from that page?

  22. It's pending approval for the plugin directory, meanwhile you can upload the file to your wp-content/plugins directory, and then activate from the dashboard

  23. Hello all, Apologies for starting the post and vanishing... I have been away. There is a lot to catch up on which I will now. Thanks to everyone for there input and help. Hopefully this issue will be sorted shortly for all.

  24. Ok - As you may have guessed from the my posts... I am a complete novice to websites and etc and code. Well getting there slowly.

    I clicked on the link above and in my browser just had a white background with the code of the plugin? I copied that into dreamweaver and created it as a .php file. I then went to plugins on the site, uploaded the file and while it was trying to unpack/install the following error occurred.

    "Installing Plugin from uploaded file: renamexmlrpc.php
    Unpacking the package…

    Incompatible Archive. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature"

    This is beyond me and I don't know what next I should do or whether I have do this completely wrong.

  25. As long as the php file is in the wp-content/plugins directory, all you need to do is go to the plugins area in wp-admin, and click 'Activate' under the 'Rename XMLRPC' plugin.

    http://codex.wordpress.org/Managing_Plugins#Manual_Plugin_Installation

  26. Whooop - I got this working, thank you mrroundhill and Jorge Bernal!

    To confirm though - I had to name xmlrpc.php to xmlrpc_post.php as anything before 'xmlrpc' did not login at all - for example 'wp-xmlrpc.php' did not work.

    chrisd11 - Just copy and paste the code in to a basic text editor such as notepad, then save as 'rename-xmlrpc.php' - Create a folder in your wp-content/plugins directory called 'Rename XMLRPC', then as has been said, login to Wordpress and activate the plugin. Finally, remove the blog from your Wordpress for iPhone App and setup again, with the URL as http://www.yourdomain.com/xmlrpc_post.php

  27. It's on the plugin directory now:
    http://wordpress.org/extend/plugins/rename-xml-rpc/

  28. Hey guys,

    Ok so I have renamed the xmirpc.php file adding something before and after. I have installed the plugin but I am still getting -

    "Sorry can't log in HTTP/1.1 405 Method not allowed"

    When I try to log on. I just don't know what I am doing wrong and its getting so frustrating as I sure it is you.

    Any advice would be greatly appreciated.

    Chris

  29. @chrisd11 - Are you typing the full URL out into the app?

    http://www.socialbeautify.co.uk/xmlrpc_post.php

  30. Hi all,

    I'm having the same issue despite having tried the 'Rename XMLRPC' plugin (and associated setup routine).

    This is something that has only in the last day or so appeared, immediately after doing a clean re-install of WP 3.3.1 (where I literally deleted everything on the server and uploaded 3.3.1 manually). I've had the blog running well for the last few days, and have only now gone to try to access it via the WP app on my iphone. Prior to doing this rebuild, I could access my blog via the app without problems.

    I've also tried a variety of security settings on the xmlrpc.php file, without success.

    Any other ideas?

Topic Closed

This topic has been closed to new replies.


About this Topic