Forums

The network connection was lost

  1. I'm able to create a new post with the Wordpress app on my iPhone. But when I try to upload an image to the post, I get the message "The network connection was lost". Where should I start looking? I have a feeling that it is a server related issue.

  2. Forgot to mention, this is on a self-hosted website. On a dedicated hosting platform that I can dictate changes to be made if needed. I have turned off Sucuri Security plugin, and I do have JetPack plugin. The wordpress is current, as well as the plugins.

  3. Any suggestions?

  4. Hi @cswann

    Its tough to say what the cause is for sure. Network trouble can be due to hardware problems on the iPhone, due to issues with the wifi or cellular network to which your iPhone connects.

    You might try fully powering off your phone and restarting it to see if that clears up a temporary hardware related glitch.

    You also might try changing cellular or wifi networks, and ensuring you have a strong stable connection to the web before uploading.

    I hope this helps!

  5. Eric,

    It is almost as if the image doesn't even try to upload. I'm trying in the office over wifi, and the image has that message over it almost as soon as I've done selecting the image to use.

  6. > It is almost as if the image doesn't even try to upload

    This is interesting. It kind of sounds like something server-side is preventing the upload, but rather than returning an informative error message (like an HTTP 403 error due to a permissions issue) the HTTP request is just being shut down or dropped.

    I'm curious what your server's logs might show regarding the image upload. It might be useful to see just what is recorded in the access log (confirming the request made it to the server) and if there is anything being written to the error log. Maybe there actually is an error being logged.

    For due diligence, I'd also be curious to know which version of PHP is running on your server, and whether the problem persists when any/all plugins installed to your site have been disabled.

    Hope this helps.

  7. Thanks Eric for the reply.

    I rechecked to make sure that I had the latest version of WP on Friday afternoon, which was auto-updated to the 4.7.2 version. I decided to try to turn off the plugins, especially WordFence and Sucuri, the two security plugins. When I turned them off, the upload worked. I turned them back on, and the upload was still working.

    So, not sure why it wasn't working but now it seems to be working correctly. I'm going to leave it alone for now.

    Thanks again for the help.

Leave a Reply

You must log in to post.


About this Topic