Forums

Statistics: URL not supported ???

  1. I added a new site to the app and was asked if I wanted to add the statistics part. I have already logged in to my wordpress.com account so I just clicked "Save" but then I get an error message that says "URL not supported" (but in Swedish) - slightly confusing error message. I haven't entered any URL, no URL was asked for, the rest of the login seem to work since I see posts etc.

    I tried deleting the site and adding it again this time with the "http://" part, no difference. Skipping and then trying to add from the statistics button gives the same result.

    So. how do I log in to the statistics part?

  2. Try this:

    Tap on the "Me" tab.
    Tap the back button until you see your list of sites that you've added to the app.
    Tap your self-hosted site.
    Tap Edit Site
    You should see an option to configure Jetpack. Make sure that Jetpack has the same WordPress.com credentials you used when activating the Jetpack Plugin on your blog.

    Once that is done, try to access Stats again.

  3. I tried this but the same thing happens. Here is some additional info of my site

    1. The site is a multi-site installation
    2. The site has one admin user and one "regular" user. In the iOS app I'm using the regular user but have logged in to wordpress.com using my wordpress.com account
    3. I only have one wordpress.com account so I can't have used the wrong one
    4. The app has one other self-hosted site and the statistics there seem to work just fine. This account was added before the last round of iOS updates (I don't know exactly when).
    5. Looking at the site, the statistics part seem to work just fine and it says that it has connect to wordpress.com
    6. Everything also looks OK on the wordpress.com side
  4. Hmm. You say "regular" user. I wonder what user role you might have assigned to it. The app expects at least an author role, but really editor or admin is preferred for all features to work as expected.

  5. my "regular user" is an "editor"

  6. The same problem for my self hosted site http://www.dnanotizie.it
    Jetpack doesn't run: URL is not supported

  7. Following up...

    First off, thanks @skromta for all the feedback. Its much appreciated.

    We did some testing and found we could reproduce the problem. This is a bug in version 4.1 of the app. We've fixed the bug and we're going to submit a new version to Apple right away.
    https://github.com/wordpress-mobile/WordPress-iOS/pull/1809

    Sorry for the trouble folks!

  8. Installed today. Getting the same error. I assume the new update is not hosted in the app store yet?

  9. @radioboy969 Yep. Version 4.1.1 had already been sent to the app store before we learned of the bug showing stats. Its fixed in 4.1.2 which is awaiting Apple's approval.

  10. I've also encountered this error and really look forward to it being fixed!

Topic Closed

This topic has been closed to new replies.


About this Topic