[SOLVED] Yet another "XML-RPC error"-thread

  1. I'm having problems getting my blog to work. Before the latest WordPress for iPhone update (22.march or whenever it was), it worked flawlessly. After the upgrade, whenever I tried to start the application, it opened, and closed itself after 1-2 seconds. There was no workaround to this, so I had to uninstall the app, and then reinstall it. The blog was now gone from the list. Any attempt to add my blog to the list again, I get the XML-RPC error.

    BlogURL: , produces the "XML-RPC server accepts POST requests only."-message. , produces a valid XML-file

    So, why doesnt it work? :-(

  2. Found out!

    My header.php on my current theme, was missing the following line;

    <link rel="EditURI" type="application/rsd+xml" title="RSD" href="<?php bloginfo('url'); ?>/xmlrpc.php?rsd" />

    Adding that, and it worked again :-)

  3. I tried that and it still won't work.

  4. thanks. i added that line in my header and now it says:

    We cannot find your blog

  5. My self-hosted blog ( has that line in its header and all I get is the XML-RPC error. I don't get any sort of error code as some others are reporting. I've done everything in the FAQ suggests, to no avail. Seems I'm just SOL.

  6. my blog ( keeps showing the xml-rpc error also. i have done everything in the FAQ and also tried adding the line in the header that was suggested above.

    still nothing.

    please help!

    are there other alternatives to the wordpress app?


  7. Had the same problem. Did everything in the FAQ to no avail. Finally changed my theme to default, connected via iPhone and then changed theme back. Worked like a charm. Good Luck!

Topic Closed

This topic has been closed to new replies.

About this Topic