Forums

Shortcode Plugins Giving: Unable to Sync - NSXMLParserErrorDomain error 111

  1. I made a very simple shortcode plugin to display a vimeo video on a post and nothing I seem to do makes it work with the iOS wordpress app.

    The shortcode works fine on browsers when you view it, even mobiles, but if I try to view my posts on the iOS wordpress app it gives that same error. I have also used other shortcode apps and get the same error, such as "Shortcodes Ultimate". I then turned on JetPack, and used the built in vimeo short code, and still get that same error.

    Disabling the plugins or removing the short code fixes the error.

    I am on a dedicated server hosted by hostgator, and this was a clean install on a new domain. Is this a known bug for the iOS app? Any workarounds?

    Code:

    class AEshortcodes {
        // [embedvimeo id="xxx" width="xxx" height="xxx"]
        public static function embedvimeo_func( $atts ) {
            $a = shortcode_atts( array(
                'id' => '00000000',
                'width' => '500',
                'height' => '281'
            ), $atts );
    
            return '<iframe src="https://player.vimeo.com/video/' . $a["id"] . '" width="' . $a["width"] . '" height="' . $a["height"] . '" frameborder="0" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe>';
        }
    }
    add_shortcode( 'embedvimeo', array( 'AEshortcodes','embedvimeo_func' ));
    ?>

    The debug log is not helpful at all, as it just reports the error message:

    2015/07/26 21:34:08:599 ===========================================================================
    2015/07/26 21:34:08:600 Launching WordPress for iOS 5.3.1 (5.3.1)...
    2015/07/26 21:34:08:600 Crash count: 0
    2015/07/26 21:34:08:600 Debug mode: Production
    2015/07/26 21:34:08:600 Extra debug: YES
    2015/07/26 21:34:08:601 Device model: iPhone 6 (iPhone7,2)
    2015/07/26 21:34:08:601 OS: iPhone OS 8.4
    2015/07/26 21:34:08:601 Language: en
    2015/07/26 21:34:08:601 UDID: 183A3366-7A2C-4E70-9220-4A84C06E2AFC
    2015/07/26 21:34:08:602 APN token: (null)
    2015/07/26 21:34:08:602 Launch options: (null)
    2015/07/26 21:34:08:602 All blogs on device:
    2015/07/26 21:34:08:609 <Blog Name: Online Gun Coach URL: http://mydomain.com XML-RPC: http://mydomain.com/xmlrpc.php jetpack: 🚀❔Jetpack not installed>
    2015/07/26 21:34:08:609 ===========================================================================
    2015/07/26 21:34:08:846 MediaService cleanUnusedMediaFileFromTmpDir
    2015/07/26 21:34:09:120 didFinishLaunchingWithOptions state: 1
    2015/07/26 21:34:09:232 <WordPressAppDelegate: 0x1702a7bc0> applicationDidBecomeActive:
    2015/07/26 21:34:09:344 Feedback response received: {
    "feedback-enabled" = 0;
    }
    2015/07/26 21:34:09:402 0 media items to check for cleanup
    2015/07/26 21:34:11:334 No instructions, do nothing
    2015/07/26 21:34:13:758 Showing alert with title: Unable to Sync and message The operation couldn’t be completed. (NSXMLParserErrorDomain error 111.)
    2015/07/26 21:34:18:636 Helpshift Disabled

  2. Hi @davellan

    I tried to reproduce the error with the twentyfifteen theme. I just added your sample code to the functions.php file and created a test post with the shortcode. Everything seemed to work fine for me and no errors with the XML-RPC response.

    How/where are you adding the code?

    Are you able to make an XML-RPC request to see what its returning? I'd be curious to see how the response is formatted.

  3. Hey Eric, I am using the evolve theme (free version). I didn't consider that it could be the combination of the theme and short codes.

    This is the second issue I had with this theme, first being that it had an option to use maps.googleapis.com scripts that was stalling my site (would hang on a blank page for a long time, sometimes stalling out). I was able to deactivate that and fix that issue.

    I really like this theme as it is easy to use, but I need to be able to use the WP app to get content in from multiple users on the go.

    I made my own plugin folder and put the php code in that folder. It is definitely a short code issue, because I tried a few other plugins that had short codes and they would crash (JetPack Shortcodes, ultimate shortcodes).

    I'm not that familar with XML-RPC requests. How would I do that?

  4. Hey @Eric, I just switched themes to 2015 and I got the same error, so that doesn't seem to be the problem unfortunately.

  5. > I'm not that familar with XML-RPC requests. How would I do that?

    The app communicates with your blog via XML-RPC, courtesy of the xmlrpc.php file that ships with WordPress. You can preview it in a browser here: http://davidavellan.com/xmlrpc.php

    An XML-RPC request is just a bit of XML, formatted in a certain way, that is sent to this file. Your blog responds with some additional XML that the app then parses. This is how data is shared.

    The error message you're seeing in the app suggests something is wrong with the expected XML-RPC response, which is why I was curious about it. I ask cos you're clearly tech-savvy. :)

    If you're using a mac, there is a nifty tool called XML-RPC Client that will let you test XML-RPC requests. I'm afraid I don't have much experience with similar tools on Windows but I see a few options just from a quick Google search.

  6. Ok, so how would I know what xml code is causing this to happen? The domain in question is OnlineGunCoach.com. I can reach the xmlrpc page, but how can I debug this? Is there an error log other than the one that the iOS app produced that can be more useful?

    Also, since I get the same error regardless of theme, could this be a server issue?

  7. > but how can I debug this

    You could try sending an XML-RPC request via the tool of your choosing and inspecting the results.
    Based on your original description, the wp.getPosts XML-RPC method would be the one to test. The way you'd format the request probably depends on the tool you choose. If you don't mind using the command line, you might find this article helpful: http://otakunozoku.com/using-curl-to-debug-wordpress-xmlrpc-calls/

    > could this be a server issue

    I'm guessing the server is responding with an error message instead of a proper XML-RPC response, and this is what's causing the NSXMLParser error.

  8. Hey Eric. I followed the blog and got this back:

    <?xml version="1.0" encoding="UTF-8"?>
    <methodResponse>
      <params>
        <param>
          <value>
          <array><data>
      <value><struct>
      <member><name>isAdmin</name><value><boolean>1</boolean></value></member>
      <member><name>url</name><value><string>http://onlineguncoach.com/</string></va                          lue></member>
      <member><name>blogid</name><value><string>1</string></value></member>
      <member><name>blogName</name><value><string>OnlineGunCoach.com</string></value                          ></member>
      <member><name>xmlrpc</name><value><string>http://onlineguncoach.com/xmlrpc.php                          </string></value></member>
    </struct></value>
    </data></array>
          </value>
        </param>
      </params>
    </methodResponse>

    So what command what I have to put to see blog posts, like I would from the iOS app?

  9. Ok, I figured out the problem. It wasn't shortcodes by itself. It was another plugin I had called iMember360. I am going to contact the developer to have him figure out what went wrong.

  10. Cool! Happy to hear you were able to determine the cause, thanks for following up to let us know.

    Cheers!

Topic Closed

This topic has been closed to new replies.


About this Topic