Forums

Problems with TinyDesk and WP4.1?

  1. I have downloaded the iOS app and tried to connect to my site.
    Logging in is not a problem but I am unable to view/access any of my files.
    Clicking any of the tabs at the bottom of the app gui reports: "error when getting posts from server".
    Clicking the 'Galleries" tab reports "XML-RPC services are disabled on this blog. An admin user can enable them at http://www.mywebsite...options-writing.php"

    However, with WP4.1 this is enabled as default and there is no way to turn it on at this page!

    Anyone know what might be going wonky here??

    Cheers,
    Dean

  2. Ooops!

    Have I posted in wrong place?

  3. Hi Dean,

    You're in the right place. :)

    What's the URL of the site you were trying to use with the app? Was it http://www.diy-sos.co.uk/ ?

    You're correct that XML-RPC is enabled by default in WordPress (since 3.4 I think, don't quote me) however some hosts block XML-RPC requests. You might contact your host and ask if they have a block of this kind in place.

    Cheers.

  4. Hi Eric,

    Thanks for the reply.
    Yes, that's the url of my site.
    Since starting this thread. I have tinkered some more and the latest is...
    I disabled some plugins and upgraded Nextgen gallery (which has caused other problems) and now,
    TinyDesk now allows me to view my galleries, but not edit them! I am still getting the "error when getting posts" message when clicking any other tab... I will consult my hosting service and report back here.

    And so it goes on :)

    Cheerz,
    D.

  5. Keep us posted.

    Something you might also try is going into Me > Settings > Support and enabling the Extra Debug feature. If you do that, then reproduce the error some extra information about it will be logged. You can then go back to Me > Ssettings > Support and review the current Activity Log for any clues about what's happening.

    Cheers!

  6. That "me" setting is part of the Wordpress app, not the TinyDesk app...
    Will utilising it help me debug the TinyDesk errors I'm having issues with then?

    Bit confused :)

  7. Sorry about the confusion! It won't help with TinyDesk but it may be helpful troubleshooting the cause of the "error getting posts" message.

  8. Ok, so...
    Enable debugging in WP App.
    Try and access my site again using TinyDesk - which is where I'm getting the "unable to access posts" messages.
    Go back into WP App and see what's been recorded in the logs, from the TinyDesk session.

    Is that right?

    Cheers Eric,
    Dean.

  9. Hi Dean,

    So, this is embarrassing. I completely missed that TinyDesk was a different app. I thought we were talking about a plug in that was installed on your site. (Maybe its a sign I should get my eyes checked!) So, yeah, please disregard what I was saying about the logs.

    Sorry for the confusion, and thanks for setting me straight!

  10. Hey Eric...

    Don't be embarrassed mate.
    I appreciate that you took the trouble to assist
    me in the first place :)
    From your advice, I contacted my hosting provider and they were able to check the logs for my site and discern that the TinyDesk app was being deemed a threat by their firewall. They were able to modify things their end to nullify the perceived threat, on the basis that the app developer would be unlikely to amend their code... Especially considering there seems to be absolutely no archived feedback from this particular developer!

    So, I was able to progress further with TinyDesk, than before... Only to discover it still doesn't allow photo uploads to static pages!

    Oh well... Back to the drawing-board!

    Thanks again for your assistance.

    Cheers,
    Dean

  11. So, I was able to progress further with TinyDesk, than before... Only to discover it still doesn't allow photo uploads to static pages!

    Oh well... Back to the drawing-board!

    Arg! That's rough! Thanks for letting us know how it turned out tho.

    Cheers!

Topic Closed

This topic has been closed to new replies.


About this Topic