Forums

Problems connecting a selhosted installation behind .htaccess witzh the iOS app

  1. Hello all together.

    I have problems connecting a selhosted installation behind a .htaccess file with iOS-App Version 4.6.0.2. on iPhone 6 Plus with iOS 8.0.2.

    The setup of the site works, the app asks for the htaccess password and shows the site in the list.

    If I try do access the articles or pages the app asks 6 times after the htaccess login and the password. Eacht time I do something.

    If I give the Information, the app works. If I dont give the information this message appears:

    "The operation couldn't be completed. (NSURLErrorDomain error -1012.))

    On my iPad there is version 4.3 of the app and it works fine.

    My Android devices work fine too.

    The Wordpress version is 4.1.
    I did not change the .htaccess-file for years, it allways worked fine.

    It seems that the app in version 4.6 does not remember the password.

    Has anyone else this problem? I did not find anything.
    Any idea how to solve it?

    Thanx for your help,

    panic.zero

  2. It does sound like the same issue. We have a patch for that particular bug coming in version 4.6.1. Unfortunately, Apple pauses app reviews during the holidays so we must wait until after January 1st before our update can be approved and available for download. Hopefully they will get to it quickly and there won't be much of a wait.

  3. Hi

    The upgrade did not solve the problem.

    regards

    lars

  4. Hi Lars,

    Sorry to hear that. Are you sure that it was the exact same situation as @panic_zero was reporting? Could there be something different?

  5. Hi Eric

    Its the same error as @panic_zero has.

  6. Hi Lars,

    Okay. That particular error message is rather generic and could be displayed in several different situations. I was wondering whether your site was also requiring an extra authentication step. The app should support both your WordPress site's normal authentication, Basic HTTP Authentication, and certain varieties of two-factor authentication (like Google Authenticator). Knowing some of the details will help me understand whether the bug wasn't property fixed, or if something else is going on.

  7. Hi Eric.

    app does not save password on the site , it saves the password for the user , however . I have latest iOS , OS X , and the latest wordpress installed.

    let me know if there is anything else you need to know

  8. Hi Eric.

    Sorry, the update did not bring a solution.

    I deleted the entry and added it again.
    That worked fine.

    But the first time i 'opened' the site the app asked again and again and again .... for username and password.

    regards,

    panic.zero

  9. Thanks for following up @panic.zero.

    @panic.zero, @snedirf, it looks like I was a bit confused about exactly what was patched. There was a crash introduced in version 4.6 that only affected sites using basic HTTP authentication, and that crash was patched in version 4.6.1. The fix did not correct the issue with being prompted over and over again to enter your credentials. Sorry for the confusion there, that was my bad.

    I've been able to reproduce the bug and we have a ticket open to get it fixed, hopefully for the 4.7 release.
    https://github.com/wordpress-mobile/WordPress-iOS/issues/3016

  10. Hi

    Looking forward to the update , meanwhile, can I use safari.

    Regards

    Lars

  11. @panic.zero @snedirf

    We think we've tracked down the problem. I have a (hopefully not too) techy description.

    The app makes several calls to fetch and sync data from your site. In one place (the post, page, comments, etc. menu) the app makes half a dozen calls at once. What we're seeing is if a site has configured basic http authentication, AND the server is configured for connections to be kept alive, there is then a problem authenticating all the requests and you get those annoying login dialogs. The number of http requests being made at once seems to have a threshold. This page previously made fewer requests and we recently added a couple of new ones.

    We're considering different options for how to address this. In the meantime, it seems that editing your server config to disable keep-alive for connections might work. More details can be found in the github link I posted previously.

  12. Hi ERic.

    Thanx for the engagement.
    Safari and my Ipad with the old version are keeping my blog running ...
    The blog is hosted not on my own server, so there is probalbly no way to change the server config for me.

    Regards,

    panic.zero

  13. Following up: we have a patch we're considering but its probably not going to be make it into the 4.7 release. If the patch is good we'll probably rush a 4.7.1 version out the door.

  14. Hello

    Installed 481 and get the following error: Couldnt upload Featured Image , begärans textström uttömd.

    previous errors seem to be solved.

    /Lars

  15. Hi Lars,

    Glad the other errors are sorted out!

    I'm not 100% sure, but I think this error can sometimes occur if you're uploading a large image over an EDGE or 3G cellular connection. At least, that's what Google is telling me. We'll look to fix this in an upcoming release. https://github.com/wordpress-mobile/WordPress-iOS/issues/3364

    In the meantime, you might check the setting for the max image size slider under Me > Settings. You might find that you can avoid the error my uploading a smaller sized photo.

    Hope this helps!

Topic Closed

This topic has been closed to new replies.


About this Topic

Tags