Forums

Primary domain works, but addon domain doesn't work

  1. I am able to get the Wordpress iOS mobile app to work with my primary domain, but not with my cPanel addon domains. I'm thinking the addon domains created by cPanel require a different path (URL) in the Wordpress iOS mobile app.

    Has anyone successfully added addon domains to their Wordpress iOS mobile app? If so, what was the path you used?

    Thanks for your help!

  2. I'm thinking the addon domains created by cPanel require a different path (URL) in the Wordpress iOS mobile app.

    Probably so. Are you hosting with Host Gator by chance? Their docs mention this specifically:

    An addon domain created in cPanel will only function if the domain is registered and pointed to the server via nameservers or an A record.

    You might try contacting your host and ask what you need to do to configure DNS for an addon domain.

    Cheers!

  3. Hi Eric-

    Thanks for the advice. I appreciate it. The the domain is registered and pointed to the server via name servers.

    I am able to access the addon domain website via my browser with no problems. It's just the Wordpress mobile app won't connect to the addon domain website, but will connect to my primary domain website.

    Puzzling....

  4. Can you share the URL with us? I'd be happy to try to spot the trouble.

  5. Thanks Eric. The URL is http://lunchwithjoel.com.

    I appreciate your help!

  6. Thanks for the link.

    Something I noticed right away is that http://lunchwithjoel.com/xmlrpc.php isn't loading for me, and eventually times out. The xmlrpc.php file is what allows the app to connect to your site. If its unavailable, or showing errors then the app won't be able to detect your blog.

    You might contact your host and see if they can shed any light on why that page would be having trouble. Once its loading correctly you should be able to add your blog to the app (assuming everything else is configured properly).

    Cheers!

  7. Hi Eric-

    Yes, there seemed to be something wrong with the server earlier today, but the issue is now resolved.

    Typing http://lunchwithjoel.com/xmlrpc.php into my browser gives the response XML-RPC server accepts POST requests only, which I think is the correct return message, but still I am unable to have WordPress mobile app connect with addon domain (lunchwithjoel), but it has no issues connecting with my primary domain.

    My addon domain has a barebones WordPress installation running version 4.2.2, the Twenty fifteen theme, and no active plugins.

    Any other thoughts? Thanks again for your help and advice.

  8. My hosting service solved the problem. They needed to white list the server in the modsec rules. I am now able to login into my website via the the WordPress mobile app on my iPhone.

    Thanks again for your help and time, Eric. I appreciate it.

    -Joel

  9. Good to hear! Cheers!

Topic Closed

This topic has been closed to new replies.


About this Topic