Forums

Post with a photo causes crash

  1. Ive tried everything listed.

    I can publish a post from the iPhone app if it ONLY has text in it. A photo attached causes the app to either time out or crash.

    Ap version 2.2
    WP 2.9.2
    PHP 5

    permissions on upload folder set to 777
    max upload settings at 30 M
    settings/miscellaneous/default upload directory set correctly.
    I can upload photos form browser without any problems

    Does anyone have any ideas or suggestions? Im am pulling my hair out over here.

    Thanks in advance!!

  2. Oh man, is there anyone that can help or test. I've tried a few different blogs, have reinstalled, have used the servers auto install for WP... I everything I can find info on... and still:

    I can upload posts that are text only, but a photo in the post causes a communication error or a timeout. Anyone?

  3. Natedawg, I can help you out. I'm not able to reproduce the error while testing using my blogs. Would it be possible for you to make me a temporary contributor for yours so I can try to step through the photo submission and see where it crashes?

  4. Thanks frsh. Here's the weird thing...

    After installing another version of wp, not having any luck in any way shape or form with that either, and pretty much abandoning hope... tonight I discovered that posting images DOES work when I am on the 3G network and NOT connected via wifi. I was able to upload images via the WP iPhone app earlier this evening when I tried it from the road. When I got home I tested while connected to my wifi network, and the same problem occurred as before: posts with photos time out with a communication error.

    However, after immediately failing, I switched wifi off on the iPhone so that the internet connection on the iPhone was 3G... and it worked. Same post, all other factors the same... just the wifi connection. ?!?!?!?!

    I don't know if anything like this is documented, but my guess it has something to do with the ip address used to connect to the blog via wifi? I have NO IDEA... all I know is that the config works when Im on 3G and that will have to be enough for now.

    Let me know if you have any inside info on this bizarre scenario...

    Thx,
    Nate

  5. That's a puzzler - I've successfully posted photos to my test blogs many times over wifi... It's unlikely the problem is with the app, but I don't know how I'd reproduce either in order to check...

    If you find any more unique characteristics that would allow us to test, let us know...

  6. I'm totally new to wordpress...
    After reading this post I've tried to upload trough 3g/edge and wifi.. But it won't work with either of the methods..

    I have the same problem when I want to make a link from my iPhone ... In the blog it shows the HTML code but only without the "<" and ">" and therefor is only showing text..

    This problem comes only when adding/editing post from iPhone.. Directly from my computer it works great..

    When adding from iPhone I manage to upload the photo.. So If I go on my computer I can edit in the right "<" 's.. And the post will work.. But that kinda sucks... So please help a newbie from Norway ! :)

  7. I'm sorry, I don't quite understand your problem - please write back and describe in more detail what you want to do in a step by step way...

    Thanks --

  8. I've got a similar problem...
    I can post through the dashboard online, but I can't get any images to work when I post via email, the iphone app or linked posts from posterous or Flickr.

    I understand that posting images via email isn't supposed to work, correct?

    Here's what my posts look like when I post from Flickr:

    This is a test post from a href=http://www.flickr.com/r/testpostimg alt=flickr src=http://www.flickr.com/images/flickr_logo_blog.gif width=41 height=18 border=0 align=absmiddle //a, a fancy photo sharing thing.

    I'm getting a similar problem with the iphone app. The images upload, but won't display properly. Intead I'm getting psuedo HTML code in the posts.

    This is my posts text.
    pa href=http://jillandmorgan.com/v3/wordpress-content/uploads/2010/03/l_1600_1200_C649BE70-BA01-4644-89F9-762D9F82DD42.jpegimg src=http://jillandmorgan.com/v3/wordpress-content/uploads/2010/03/l_1600_1200_C649BE70-BA01-4644-89F9-762D9F82DD42.jpeg alt= class=alignnone size-full //a/p

    I'm using WP 2.9.2 and PHP 5.

  9. Please search this forum for image + iphone or picture + iphone... there are several posts with a few solutions to this problem. Some were server side issues although I don't recall at this moment what the exact solution was.

Topic Closed

This topic has been closed to new replies.


About this Topic