Forums

Photos not uploading

  1. Just got here and read everything but I still don't see a fix on the problem. Am trying to upload photos but got the API error saying its disabled. I enabled the JSON API on Jetpack and still no go.

    As for the .htaccess, I don't know if I should touch it. :-(

    What I'm saying is that the upload worked before without all these hacks that you guys are talking about. Then we have an upgrade and it does not work all of a sudden.

    Then the Administrator said that something was pushed on August 25th to correct the error. I'm still getting the error. So, what is the true solution?

    Do I still need to activate the JSON API for it to work? Or the app is broken?

    Thanks

  2. Here's the reply I got back from Bluehost:

    "You cannot turn off mod_security on a shared server, but you can whitelist the rule that is having a problem with it. I was going to do that for you, but you didn't clarify which rule was having the problem. If you can identify that rule for us, we can go ahead and whitelist it on your server for you."

    So perhaps that bit of information would be the long-term fix to this problem?

  3. I previously had the photo-not-uploading problem, enabled JSON in JetPack, and all was well.

    WP 4.0 and the newest iOS app update came this week, and I'm intermittently getting image upload failures. Sometimes I get the "timed out" message. Occasionally I get the internal 500 error.

    Site: http://stopdropandblog.com

    Any help would be greatly appreciated as these past two updates have been very frustrating.

    Thank you.

  4. Well, the first post from my iPhone went smoothly enough (but WHY no sizing control...what a pain in the patooty) after updating the app and to WP4.0. and I'll keep an eye on it for the next while to see what happens next.

    Better testing next time guys, please.

  5. I'm still unable to upload ANYTHING this morning with the updated app and WP 4.0 -- everything is giving me "timed out" error.

  6. Is this being worked on?

  7. I jut got Request Failed: Gateway Timed Out (504) this time.

    Can ANYONE help?

  8. @firemom

    A time out messages typically mean your site is being slow to respond to requests made by the app. This could be due to a bad internet connection, due to a high volume of traffic to your website, or any other event that would cause your site to run slowly.

    I suggest you contact your hosting provider and report that you've experienced some time outs trying to use the app with your blog. You might ask if they are aware of anything that might be causing the slowness, and if there is anything they can do to ensure your site's performance. Make sure the technician you speak with checks your sites traffic logs and can confirm the time outs.

  9. @Eric, This didn't happen until the two last updates of the app. I refuse to believe it has anything to do with my provider, but I'll email them. I'm really frustrated at this point.

  10. @Eric, Actually, no, that's totally not the case. I can upload immediately via desktop the same photo at the same resolution/size. It's the APP, not my provider. I need help with the APP, not my provider. Please advise.

  11. @firemom

    It is usually the case for the cause of a timeout to be related to either a poor internet connection, or slowness on your sever. I focused on the server option in my earlier post, but there are a few things you can try with your iPhone or iPad to determine if the cause is related to your internet connection.

    Make sure that you have a strong and reliable internet connection. If the timeouts are happening while you're on wifi, switch to cellular or a different wifi network. IF they happen while connected to a cellular network, try switching to wifi. The goal is to determine if the network you normally are connected to is the source of the timeouts.

    Hold down the power button on your iOS device, until prompted to slide to power it off. Turn off your device, then power it back on. Once the device is powered back on, see if the timeouts continue to occur. Cycling the power on your device is a way to refresh its network connections. The goal is to determine if your device's connection to the network is the source of the timeouts.

    Lastly, you can uninstall and reinstall the app. It is possible, though exceedingly rare, for an iOS app to glitch during the update process. Usually when this happens an app will not even launch. Even though it sounds like the app is functioning (apart from the timeouts you experienced) its fine to try this step as well.

    If you try the above and find that you are still experiencing timeouts when using the app, I would again urge you to follow up with your web host. The app does not communicate with your site in the same fashion as a web browser, and its possible for your site to load quickly in a browser and still be inaccessible by an app.

  12. The timeouts are happening: wifi, LTE 5 bars, power cycled, app uninstalled and reinstalled and, again, did NOT happen until the two most recent updates.

    It seems to me that if it's loading quickly in my browser but not with your app, that your app is to blame, not the server.

  13. going through similar things here. just want an app that works. i really miss the version where you can resize the images. never had any issues until the updates after it rolled out

  14. still nothing on this?

  15. still nothing on this? no updates or anything? still haven't been able to regularly update my site since May.

  16. request failed: not found (404)

    what does this mean?

  17. I posted my problem on another thread -- "Image Uploading - HTTP Error" (http://ios.forums.wordpress.org/topic/image-uploading-http-error?replies=7) -- and I guess I can re-posted it here since I too got the same problem -- and still no answer from the team:

    I have the same problem too. At first, I thought it was caused by iOS 8 in my phone so I tried using my iPad (I haven't updated it to iOS 8 should this kind of problems exist due to some compatibility issues on some apps.)

    On iPad, I tried uploading a picture just for a test. It worked. So I thought the problem then definitely on iOS 8. However, when I tried to upload the initial picture -- the "real" picture -- the problem appeared again ("Internal server error")

    This is frustrating. Just last week everything was fine.

    I wish the WP team would take a look on this :(

  18. i saw your post as well and wondered why no one responded. i've been having issues since may and nothing has really changed when it comes to being able to update regularly from my phone

    some people depend on this tech for work. this isn't going very well

  19. At this late stage I had long ago stopped trying, but quite out of nowhere and for no reason that I can fathom, a photo uploaded from the iOS app with no fuss whatsoever. So... good work, Team WP?

Topic Closed

This topic has been closed to new replies.


About this Topic