Forums

Moved wordpress directory, can no longer login via IOS app

  1. I recently moved wordpress from mysite.com/wp to mysite.com by following the instructions at

    http://codex.wordpress.org/Moving_WordPress

    Everything seems to be working fine since the move, except I can no longer login to my site via the WordPress IOS app.

    I have deactivated all plugins.

    I suspect I am having an issue with my xmlrpc.php file.

    If I go to mysite.com/xmlrpc.php I see my theme with my menu and my sidebar, but with a "404 - Page not found" error in the body of the page. I believe I am supposed to see "XML-RPC server accepts POST requests only."

    If I rename xmlrpc.php to xmlrpc2.php and then navigate to mysite.com/xmlrpc2.php, I do see "XML-RPC server accepts POST requests only." But when I rename it back to xmlrpc.php, I get the same 404 error.

    The permissions on xmlrpc.php are 0644.

    Does anyone see what I am doing wrong here? I would appreciate any suggestions. Thanks.

  2. What is your URL? It would be helpful if we could try pinging your xmlrpc.php endpoint ourselves.

  3. Thanks for responding Eric.

    It is deckpropowerwash.com

  4. Fixed it!

    My host was somehow blocking xmlrpc.php. It works now.

    Thanks again for responding, Eric.

  5. Fixed it!

    Yay! :)

Topic Closed

This topic has been closed to new replies.


About this Topic