Media Upload Failure and not posting

  1. I was so excited to have the size selector fixed and have been making regular posts on my blog for the first time since last May when all of the WP updates began to screw with my phone. Wouldn't you know with today's brand new update, things are wacky again. Can't post pictures, can't post words and can't update previous posts. It's says "update failed" above them.

    I've been happily posting for less than 10 days and this happens. I guess I'm happy to have had those 10 days.

    What could the issue be? Before last May I NEVER had a problem with my wordpress app. What do I do now?

  2. Hi David,

    I replied in the other thread also, but its getting rather long.

    So, what I gather is that you were able to create new posts, and they were showing up as Failed in the app, but some of the changes made were still showing up on your site. Was that correct?

    Next question: You mentioned you were able to post for about 10 days, then started seeing the fail messages. It sounds like when version 4.6 was released you were able to post without any trouble, but then with the release of 4.6.1 you started seeing the fail message. Does that sound correct?

  3. I am also not able to post pictures to my site. My wordpress version is 4.0.1 and my iOS app version is the newest 4.6.1 Every time I try to upload with a picture I get the error- Request failed: internal server error (500).

  4. My version is 4.6.1 on iOS 8.1.2, using and iPhone 6 Plus. I'm also using WordPress 4.1 Everytime I update a post using the 4.6.1 App I get told the update has failed, though it has updated and appears on the site. Any ideas what could be causing this?

  5. @dakay @jr_booth

    I've gone back and reviewed the changes we made for version 4.6.1 and I'm not finding anything that would account for what you guys are experiencing.

    I wonder if one of you would mind letting me trying to debug this directly? If so, you could create a new user on your site with an Editor role and email the credentials to "mobile at automattic dot com" to my attention, and reference this forum thread. I'd like to create a new post with a draft status (so it will not be visible on your site) and then try editing that post with the app. I'm hoping I can reproduce the error that you are seeing and maybe determine the cause.

    Let me know, and I'll do what I can to figure out what's going on.

  6. @blesch

    If you're seeing a 500 error you might find the info this this FAQ useful:

  7. Hi Eric,

    I'm more than happy to do this, I'll get on to it after my meeting and have it to you before I finish work.


  8. Hi, I've updated the app, deleted and re-installed the blog on the app and I'm getting these errors. They update find but it's a bit disconcerting for a client who is not used to technology


    the website is also

  9. @jr_booth Thank you so much! I promise to be on my best behavior with the test account!

    @pheyonagh, Thanks for the screen shot!

  10. No problem. Might not be obvious, on the web everything is fine and dandy no issues.

    I added a new post from the app and it worked, went to update and it came back failed. Just another note to add to the glitch.

  11. Hi @jr_booth. Just a quick follow up. I haven't seen an email and wanted to double check with you in case it got lost in transit somehow.

  12. Hi Eric,

    My apologies for the delay, this new editor log-in has ben sent to "mobile at automatic dot com"

    It should arrive with an automated e-mail.



  13. Any new developments? Tried uploading and posting as usual and the image upload times out and gives a 404

  14. @jr_booth, Thanks Jonathan! I have received the email and I'll be doing some testing this morning.

    @dakay I'll follow up here as soon as I'm able.

  15. @jr_booth.

    Hi Jonathan,

    Thanks again for letting me do some testing. Unfortunately, I was unable to determine the cause of the error. However, it did spark a couple of ideas.

    I noticed that you have the Jetpack plugin installed and I'm assuming you have entered your Jetpack credentials in the app to utilize the Stats and Notifications feature. This is interesting because Jetpack's JSON API module provides the app with an alternate way to communicate with your site. Normally, the app will communicate with a self-hosted site via its XML-RPC API. This is the default mechanism, and the one I used when testing (as I don't have your Jetpack credentials). Because of the differences between the JSON API and XML-RPC API, I'm wondering if you'd still see the error if you switched from one to the other.

    If you're willing to try, please try disconnecting the app from Jetpack. The easiest way to do this is probably to remove your site from the app, then add it back, skipping the step to connect to Jetpack. If, on the other hand, you haven't been using the app with Jetpack, maybe give that a try.

    Either way, if the failed error goes away it will be a good clue as to where the actual problem is.

  16. @dakay, @pheyonagh

    Are either of you using the Jetpack plugin on your sites? If so, would you mind testing my suggestion to @jr_booth and letting me know if it makes any difference?

  17. @eric - I have the same issue and am using Jetpack. I removed the site from my app and then added it again skipping the step to sign into Jetpack. I then updated my post title. The app indicated the update failed - but the title was actually changed. My website is
    Any help is appreciated - I use the app quite a lot to make tweaks to existing posts.

  18. Thanks @thinshaw. So if I understand correctly, the "Failed" status was happening no matter if you were connected to Jetpack or not?

  19. Hi @eric had a go by removing from the app and adding it again without signing into jet pack - unfortunately i didn't have any success with this.

  20. @Eric - that is correct

  21. @thinshaw @jr_booth,

    Thank you both for the follow up. It tells me that the issue probably isn't related to Jetpack. I'll keep hunting.

  22. No jetpack here

  23. Thanks @dakay.

  24. just to clarify from me @eric no jetpack here either

  25. Thanks @pheyonagh

  26. I see lots of problems popping up on the boards with this version of Wordpress -- do you think all of our issues will be addressed in this next release? I just realized I haven't posted at all this year because my last post was December 30 - then the app stop uploading my updates

  27. do you think all of our issues will be addressed in this next release

    We patched as many as we could for version 4.7 but I won't say we got them all for sure. :/ For instance, we've had no luck reproducing the "failed" issue so we're not sure if its fixed or if we're just missing the right combination of factors to reproduce it. (Tracking it here btw:

    As soon as 4.7 is approved we plan to submit a follow up (4.7.1) to Apple that contains a few more fixes that didn't make it into 4.7. Hopefully, between the two updates, we'll squash all the bugs.

  28. @eric Could the actual device be causing the issue? I've no clue what verision of iPad I actually have but it's about 2 years old.

    The other half has a brand new one, I'll see if it still 'fails'.

    Is the iphone app the same as the ipad one? Again I'll test it.


  29. @pheyonagh Its certainly worth considering. We haven't seen device specific bugs in the past but there's a first time for everything. If you get a chance to test I'm very interested to hear if it fails consistently on one device but not the other.

  30. I have the same "Update Failed" issues for every post I edit. The changes go through, they just now sit in a "failed" block at the top of my post list.

    It's the same on my iPad and iPhone. Very frustrating.

Topic Closed

This topic has been closed to new replies.

About this Topic