Forums

Media Library several issues (can't delete, can't add, can't update post)

  1. Hey everyone!

    I have a LOT of problems with the WordPress.com mobile app.
    Long story short: I have migrated my website annammetz.com from wordpress.com to wordpress.org (Bluehost). I still wanted to use the mobile app, so having Jetpack enabled, I was still able to post, update, comment, add/delete media and everything I did with the app when I was on wordpress.com and it all worked fine. All the updates were being updated on my wordpress.org site.

    For about 2 weeks, I’ve been getting several errors in Media Library.
    1. When I try to upload media, it gives me cURL error 28: Operation timed out after 30001 milliseconds with 0 bytes received. Basically it tells me that the image failed to upload. However, if I restart the app, the image is right there, next to the “failed” image.
    2. The images are being uploaded 2/3/4/5 times and I’m ending up with a million duplicates of the same picture.
    3. If I try to delete these duplicates, it won’t let me. “Unable to delete media item”
    4. Sometimes it won’t let me add images to posts.
    5. Other times, when I do manage to add images to posts from my Media Library, it won’t let me Update the post.

    Important note: This ONLY happens on my phone. I’ve tried this on several other phones, using the app with my account and everything works fine. I’ve reinstalled the app several times, the issues still occur. These issues DID NOT occur on my mobile app prior to migrating to wordpress.org.

    Can anyone please help?
    Since the mobile app is made by wordpress.com, I think it’s pointless to ask wordpress.org for support.

    The blog I need help with is http://www.annammetz.com.

  2. Hi there,

    First of all, thanks for all the info!

    This indeed feels odd and, according to what you mentioned (that the app + your account works from other phones), I believe there's something specific with your iOS device.

    1. Are you able to upload the same images, from your phone, but using your browser via https://wordpress.com/media instead?
    2. Does the issue happen with both WiFi and your data plan?
    3. Does your phone have free space?

    And to help us further diagnose the issue, it would be great if you could contact the app support from My Site and selecting the Profile icon on the upper right. Then, click on Help & Support and feel free to share your app logs from there.

    Thank you!

  3. Hello @Eduardo,

    I've resolved the issue today. It seems the problem was Jetpack. I've contacted Bluehost (for the millionth time) and this time they figured out the issue. There was a problem with the permissions of Jetpack. I can upload images now and I can use the app as before.

    Thank you!

  4. Fantastic!

    Glad it's working then, and thanks for letting me know!

Leave a Reply

You must log in to post.


About this Topic