Login and XMLRPC Errors(Solved)

  1. Hi,

    I thought I would share with you some of the errors I was having and how I solved them. I initially, like many others was not able to login due to the "Incorrect username or password" error. I thought I would point out some details that may seem obvious, but I was missing at first.

    *All these tips are for a self-hosted blog. Not sure if they are relevant to a blog

    1. Don't forget to include /wp-admin after your sites name in the URL box. This may seem like a no brainer but I was not putting this in at first. :) eg.

    2. Enable remote blogging in your wordpress setttings by going to: Settings>Writing> Now make sure the box is checked next to XML-RPC

    3. At this point you will want to add you username and password. Yet again, here is something I was doing wrong. I was adding my password to my website, the one that I use to add new themes or plugins. You need to be adding your username and password that you set up for your wordpress login, which may be different.

    4. Finally, I was getting the error "Unable to locate XMLRPC endpoint". To solve this you may need to do some digging, but most should be able to follow this example. When you enable XML-RPC in your Wordpress control panel, it adds a xmlrpc.php file to the directory of your website. You need to enter the URL for this file next to the XMLRPC. For most users, the location of this file should be in your root directory. So, you should be entering the following: If that is not working, login to your site with an FTP client and try to manually locate the xmlrpc.php file, and note the location, so you can enter the URL.

    5. At this point, you should be good to go.

    6. One more thing, most sites should make sure that HTTP authentication is set to OFF.

    Hope this helps some of you who are having problems.

  2. Tried all this, but not been successful so far. Still to FTP my site to see if the xmlrpc.php file is in another location.

  3. Thanks! In retrospect, specifying the full path to the wp-admin directory should've been obvious. That, and a conflict with Twitter Tools had been messing me up.

  4. I am about to give up. I can't get this to work. Arghh... I found the xmlrpc.php file and tried that still no dice.

    Any other ideas

  5. Same here - still no joy, despite following instructions, and even adding a new test user with no admin privileges (just in case!). Getting very frustrated here...

  6. @stuartfmurray, @thehig, @AnneLyle - could you please send us the URL of your blog so we can take a look? thanks.

  7. is my blog. I finally got it to work with my iphone but not my ipad. I have no idea.

  8. I've also not been able to access my blog on my ipad although I have tried the above suggestions multiple times! Any other ideas?

  9. OK, carrying this thread a bit further, I did what was above and still got the xml-rpc error. xmlrpc.php was in a wwwroot directory so the instructions above SHOULD have worked.

    Anyway, I noticed some of my URLs pointed to alias so my main url ( was redirected to a different location ( - this was a temp url from when I was setting up). Changing this setting in my settings/general to the URL got me past the xml-rpc error.

    So, I'm curious if any of you either have the same problem or something similar due to domain name redirection.

    BTW, I DID NOT need to provide /wp-admin for the URL - just may base URL

    Note, this didn't get everything working... as others have found, I also has to clear out some defaults in the advanced options to get past a series of 3 or four login errors (after a successful validation above)


  10. Mike McCallister, aka workingwriter
    Dec 15, 2010, 3:26 AM

    I've had no luck either connecting my iPod Touch with -- ever. When it appears that I've entered the correct path to XMLRPC.php, the app complains that the username/password isn't valid.

    Like AnnLyle, I even created a new user with Editor privileges, typed the password into the app -- no joy!

  11. Yeah this thing has been a real exercise in frustration. I did all the above as well, several times on both my iPhone 4 and my iPad and progress. I've seen just about every variation of the xmlrpc error and it finally caused me to wipe the app off both devices - again and give up. Of course being a dork that I am, now I REALLY want it to work, mainly because it doesn't.

    There just seems to be some kind of problem with the app. Most everyone who deploys the WP system to their blogs just upload the file package, so for most people I'd have to guess that the path to the XMLRPC.php file is right where it is supposed to be like it is for a million other why cant the thing find it??

    Its almost like a challenge now, I am re-reading every post on this trying to figure out what to do to get this to work...the real shame is this has taken so GD long that I have forgotten what the hell it was I wanted to remote post already...

    The silver-lining?

    it was free

    I guess the frustration was a bonus

    merry christmas!!

  12. Hey folks

    thought I would throw my 2 cents in since I was whining earlier. My solution was born of reading through these forums and also by contacting my webhost.

    I was getting the XML-RPC error like many, or the thing would just hang up forever.

    After some reading from here and there I decided to try to make sure my xmlrpc was accessible. I ultimately went to my control panel on my web-host and added a .htaccess file to my WP directory.

    on the .htaccess file I used (with the assistance of the webhost)

    <IfModule mod_security.c>
    SecFilterRemove 114

    saved it then retried the app on both my iPhone4 and my iPad (both using latest IOS)

    bear in mind, I am using a default upload of wordpress to my own server and it was installed to the root directory.

    I entered in the following:

    site: ( DID NOT ADD wp-admin)

    I clicked and it did its thing quickly and boom, it said good to go

    I then hit add blog and viola, there it is.

    Now, I have yet to USE it, but I can see my blog and I can see the posts and all that jazz on both my iPhone and iPad.

    So there is my take on the problems and I hope it helps someone!!


  13. Thanks for the tip about .htaccess, jpme226!

    Everyone else - have you guys tried updating to 2.6.3? If you still get the same result let me know.

  14. Hello!

    I know everyone here is on self-hosted WP blogs but I'm using the and I'm getting the XML-CRC error which I cannot do any changes to the settings (obviously). I'm using the Wordpress iOS 2.6.3 and I'm stuck! I can't set up my blog which has always been working before the update. I tried using the "Add blog hosted at" option - failed with "XML-CRC - Bad URL - Communication Error". I tried the "Add self-hosted Wordpress blog" option - failed with "Communication Error - bad URL".

    I don't know..this is very frustrating. Everything works fine on Safari and online. I can't remove "http://" cos it prefixes it automatically. I can't tell if this is an app issue cos I tried using another account and it works fine!

    Any idea? :(

  15. Mike McCallister, aka workingwriter
    Dec 23, 2010, 2:36 AM


    Happy to report that v2.6.3 worked for me! I included /wp-admin in the URL and included the full path to the XMLRPC.php file. Once I did that, I didn't get an error, saw the 'good to go' announcement--but I didn't realize I still had to click Add Blog to confirm! So I had to retype everything -- but then it worked! Posting also seems to work: Thanks!

    @ocrandom: I've never seen this issue with dotcom blogs. Are you certain you're typing your username/password correctly? It's so easy to fat-finger any text on the iPod/iPhone.

  16. Mike,

    I'm very very sure the password & username is correct. Totally am aware of the fat-finger problem! :D I can login, view the blogs under the account, select the blog that I want to add..and tadaa.."Communication Error - bad URL". It's so frustrating!

    I just had my email hacked yesterday and I have frantically changed most of my passwords. I thought it was the special characters in the pwrd that the Wordpress iOS 2.6.3 couldn't accept. I tested without the special characters and it still fails :(

  17. I cannot access my blog through the wordpress ios app (used to work, stopped working). I deleted the blog and tried to add it back -- now it says it can't find the XMLRPC endpoint. Even when I enter the XMLRPC endpoint URL by hand ( I get a 404 error in the wordpress app. any ideas?

  18. I have 3 different self-hosted blog with wordpress but using iPhone app I can't access to one of them...with the same problem regarding the XMLRPC endpoint. I Enter the URL but nothing changes...someone can help me please?

  19. I'm still getting the error "XML-RPC Error 406 unacceptable" when I try and authenticate

    URL = (get substituted with
    XMLRPC =

    Setting turn on in blog for XMLRPC
    .htaccess tried

    I'm done. Can't think of anything else to try. Anyone out there able to help?

    Thanks in advance for any advice.

    TimsterC ;o)

Topic Closed

This topic has been closed to new replies.

About this Topic