Forums

Local draft issue

  1. I have the latest version of the Wordpress2 iphone app and I've written some local drafts and I can't find them.
    I know they're supposed to appear above the posts in a Local Drafts section, but they don't. Any suggestions?

  2. That shouldn't be happening...

    Can you give me a step-by-step breakdown of exactly what you do so I can try and reproduce this?

  3. I start the app, go to Posts, write a simple "hello world" type post with the default setting of Local Draft, hit Save and I can't get it from the UI anymore.

  4. Seeing the exact same thing here. Tried writing a post with the app for the first time tonight, doing the same thing mentioned above by cmsj and the post disappeared - can't find it anywhere...

  5. Where should one file a bug? :)

  6. @cmsj and @haggaret -- can you guys provide a few details about your setup. Which version of WP or WP.com ? And is your iPhone jailbroken ?

  7. Hey raanan, sorry for the late reply - is there a way to subscribe to updates on topics you've replied to?

    Anyway, to answer your questions, I'm using WP 2.9 on a self hosted blog. My iPhone was NOT jailbroken at the time, but it is now and I'm getting the same behaviour. I'll ssh into the phone and see if the posts are actually being saved or not...

    If you need any specific info, let me know.

    Thanks
    Kevin

  8. @raanan: WP 2.8 at the time of the error, 2.9 now. Using version 2.1 of the client. my iPhone is not jailbroken and never has been.

  9. cmsj,

    I can't reproduce - local drafts reliably show up on my install...

    Does this happen every time or just occasionally?

  10. Everytime.

  11. yeah every time. I've made several local drafts and I've never seen them. How do you store the drafts? I'm guessing it's sqlite? Maybe because I started using the app as soon as v2 was released I have an old/broken database?

  12. No, it's not sqllite. This is strange - I cannot reproduce.

    Have you tried deleting and re-installing the app?

  13. Deleted and re-installed, and a test local draft appeared right away and I'll obviously have lost the ones I'd written previously.
    Best of luck figuring it out!

  14. Can you give me a step-by-step list of actions to reliably reproduce this? I know it sounds silly, but sometimes the smallest details make the difference...

    If I do the following, the draft post is available...

    1. touch the button to create a new post
    2. add a title
    3. add something to the post body like "1234 test post"
    5. touch the done button to dismiss the keyboard
    4. touch the save button

    The draft post appears in the listview that comes after selecting save

  15. CMSJ - do you use http authentication to log into your blog?

    Another user posted something that suggested this may be a key component in reproducing the problem...

  16. Same problem here. Latest version of Wordpress2 on a late 2009 iPod Touch (not jailbroken) connected to a community-hosted instance of Wordpress MU (version currently unknown) with HTTP authentication turned off.

  17. I am having the same issue but on Wordpress 1.2 and my phone is not jail broken. I have two local drafts that are not appearing. The folder says there are two local drafts and I can't access them. They don't even appear when I go into the folder. I just downloaded Wordpress 2 and that is fine. But I need the drafts in the older version. I have a wordpress.com site

  18. I saw your post on the other forum... Did you have drafts that were not appearing in an older version of the app and then you downloaded the latest version of the app?

  19. If you make a new local draft in the latest version of the app, does it disappear also?

  20. Similar problem. Conditions: borrowed WiFi, iPod Touch 2G (not jailbroken) with OS 3.1.2. WordPress app was installed yesterday, Feb 2. WP is my own installation, running 2.9.1 at aylwinlo.ca/blog

    Rough steps:

    1. Paste contents of post from Notes to new post in WordPress app.
    2. Publish. Wait a long time.
    3. Grey matte appears that usually precedes a modal dialog, but modal dialog does not appear.
    4. After a few minutes, press Home to quit. WordPress quits normally.
    5. Restart WP app. Draft is still there, try to publish again.
    6. This time app reports no connection (though status bar shows there's a wifi connection). OK, quit.

    ... time passes...

    7. At home, sync to Mac at home (most recent iTunes & OS X), recharge, listen to music. No WiFi connection.

    ... time passes...

    8. At work, connected to reliable WiFi, open WP app. Draft post appears for a moment under Published, then disappears entirely.

    Let me know if I can provide anything to help w/ debugging.

  21. Just had the same thing happen, NOT amused.

    Wrote nearly the whole post, saved it, and when it went back to the list of posts, it wasn't there.

    Using the latest version of WP on iPhone, iPhone OS is 3.1.2, not the latest 3.1.3. iPhone IS jailbroken, even though this should have absolutely no bearing on the app whatsoever.

    How can I get to the post without deleting the app & losing the post?

    WP blog is 2.9.1, but that shouldn't matter either.

  22. I'm currently investigating a bug that has similar symptoms. Any chance you used the "more" tag in that local draft? If so, I'm pretty clear about what went wrong and possible solutions...

    As for recovery, if you saved it to your blog, it should be there, if it's a local draft you can probably get it from an iTunes backup, although that's a bit arduous... If it is a local draft, do NOT save to the blog as that will probably lose it...

    Naturally, we're very sorry about the frustration - few things more frustrating than losing work like this.

    Write back and let me know...

  23. I just had this happen to me as well... wrote out my post, had two pictures attached, tagged it with two new tags, added it to a new category, was in the body section and (here's what I think the problem might be...) I hit 'Save' without hitting 'Done' to dismiss the keyboard.

    It paused a moment after clicking 'save', but then went back to the list of posts that now only contained one local draft that was completely blank (wish I knew if it were there prior, but I don't think so.)

    Will now attempt same thing but avoid hitting 'Save' prior to hitting 'Done'.

    Running WP4iP 2.2 and WP 2.9.1 on self host box.

  24. That's a great description of how to reproduce - thanks!

    I'll check into it. Is there any chance you were using the [!--more--] tag in that Local Draft? We've identified a bug that will display an empty text view if the more tag was in the post...

  25. I'm currently traveling through India so I blog on my iPhone and then upload posts when I come across the sporadic points of wifi I find. I had 5 or 6 Local Draft posts in my iPhone when I found a wifi spot and attempted to upload (my favourite) post only to find that the connection was not actually working even though it appeared to connect perfectly.

    I selected Local Draft and changed it to Published which produced the spinning/hourglass thing that could only be removed by closing the application.

    And now, I can't even open my blog! I'm not even sure if the Local Drafts are there! I open the application and go to tap on my blog and nothing happens!

    The previous version of WP on my iPhone is opening but the Local Drafts aren't there (which I can understand to some degree...)

    Help!?!?!?!

    Teddy

  26. ateddy,

    If you have a Mac we may be able to recover the posts. Unfortunately there are some outside cases (like what you describe) where the app will get stuck and won't open. I've had a very hard time reproducing that.

    Data should still be there. If it's important, do not delete the app.

    For recovery process we'll need a mac with iTunes and for you to connect your phone and allow a backup to occur. Let me know if that's possible for you... If it is, we'll take it from there... We'll have to dig deeply through those backup files on the Mac, but it should be possible...

    If you don't care that much about the drafts, you can delete the app and re-add your posts... oh, by the way, you may want to check if that post you were saving made it to your blog. If it did, it will come back after deleting and re-installing the app.

  27. Hi,

    For my part, I don't recall whether I had a "More" link in there yet. Would have to check through a backup, I guess?

    Aylwin

  28. I am having similar problem when saving to a local draft post. I am not adding photos or images, just adding text. I save and the post is there but without any of the stuff I just types. This has been going on for a while now. Same before and after upgrade.

  29. Are you using the "more" tag inside the text of the post? We've just discovered (and killed) a bug there that reproduces your symptoms...

  30. whitespider1066
    Member
    Mar 9, 2010, 6:29 PM

    I have been having problem with local drafts I create a post save it locally, go back in to add more, save it still as a local draft, go back in later to add more text and the changes I did previously are gone.
    Kind of makes it unusable.
    this is v2.2 of the app as well, so far v2.2 has made me wish I hadnt installed it with this and the posted image size going super large as well.

Topic Closed

This topic has been closed to new replies.


About this Topic

Tags

No tags yet.