Forums

List of posts/pages made not appearing (iOS)

  1. So I'm looking on our private Wordpress site via the app on iPhone as well as iPad. private as we have a login prior viewing the actual page.

    Under Pages, there's only two items listed, a post from 29th April 2011 and one for 21st January 2011.

    Under Posts, there's two of the same page both for the same date and time.

    Assuring that we've got more than just those posts on our actual website (of course we can view them no worries on the dashboard via the web browser).

    What's going on? *scratches head* I'm kind of new to all of this wordpress stuff.

    If there's any more questions you guys would like? please let me know :)

  2. Are you running a plugin that makes the blog private? Also, is the account you are accessing the site with an administrator?

  3. Hiya,

    Am I running a plugin that makes the blog private? Quite possibly, I'll talk to the web guy about that :) as for the account I use? yes, I've got admin rights

  4. You should try with the default theme and with no active plug-in.

    (Trying it with the default theme and plugins disabled will help pin down where the problem is. If everything works then you go back and enable your theme and then try it again. If everything still works then you go back and activate each plugin one at a time until you find the one that is causing the breakage.)

  5. Thanks folks, I'll check it out more once we make the site more public. Then we can remove that private prompt at the start :)

  6. Okay so the website now is public, and the privacy bits are removed and yeah, still only some of the posts are appearing in the posts list on the app :|

  7. Bumping, because I'm in dire need of help. I've tried to disable plugins, and it made no difference :/

  8. I had a friend debug this with me:

    Disabled all plugins, changed theme - still not working.
    He was able to write a simple XML-RPC client in python to connect to the Wordpress installation, and was able to pull out information no problems.

    We have uninstalled & reinstalled the Wordpress for IOS application several times, no dice. No useful information in the server xmlrpc logs and/or Wordpress for IOS log file:

    2011-11-14 10:26:35 +0000 <PageViewController: 0x250190> viewDidLoad
    2011-11-14 10:26:38 +0000 <WPDataController: 0x2c1050> executeXMLRPCRequest: wp.getPages http://www.retrospekt.com.au/xmlrpc.php
    2011-11-14 10:26:39 +0000 <WPDataController: 0x2c1050> errorWithResponse: (null)

  9. If you want to double check that your blog's XML-RPC API is working correctly, I'd also recommend testing it in a desktop app (such as MarsEdit). MarsEdit interacts with your blog the same way the WordPress app does.

    I suggest you to turn on the php log in your php.ini configuration, and check the php error log file, as well to check the web server log.

  10. Thanks for the reply - we've already debugged the XML-RPC API and that's working perfectly (please see my last post).

    I have downloaded MarsEdit, and that works perfectly. No errors on the server, including with php logging on. It is only Wordpress for iOS which is not working properly. Refreshing sometimes does nothing, sometimes brings up 1 more item.

    Please see screenshots.

    MarsEdit:
    http://i.imgur.com/7KS9U.png
    http://i.imgur.com/LlrfB.png

    Wordpress for iOS:
    http://i.imgur.com/G6qKT.png
    http://i.imgur.com/JESg8.png

  11. Any suggestions folks?

  12. I was having the same issue yesterday with a new install. Most of my entries were imported from Tumblr so the post ids were all 10 digits long. This morning I created an xref table and renumbered the posts starting with 200 and everything is working on my iPhone and iPad. I also use MarsEdit and saw the same thing, worked fine from there but not the app.

    Not sure if it's coincidence or the actual problem but thought I'd share.

  13. Awesome, thanks for that, I'll check it out :)

  14. Hey there, so after looking at it, that didn't seem to make a difference at all! :( as I have posts made in Wordpress, and others made in Tumblr, and once again they're still not appearing.

    This is ridiculous, as this has been ongoing for so long now. I appreciate your tip bigjim01, but after testing that out, it didn't seem to work.

Topic Closed

This topic has been closed to new replies.


About this Topic