Forums

Latest Posts/Drafts not showing in iOS App

  1. Hi,

    I'm using the current version of the Wordpress App on my iPhone (iOS7) and on my iPad (iOS) and one both devices I can't see my latest posts and drafts.

    According to the App the last post is from Nov 17th while in reality there are two newer posts from this and last week. I also can't see all my latest drafts and therfore can't use the App to publish them.

    It's all fine in the browser.
    It's also everything (stats, comments, ...) fine within the App, except for the "Posts" section.

    My Blog: http://www.hqcovers.net
    It's a wordpress.com hosted site.

    This issue came out of the blue, I'm sure it still worked a few days ago.

    I've reinstalled the App on both devices - no change.

    Please help, thank you!

  2. Hi there,

    I'm really sorry you're having this problem! Would you be able to go to Settings > Support > Contact Us and write a brief note detailing this, in your app? We'll be able to see a bit more of what's going on behind the scenes that way.

    Cheers!

  3. I've installed the latest update, which was released today and still no change.
    This is reall annoying! Can you even reproduce this error or am I the only one with this issue? Are you addressing it in one of the next updates or am I waiting for nothing?

  4. Hi anakin022,

    Were you able to reach out to the WordPress support folks like Zandy suggested? Its a chat feature built into the app where they can assist you in almost real time. If you haven't had a chance yet you might give it a try.

    As far as the missing posts go, its not quite clear to me what could be happening based just on the description. Could you share links to some of posts that are missing from the app? Maybe there is something about them that could point to what might be happening.

  5. Yes I did. Support told me that something in my account got resetted, but that didn't help. It was furthermore refered to the next app-update, that's why I'm asking again.

    This is the most recent post I see in the app:
    http://hqcovers.net/2014/11/17/interstellar-by-hans-zimmer/

    The following posts are all missing within the app:
    http://hqcovers.net/2014/12/08/the-hobbit-the-battle-of-the-five-armies-by-howard-shore/
    http://hqcovers.net/2014/12/15/game-of-thrones-by-ramin-djawadi/
    http://hqcovers.net/2014/12/23/nightcrawler-by-james-newton-howard/
    http://hqcovers.net/2014/12/30/aliens-by-james-horner/

    I also have no idea what's going on. This problem came out of the blue on two devices (iPhone, iPad)

    And out of curiosity I just checked it on my old iPod touch too. Because of iOS5 I had to install the WordPress version 3.7.1 and guess what, everything's totally fine.
    So the error is definitely within one of the latest app-updates.

  6. Hi anakin022

    Thanks for following up. Sorry the conversation with the support folks didn't resolve things. :(

    I did some digging, and I think I can offer an explanation. The short version is, if you make the posts not be sticky, then they should show up.

    The long(er) version, the app communicates with your site via a service on WordPress.com. Older versions of the app used an XML-RPC service, while later versions use a different service, the WordPress.com REST API. I won't go into the techy details about the services (unless you ask me to) but it turns out the first version of the REST API has a bug where sticky posts aren't being sent to the app. Just like the iOS app has different versions, the REST API has different versions, and the bug that was preventing sticky posts from being returned has been fixed in the latest version of the REST API. Unfortunately, the current version of the app is using the original buggy version of the REST API.

    Did all that make sense?

    Now that we're aware of the problem (and thank you for making us aware of it!) we'll update the app so it uses the newer version of the REST API.

    In the meantime, you can get the posts to show up in the app by removing the sticky flag. I know that's not ideal but hopefully its manageable.

    I hope this helps!

    Eric

  7. Hello Eric,

    that's great news and I'm very much looking forward to the new update!

    As a long-time user and supporter of your app, it just irked me too much too see it not working properly (as in the past). Even better now that I could help, albeit involuntary ;)

    Thanks
    anakin022

  8. that's great news and I'm very much looking forward to the new update!

    Yay! One thing about the update: because of the way our release schedule works (and the way Apple has to approve updates) the fix won't make it in the 4.7 release. Look for it in version 4.8. Hopefully the wait won't be too long.

Topic Closed

This topic has been closed to new replies.


About this Topic