Forums

Jumping to the end of text after each input

  1. Hello

    I've experienced a problem and it appears on iPad iOS 4.2.1 as well as on iPhone iOS 4.1. I tried different devices with the same result:

    If I want to put any letter or other sign anywhere of any phrase, or even when I try to delete any previously written sign, the cursor is moved to the end of the text. To edit something I have to jump to desired place after each pressed key! It's extremely annoying.

  2. Yup, it is annoying! We submitted a hotfix to apple last Friday, so it should be out soon.

    http://ios.forums.wordpress.org/topic/cursor-jumps-to-end-of-post-when-editing-earlier-text?replies=7

  3. Having deleted my first post full of screaming . . .
    While I have loved using it, I have had troubles since I started using the Wordpress ipad app about 2 months ago with it crashing halfway through a post when uploading a photo. Usually the fourth or fifth photo. Whatever text I had typed since the last upload of a photo would be lost. I got used to copying the text before uploading each photo.
    As a consequence I have been looking out for updates. The first update I uploaded, about 3 weeks ago, caused my portrait photographs to be displayed in landscape format, but did not change the crashing problem.
    Then last night, European time, I found a new update. Only to find that it had turned the app into something that cannot be used. I typed some text, then uploaded the first photo. All my typed text was gone. Then when I tried to retype it, I found the problem others have mentioned - ie that the curser immediately defaults to the end.
    Reading the posts above it seems that the problem has been known for some days. Shouldn't the 'update' be removed until it has been fixed? It is rendering the app useless.
    Is there an option to upload an earlier version that does not have the problem?

  4. The 2.8.2 update was just approved, look for it in the app store!

  5. Initially I thought 2.8.2 update was a dream. All the bugs were gone, including the cursor issue - even the crashing that had plagued me from the start. However after using it for about an hour, during which I completed a post previously written, I started a new post and found the issue of all text being deleted when I uploaded a photo had returned. I closed down and rebooted the ipad. That seemed to fix it and I finished a second post. This morning I found that much of the new material in the first post and all but two of the photos of a second post that I had completed and, I thought, updated last night had gone from the ipad. Some problem saving it would appear. I was enjoying using the app until the recent updates, but having lost so much time and work I am thinking I need to find another blog option.

  6. I wonder if there's a specific scenario that causes the text to be lost like that? I've tried to reproduce the issue myself but haven't had any luck yet. If you can provide exact steps it would really help us out!

  7. I have replicated the problem 3 times now. The first two times I did this. I opened a new post and typed some text. Then I uploaded the first photo. When I returned to the post the text I had typed had gone. However those first two times I found that after that I could continue without a problem. On the third occasion the problem persisted. One work around was to keep updating the post - then when I uploaded a new photo it would only 'lose' the text since I last updated the post. It seems to be a saving problem. With this last post I find that when I 'cancel' there is no option to save what I have done to date. If I have not uploaded a photo since I last updated it does not even give me the error message telling me that any changes will be discarded - it is as if it does not realize I have typed any text. I am not sure why the problem was only with the start of the first two posts, but continued with the third. Must have done something the first two times to 'save' that I did not do the third time. Perhaps the first two times I saved it in draft once before I posted it, while the third time I just went straight to update without first trying to save a draft, and now there is no save draft option. Another odd thing, that does not seem to affect the outcome, is that the first picture that I upload in each post is missing some of the script that identifies it as a photo. All other pictures start with the text

    before continuing with <a href="http etc - but the first photo each time does not have that initial text. As I said, does not seem to stop the photo appearing so perhaps not important. Looking forward to the fix that will repair the saving issue.

Topic Closed

This topic has been closed to new replies.


About this Topic