Forums

iPhone App crashes when adding a blog

  1. Hi,
    I'm currently running a few blogs using the latest WP3.0 in a multisite, self-hosted environment.

    My home blog is accessible somehting like http://sub.domain.com/blog and all other blogs are http://sub.domain.com/blog/whatever.

    When trying to add any of these blogs, the iPhone App crashes without any error, after a a few seconds of the spinning "Validating blog..." thing. I've tried with several account, made mistakes to check if errors arise in those cases (they do!), the problem only comes when everything is.. correct !

    I've also tried the XML-RPC checks of the FAQ, and everything is fine too.

    Tried also to disable all plugins (well, I only had the geolocation plugin), but unfortunately, it didn't help...

    Any idea ?

    Thanks!

  2. A few details that may help :
    - WP3.0
    - iOS 3.1.3 on a 3GS
    - Wordpress app 2.4

  3. I have the exactly same problem as yours.

    but the iPhone App works with site that use Wordpress 2.9.x. It works fine.

  4. Same problem here.

    iPhone 3G
    iOS4
    WordPress for iOS v 2.5
    WordPress 3.0 multisite self-hosted

    Seems to maybe be incompatibility between iPhone app and WP3?

  5. Same same same ... started happening with WP3 alpha/betas/RCs and continues with GM.

    * Iphone 3GS
    * iOS4
    * WP 3 multisite self-hosted (dreamhost)
    * mu sites setup as sub-folders FWIW

    Attempted to add a blog with no luck. Deleted WP for iOS, reinstalled app from App Store ... still crashacrashacrasha.

    Now WP for iOS crashes on launch after attempting to add a WP3 blog. It won't even open.

    Earlier I tried to follow some threads here to fix this problem during pre-release period but to no avail. My host hasn't changed anything.
    Love this app, not sure how to dive in and trouble shoot anything deeper yet, rather, not sure how to debug.

  6. OK, could everyone who has posted previously verify one thing for me to help me track this issue down:

    Did the issue with your multisite 3.0 blog exist prior to the 2.5 update, or did it begin with this version?

    Thanks everyone!

  7. I also have the same problem.
    It started when the 3.0 beta releases etc were released.

    *iPhone 3GS
    *iOS3(something, something)
    *WP 3.0 self hosted
    *all located in the root folder

    The problems are prior the 2.5 update @frsh

    It's very annoying.... And I do not want to downgrade myself to 2.9.2...thanks...

  8. I had the same problem.

    To Frsh (Moderator),
    I migrate my MU wp site to WP3.0 a day before iOS 4 is launch.

    Thus, you may said it's all new WP3.0 with iOS 4 new wp for iphone. Like the symptom mention by another thread, the gets to the validation alert, showing the blog title and it crash, there after I can't setup the apps on iphone at all.

    WP 3.0
    WP iPhone 2.5
    iOS 4

  9. Existed after I started using WP 3 alphas, through RC. The iPhone app version hasn't mattered.

  10. Just wanted to add that I'm having the exact same issue.

    Wordpress 3.1 Alpha Self Hosted (Multi-Site + Domain Mapping)
    WP iPhone 2.4 & 2.5
    iOS 3.1.3
    iPhone 2G (The Original)

    Add a site and app crashes on Validating Blog Screen. Now it won't open at all. The App crashes on launch.

    Looking forward to the bug fix.

    :)

  11. Same thing happening to me after I upgraded to WP3. Running iOS4 on an iPhone 4 with MultiSite.

  12. Updated everything on my 3GS :
    - WP app 2.5
    - iOS 4.0
    - still using WP3.0 (french) with multisite enabled

    The crash is a bit different :
    - 10s of "Validating blog" with the spinning thing
    - 3/4s of "Adding -name of the blog-..." then crash, no error...

    @frsh : please contact me privately, I can open a blog and give you access to it if you want to try.

  13. And well, after a blog has been (unsuccessfully) "added", the app crashes at startup, after 3 seconds of the WP logo...

  14. Any News or Updates on this?

    I'm really struggling right now... cause I can't update my blogs from my iPhone anymore. There are really no other good alternatives.

  15. began with this one.

    FIX IT NOW PLEASE!!!!

  16. is their an update the for the app yet?

  17. @a-kyle

    Dude, I want a fix as much as you do, but do you REALLY think pestering the dev team is going to get an update any faster?

    This is a free app, the dev team are probably volunteers, it's the weekend, and on top of that it's a freakin' HOLIDAY weekend here in the US.

    When you pay developers, you have a right to demand results. But when you DON'T pay them, you ask politely and then wait for a fix.

    So calm down and stop posting daily demands for an update.

    You have an iPhone, for God's sake. Use the freakin' browser and run your blog from the regular admin pages. Sheesh!

  18. Hi.

    Please open “your/wordpress/directory/xmlrpc.php” in any text editor, and rewrite the line 477,
    'blogid' => $blog_id,
    to
    'blogid' => (string) $blog_id,.

    Yeah! Now, you can use WordPress for iOS!

    Cheers!

  19. Hi there - i had the same problem but trying hirokikatos fix did work for me.
    Greetings, mojobox

  20. Hi there, hirokikato's fix also worked for me ! Thanks !

  21. Hi, hirokikato's fix worked for me too. Gosh WordPress, this is so bad.

  22. I tried it on my blog and it didn't fix it :(

    Glad it worked for some people. Pity it didn't work for me.

    I get the usual "XML-RPC server accepts POST requests only." if i go to the xmrpc file on a browser and still cant post to the blog in the iphone app. I get the "Communication Error: Bad user name or password."

    Maybe someone can help :
    hirokikato, you seem to know your stuff. What do you think?

  23. Worked like a charm, Hiro.

    Thanks!

  24. Congratulations mojobox, ChezMoe, ykteng and nickscipio.
    Well, my fix is a temporary solution.
    I hope WordPress core will be fixed soon.

    smcgarr, I'm sorry about my bad English.
    Please connect with FTP/SFTP to your web server, open “your/wordpress/directory/xmlrpc.php” with any text editor not web browsers.

  25. Well, I have the same problem
    App crashes on iPhone and on iPad :(

    - WP 3.0 MU
    - WP app 2.5
    - iOS 4.0

    On a 3G iPhone and a 16Go iPad Wifi

  26. Scott Winterroth
    Member
    Aug 2, 2010, 4:01 AM

    Same problem. WP 3.0.1 with multisite and domain mapping. Crashes on both iPod touch iOS4 and iPad. I really need this app please!

  27. Update for everyone: This is resolved in the upcoming release, 2.6. Thank you for being so patient.

  28. Joseph Mainwaring
    Member
    Aug 11, 2010, 5:40 PM

    Chris you the man, any ETA on when we can expect 2.6?

  29. Peter Holme Obrestad
    Inactive
    Aug 28, 2010, 11:24 PM

    this patch worked for me as well :) just one thing.. you said to change line 477 to:
    'blogid' => (string) $blog_id,.
    but I think there is a '.' too much. All worked well when I lost the dot.

    Thanks for a great app!

  30. alright it seem that everyone has same issue.. but patched work for me as well thanks much

Topic Closed

This topic has been closed to new replies.


About this Topic