Forums

iOS, self-hosted + jetpack, saying cannot connect to Jetpack site

  1. I'm running a self-hosted site on DigitalOcean. I'm having one hell of a time trying to get the Wordpress iOS app connecting. I have:

    • disabled xmlrpc 301 redirect -- enabled by default from DO's Wordpress "image"
    • Installed Jetpack
    • Disabled brute force attacks
    • install CloudFlare add-ons - CloudFlare Plugin and SSL Plugin
    • Putting Cloutflare in Dev mode
    • Using PAW to replicate calls

    And I still cannot get connected with the iOS app.

    I'm on a personal VM, running Apache, Wordpress 5.1.1, Jetpack freshly installed, DNS going through Cloudflare.

    Nothing I do seems to allow the iOS to connect to my site. Any idea what's going on?

    Here's the log trace (with domain filtered out)

    108.162.216.54 - - [05/Apr/2019:18:11:35 +0000] "GET / HTTP/1.1" 200 6618 "http://www.mysite.com/" "WordPress.com; https://public-api.wordpress.com"
    108.162.216.84 - - [05/Apr/2019:18:11:36 +0000] "GET /wp-json HTTP/1.1" 200 142449 "http://www.mysite.com/wp-json" "WordPress.com; https://public-api.wordpress.com"
    172.69.170.36 - - [05/Apr/2019:18:11:36 +0000] "GET /wp-content/plugins/jetpack/wpml-config.xml HTTP/1.1" 200 486 "http://www.mysite.com/wp-content/plugins/jetpack/wpml-config.xml" "WordPress.com; https://public-api.wordpress.com"
    172.69.170.78 - - [05/Apr/2019:18:11:36 +0000] "GET /wp-content/plugins/jetpack/readme.txt HTTP/1.1" 200 5334 "http://www.mysite.com/wp-content/plugins/jetpack/readme.txt" "WordPress.com; https://public-api.wordpress.com"
    172.68.58.253 - - [05/Apr/2019:18:11:36 +0000] "POST /xmlrpc.php?for=jetpack HTTP/1.1" 200 451 "http://www.mysite.com/xmlrpc.php?for=jetpack" "The Incutio XML-RPC PHP Library"
    172.69.170.12 - - [05/Apr/2019:18:11:36 +0000] "POST /xmlrpc.php?for=jetpack&token=UdDuQgl6Dx1%25VbCbiW%24U%40%28uKH%2AB%26GjuZ%3A1%3A1&timestamp=1554487896&nonce=xbP8XHCBA7&body-hash=pdst%2B%2B8gjpsEsdzTGdS19%2BYN3g4%3D&signature=ypotysLf5PNwJunk8YFpXxENtzk%3D HTTP/1.1" 200 438 "https://www.mysite.com/xmlrpc.php?for=jetpack&token=UdDuQgl6Dx1%25VbCbiW%24U%40%28uKH%2AB%26GjuZ%3A1%3A1&timestamp=1554487896&nonce=xbP8XHCBA7&body-hash=pdst%2B%2B8gjpsEsdzTGdS19%2BYN3g4%3D&signature=ypotysLf5PNwJunk8YFpXxENtzk%3D" "Jetpack by WordPress.com"
    162.158.74.125 - - [05/Apr/2019:18:11:37 +0000] "POST /xmlrpc.php?for=jetpack&token=UdDuQgl6Dx1%25VbCbiW%24U%40%28uKH%2AB%26GjuZ%3A1%3A1&timestamp=1554487897&nonce=MMSv8z32x5&body-hash=pdst%2B%2B8gjpsEsdzTGdS19%2BYN3g4%3D&signature=H%2F7mDAw9msrND1WGWR1Pm0e%2BgFY%3D HTTP/1.1" 200 438 "https://www.mysite.com/xmlrpc.php?for=jetpack&token=UdDuQgl6Dx1%25VbCbiW%24U%40%28uKH%2AB%26GjuZ%3A1%3A1&timestamp=1554487897&nonce=MMSv8z32x5&body-hash=pdst%2B%2B8gjpsEsdzTGdS19%2BYN3g4%3D&signature=H%2F7mDAw9msrND1WGWR1Pm0e%2BgFY%3D" "Jetpack by WordPress.com"

    It returns "We're not able to connect to the Jetpack site at that URL." on the Wordpress iOS app

  2. I deactivated Jetpack and these are the requests:

    172.69.170.84 - - [05/Apr/2019:18:15:31 +0000] "GET / HTTP/1.1" 200 5747 "https://www.mysite.com/" "WordPress.com; https://public-api.wordpress.com"
    172.69.170.36 - - [05/Apr/2019:18:15:31 +0000] "GET /wp-json HTTP/1.1" 200 78329 "https://www.mysite.com/wp-json" "WordPress.com; https://public-api.wordpress.com"
    162.158.74.167 - - [05/Apr/2019:18:15:32 +0000] "GET /wp-content/plugins/jetpack/wpml-config.xml HTTP/1.1" 200 486 "https://www.mysite.com/wp-content/plugins/jetpack/wpml-config.xml" "WordPress.com; https://public-api.wordpress.com"
    172.69.170.84 - - [05/Apr/2019:18:15:32 +0000] "GET /wp-content/plugins/jetpack/readme.txt HTTP/1.1" 200 5335 "https://www.mysite.com/wp-content/plugins/jetpack/readme.txt" "WordPress.com; https://public-api.wordpress.com"
    172.69.170.78 - - [05/Apr/2019:18:15:32 +0000] "POST /xmlrpc.php?for=jetpack HTTP/1.1" 200 451 "https://www.mysite.com/xmlrpc.php?for=jetpack" "The Incutio XML-RPC PHP Library"
    172.69.170.84 - - [05/Apr/2019:18:15:32 +0000] "GET /wp-login.php HTTP/1.1" 200 1561 "http://www.mysite.com/wp-login.php" "WordPress.com; https://public-api.wordpress.com"
  3. According to Jetpack's Debug tool, "Everything looks great!"

    Everything looks great!
    All tests have passed for http://www.mysite.com and your Jetpack powered site looks good to go! If you're still experiencing trouble working with Jetpack, please check out the following resources:

Leave a Reply

You must log in to post.


About this Topic