Forums

iOS app no longer updates comments after HTTPS implementation

  1. hi folks,

    (cross-posting this here after initial posting on the WordPress.com forums (http://j.mp/1PAUBFT) -- I only just discovered this dedicated iOS WP forum.

    Hope you're all well. Firstly let me say that I have been working with WordPress for many years and am completely addicted to it. Thanks to everyone in the community for your hard work on it :)

    And now on to the issue I am having ... I run a largish independent technology news site, Delimiter (https://delimiter.com.au).

    I have spent many years moderating comments via the WordPress iOS app. However, some months back we implemented HTTPS on Delimiter. Now, the comments no longer update and do not show new comments in the WordPress iOS app. The comments will renew if you delete the app from iOS and then reinstall, but will not update after that point.

    Can someone clarify what the issue is here and how to fix it? My site is hosted with Pagely.

    Kind regards,

    Renai LeMay

  2. Hi @renai42

    Sorry to hear about trouble with comments. Let me ask a couple of questions to help me narrow down what the issue could be.

    - Is the Jetpack plugin installed on your site? It doesn't look like it but I want to confirm since it affects the way the app syncs comments.

    - Are you seeing any error message at all?

    - When you pull to refresh the comments list does it look like the app is trying to fetch new content?

    - If you scroll all the way to the bottom of the comments list do you see a loading spinner?

    - Does the problem also affect the Posts and Pages list or is it just affecting comments?

    - You mentioned the problem seemed to start around the time the site switched to HTTPS. Have you tested without HTTPS enabled?

    - Have you tried temporarily disabling any third-party plugins to see if one might be causing a conflict?

    Okay, so that was more than a couple of questions, but hopefully the answers will help narrow down what it could be.

    One other thing that might be helpful is to have a look at the app's activity log to see if it contains any clues. The logs are located under the "Me" tab > Help & Support > Activity Logs. If you would, follow these steps:

    - go to the "Me" tab > Help & Support and enable "Extra Debug"
    - go back to the comments list and pull to refresh
    - when the refresh ends scroll to the bottom of the list to trigger the app fetching the next batch of comments for the list
    - go back to "Me" tab > Help & Support > Activity Logs > Current and get a copy of the log.

    If you share a copy of the log here I'd be happy to look take closer look.

    Thanks!

    Eric

Topic Closed

This topic has been closed to new replies.


About this Topic

Tags