incorrect username/password - self hosted site

  1. Thank you sarahk07. Your solution dated Nov 17 2010 worked. I'm delighted.

  2. awesome sarah!! thanks so much, worked like a charm

  3. @ChrisBoyd do I need to have a different login other than admin to use the app? It's not working, and it was working fine at one point. Do you know when the problem with it will be fixed?

  4. sarahk07 you're my hero!

    thanks for sharing...

  5. i've tried all of the solutions provided so far. no joy.

    here's what i'm putting in to the required fields:
    URL =
    username = nocurling (that's my wordpress admin username)
    password = my wordpress admin password
    xmlrpc =

    the actual website is, but that's just a redirected URL to the one listed above.

    also, when i use safari on either my ipad or iphone, i cannot log in to my wordpress account, whereas with my (non-mac) laptop (same network) it works fine. in fact, i cannot log on using my wife's macbook pro either. so it seems that apple devices don't connect, others are fine.

    i'm stumped.

  6. Hello ofawetland. Your URL is don't add the wp-admin

    also, I don't think you will need to type in the xmlrpc if you follow the instructions of sarahk07.

    Good luck!

  7. hi, cynthia.

    tried it that way (earlier and again just now). still no joy. i think its particularly weird that i also cannot sign in through safari on any apple-based appliance. that's got to be part of the issue.


  8. The app is completely broken for me on the iPad running 4.2.1. From earlier in this thread it looks like they may be aware of the issue and are working on a fix. For now I just get 'Bad username and password' errors or internal 500 errors. In my use the app also seems to now be riddled with display bugs and other issues. Lets hope there's a public fix soon.

  9. Same problem on an iPod touch running wordpress app 2.6.2 dated november 30th. Could it be that the Canadian store was not updated?

  10. NicoleBeauchamp
    Nov 26, 2010, 1:07 AM

    I am also having this issue. I have tried the suggestions listed here and other sub forums,and it seems to work fine and then I will get the communications error again from the iPad app.

    Has the new version of app come available as yet ?

  11. FBFM -fixed by freaking magic. that is the only way i can describe it. i now have the app running on both the iPhone and iPad. as cynthia suggested above, don't append the /wp-admin to the URL. don't know why it is suddenly working, but i'm grateful that it is.

  12. That's great news ofawetland. It worked, it worked! I know the feeling. I'm glad my little piece of info was helpful as was the information provided by sarahK07 for me. Have fun!

  13. Sarahk07....that solution worked for me on my iPhone 4. Thx.

  14. I wish I was as lucky as some of you guys. I've tried all of the solutions mentioned but I still can't connect on my iphone :-(

  15. @liamology. here's a wild hair. i used my URL without the /wp-admin (so i didn't get the prompt for xmlrpc), my wordpress signin name (in my case 'nocurling'), but i changed my wordpress password (even though it was working fine in the windows world), and bob's your uncle. i'm using the newest version of ios (4.2.1) and version 3.0.1 of wordpress. like i said to @cynthia, all of a sudden it worked.

    good luck,

  16. okay here's my random 2ยข on how I made this work after some frustration and failed attempts.

    I confirmed what Sarahk07 wrote:

    Go into www.(yoursitename).com/wp-admin/options-writing.php

    Then, scroll down to the bottom and check the box for "Enable the WordPress, Movable Type, MetaWeblog and Blogger XML-RPC publishing protocols."

    Click "Save".

    Then, after doing that,

    I typed simply the URL of my blog (
    I added my username, my password.
    Then, before I tapped "Add Site" I tapped back up in the username box.

    The server authenticated then and wrote "good to go" - then I hit Add Site. And it worked!

  17. Hey guys,

    having the same issue though trying all the methods of resolution posted above. Still got this stupid message, though the username (tried 2 user: a user which is configured admin and another which is just author) and password is 100% correct. Tryed to change my pw, didn't worked out. Any suggestions?

    Thank you all very much!


  18. Did all suggestions, got the "good to go message", clicked on joy, bad user name and password. I redid it four times and re-installed the app thrice. I'm now hoping for magic. It's a shame as I am fan of word press.

  19. Hello Greenhead, sarahk07 on 17nov suggested:

    Then, scroll down to the bottom and check the box for "Enable the WordPress, Movable Type, MetaWeblog and Blogger XML-RPC publishing protocols."

    Are you sure you've done this? This was the step that I had missed. Don't give up!

  20. Turning on XML-RPC works for me

  21. Cynthia, yes I am quite sure, I even disabled the setting nag re-enabled it to see if made a difference. It does seem to be related to a different problem which I experienced earlier with being prompted for the XML-RPC location but that was resolved by enabling that option.

    The message I get when attempting to save the site in the word press iPad app is :
    Communication error
    Bad username or Password

  22. Hi green head. What URL are you using? for example my URL is

    My blog is in a sub directory called serendipity. If it was in the root directory it would have been

    Then user name and password. The one you use to edit your wordpress blog.

    You've probably done this already but sometimes just one little step has been misunderstood.

  23. same issues.
    site authenticates fine..."good to go"
    then, 'bad username or password' when adding it.

    I got it to work once...
    by adding it with BLOGURL/wp-admin
    and including BLOGURL/xmlrpc.php

    but i tried changing the password, and then re-adding the site again.
    back to the same issues.

    app 2.6.2
    iOS 4.01

    i tried deactivating all plugins and then dice.

    another blog with the same setup works/adds fine.

    Is there some sort of weird caching issue going on?

  24. As an update,
    I created a new admin user account.
    Everything works fine with it.

    But, trying to use the account that I want, still doesn't work.

  25. @interestica - Is the account that you want to use an admin account? Is there anything unique about that username? Special characters, etc?

  26. cynthiablue44, My url is:

    I will create a username and password for you with admin rights.

  27. @mrroundhill - the second account that I created is also an admin account. i simply appended the number 2 to the original (which was a simple name made up of letters) The original account was an admin account as well (my primary login for the site)

    No special characters, etc.

    I get the feeling is has to do with the 'http auth' section picking up the username when it shouldn't...
    Or there's some sort of issue with old data being cached...?

    Does anyone know if there's a config file for the WP app if you were to SSH into the iPhone...?

  28. Ok it just got weirder. My I-touch and I-phone can attach to the same site with the same account and everything works. It is only the I-pad that is having the problem. I am attempting to figure out if there is the slightest setting deltas between the three devices. Blackberry devices work flawlessly so I think I can isolate this just to IOS.

  29. Hi GreenHead, It sounds like your problem may be a device issue which is beyond my knowledge. If you want me to attempt to test it with my iPad that's ok. Send me details if you think it will help, via

  30. Hello everyone,

    I came here because of the same problem but after reading this thread and a few trial and error later, I finally got mine to work.

    1. Login to your Wordpress account, go to 'Setting', then enable XMLRPC.
    2. Go to your app and when make sure to put / at the end of your url in full e.g I did not do this in the beginning and somehow adding that made it work.
    3. Enter 'username' and 'password'. Wait for it to authenticate and click 'Add Site'.
    4. After getting all frustrated for half an hour or so, the solution was so simple! I hope this will work for you guys too, so good luck!

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.