Forums

Impossible to log on a wordpress.com hosted blog

  1. Hello everyone

    I have recently set up a wordpress.com blog (https://infosansintox.wordpress.com/), and i just can't connect to it using my iphone or ipad with the IOS app.
    I get the bad login XML-RPC error constantly, tried to reinstall the app 6 times on both the ipad and iphone.
    Ive read everywhere that XML-RPC had to be activated for the app to work, but this advice is only valid people who use the wordpress software for their self-hosted blog (correct me if i'm wrong), as there is no such option under Settings>writing for me.
    I've also read that XML-RPC is automatically enabled for wordpress.com blogs (still correct me if i'm wrong).
    And one more thing: Oddly, i can't even connect to the admin when using the mobile version through safari on the iphone/ipad, i still get invalid username/password. Tried this when connected through Wi-Fi and 3G.

    Anyone got an idea about what I should do?
    Thanks in advance

  2. I too have the same problem on a wordpress.com blog that is hosted by wordpress. So frustrating.

  3. Yeah, theres solutions for everyone except when you have a classic, simple wordpress.com blog, hosted by wordpress. Its supposed to work right away right?

  4. I bought a premium theme too. Fingers crossed some one out there has the answer

  5. @mirzanda - do you have a premium theme as well? Maybe that's the problem. It really looks like you have the wrong credentials though if it doesn't work in safari.

  6. @mrroundhill
    Nope, no premium theme on my side, just a plain ol' default theme !
    I can log in with the login/pass on my macbook (with firefox), no problem. BUT i can't login on my desktop PC (cookies activated of course), with either firefox, IE6, Chrome or Opera (yes i'm going nuts).
    I changed the passwords 3 times but there is still the same problem : All good with my Macbook, no worky with either my Iphone, Ipad or PC. Tried through 3G and different wifi networks too.
    Sorry, i'm drifting away from the iOS subject a little, but i wonder if this might be linked in some way.
    I'm not a newbie in computers and all that, so I have absolutely no idea how this coudl happen.

  7. I too use a MacBook Pro and safari and have no problems logging in. I have just changed my theme to a simple wordpress freeby and still have the same issue.

    I too have changed pwd's, reinstalled the app, rebooted the iPhone 4, and still get the error message. This is so frustrating.

  8. Hmmm, interesting!

    I just reset my pwd but reduced it from 17 character to just 8 and the wordpress connected!

    I then posted couple of test posts with images and that worked.

    I then changed my theme to the one i had bought, and it still works.

    Can't believe that the length of my pwd's was the cause of all this, but hey it is working.

    Mirzanda, hope this helps and solved your issue :)

  9. I usually use long and complicated passwords so i tried to reduce it like you said.
    No change for me. Arrh

  10. Thanks to the ├╝ber-update, everything work Neat-o now.
    Thank you for your hard work.

  11. I changed the password length and now I can login with Wordpress for iOS, but not blogsy.

  12. I can log in to WordPress.com using a very long password. I guess you guys tried using a password with special characters in it.

  13. I experienced the login issue on my wordpress.COM blog as well, but with my co-writers (for myself it was working fine on the Mac & iOS).

    I had to change their account role to at least "Author" (have it on "Editor" now and works as well).

  14. I've tried reinstalling, I've tried the password thing, I've looked for some setting on the settings page that I might have missed. I can't get a single one of my blogs to show up on the app.

    I don't get an error, I don't get a cancellation screen. I get booted out of the app and when I start it up again, there's a loading symbol next to the blog names.

    Has anyone heard from Wordpress about what's going on?

Topic Closed

This topic has been closed to new replies.


About this Topic