Forums

Image upload error - invalid data

  1. Hi,
    I'm having real issues uploading posts to my self-hosted site using the app.
    Regular posts without images are no problem, as are small images, however as soon as I try and add a new post with an image, or use the "quick photo" option, the image upload fails with the "blog returned invalid data" message.
    I've searched through this forum and done various things others have sugested (update .htaccess, LibXML2Fix) but to no avail.
    Any help would be much appreciated.
    Wordpress 3.2.1
    php 5.3.6
    latest app (2.8.3)

    blog address http://blog.mattaubrey.co.uk

    Cheers
    Matt

  2. It could be your PHP file upload limit is set too small. Here's a thread on the WordPress.org forums on how to increase it:

    http://wordpress.org/support/topic/increase-media-library-upload-file-size-limit

  3. Thanks I'll try that. I had already added to the htaccess as suggested, but will give this a go. What confuses me is that the photo DOES get uploaded as it appears in my /uploads folder, but the app still says it's failed.

  4. Hi,
    As an update, and further cry for help, I've been trying all sorts and the issue seems not to be with the actual uploading of the file, but the creation of the post or attaching the file to the post.
    After I try and attach the image I still get the "upload failed - tap to try again" message (no pop-up error) however the image does appear in the uploads folder and in my media library as an unattached image.
    Any ideas anyone?
    I've got the htaccess set at 128M limit and 360 seconds timeout.
    Matt

  5. Matt,
    I would try disabling any themes and plugins that you think might be interfering with image uploads.

  6. Thanks, tried disabling all plugins and reverting to twentyeleven them, but still no use.
    When the "crunching" dialogue disappears and I click "Show" the image details section appears but under "size" the only option I can choose is Large (0x0) which is obviously where things are going wrong.
    Any other ideas!?
    Matt

  7. Did you solve this problem? Can you share the solution?

    Thanks

Topic Closed

This topic has been closed to new replies.


About this Topic