Forums

HTTP /1.1 404

  1. Hi,

    I've recently moved a client's site to a new host and started receiving a 404 error when trying to connect from the iOS app. The site is http://flaksburyst.com and I've been trying to figure out this problem for the past few days. I've been working with the host to track down the issue but unfortunately progress has stalled in finding the problem. The weird thing is that both http://flaksburyst.com/xmlrpc.php and http://flaksburyst.com/xmlrpc.php?rsd return the expected responses but when we try to POST to xmlrpc.php we get a 404 error.

    A few things we've tried already:

    • Disabled mod_security
    • Tried to connect with or without the www
    • Disabled and re-enabled XML-RPC in WP settings
    • Disabled all plugins

    Here's a snippet of the access logs so you can see when the 404 occurs:
    166.137.136.43 - - [08/Feb/2012:14:23:02 -0500] "GET / HTTP/1.1" 200 41793 "-" "wp-iphone/2.9.3"
    166.137.136.43 - - [08/Feb/2012:14:23:05 -0500] "POST /xmlrpc.php HTTP/1.1" 404 18469 "-" "wp-iphone/2.9.3"
    166.137.136.43 - - [08/Feb/2012:14:23:06 -0500] "POST / HTTP/1.1" 406 41793 "-" "wp-iphone/2.9.3"
    166.137.136.43 - - [08/Feb/2012:14:23:07 -0500] "GET / HTTP/1.1" 200 41793 "-" "wp-iphone/2.9.3"
    166.137.136.43 - - [08/Feb/2012:14:23:09 -0500] "POST /xmlrpc.php HTTP/1.1" 404 18469 "-" "wp-iphone/2.9.3"
    166.137.136.43 - - [08/Feb/2012:14:23:11 -0500] "GET /xmlrpc.php?rsd HTTP/1.1" 200 828 "-" "WordPress/2.9.3 CFNetwork/548.0.4 Darwin/11.0.0"
    166.137.136.43 - - [08/Feb/2012:14:23:12 -0500] "POST /xmlrpc.php HTTP/1.1" 404 18469 "-" "wp-iphone/2.9.3"

    Any ideas on how to resolve this?

  2. Update: This issue was indeed cause by ModSec although I thought it had been disabled.

    The issue was resolved by adding a location match for "/xmlrpc.php" to disable rule 90001 in the modsec conf file:

    <LocationMatch "/xmlrpc.php">
    SecRuleRemoveById 90001
    </LocationMatch>

    Just wanted to include the fix in case anyone else has the problem in the future.

Topic Closed

This topic has been closed to new replies.


About this Topic

Tags