Forums

Has anyone got this app working for a SELF-HOSTED blog?

  1. I have been having trouble with the iphone app as well and just managed to get it to work. I will share my experience in case it helps anyone.

    So the only think I can contribute to actually fixing the problem, was that I kept trying. I just kept re-entering my user name and password and switching between wifi and 3g. I kept getting the error where it said it "could not find" the site, so I would just hit "back" and re-enter the info, or I would restart the app. My phone is jailbroken so it was easy to turn wifi on and off without leaving the app. When I finally did manage to connect I was connected using 3G, with the wifi still activated (I had wandered out of coverage), which is (like revyd) but it had failed many times before while I was using 3G.

    I'm using WP 2.8.2 hosted at my hosting company, and I have the newest iPhone app (as of July 28 ).

    In any case, hopefully a few more attempts will help out some of the rest of you.

  2. I have the same problem here. I'm running a new iPhone (bought it 3 days ago!) and my Wordpress self-installation is version 2.6.2.

    The wheel keep on spinning. i switched from 3G to Wi-Fi, still no improvement.

  3. First, I would update to the latest version of WordPress. I'm not sure the app works with 2.6.x

    One thing you might try is validating your blog's first page at w3.org and correcting any errors found. I've built a fix that solves the XMLRPC issue, and that will be coming out in the next release. But the spinning wheel could be for many reasons and it's difficult to be sure what is causing that.

    If you set up with the defaults, you should be able to hit (http://yourblogname/xmlrpc.php?rsd) in a browser and get some XML on the page that shows your XMLRPC endpoint. This is how the app derives the correct endpoint. If you get errors on that it may indicate security settings that are preventing access.

    See this article for more on the security...

    Post back and let us know how it goes...

  4. I got it to work!!

    I've upgraded from 2.6.3 to 2.8.2. I had the XMLRPC working, but apparently the App did not play well with 2.6.x

    Now after the upgrade I got the blog set up (as a note I have my blog under the folder '/blog' and therefor the XMLRPC.php file is located under arturorevilla.com/blog/ but when I setup the blog I didn't require to add the folder, just the top name.

    In other words I use the url as defined on the Options for the field Blog URL. Do not use the Wordpress URL

    Hope this helps

  5. Glad to hear it worked! Thanks for posting back.

  6. I tried the recommendations thus far and it still doesn't work for me.
    This is the information:

    What else should I try?

  7. Maybe I missed it, In that case sorry. But I can't see that the issue with themes has been mentioned.

    I have 6 self hosted blogs and the iPhone app worked fine with 5.

    It turned out that the problem was the theme on that particular blog. I added the little code-line and now every blog works fine.

    http://josephscott.org/archives/2009/04/wordpress-theme-authors-dont-forget-the-wp_head-function/

  8. All,

    I'm seeing more and more instances of malformed XML as the probable cause for this issue on self-hosted blogs. While the new code I wrote will get around this, there is a high probablility that fixing the xml-related issues on your blog's main page will get you working now.

    I'm very interested to hear from anyone who tries this... Please check your web page with the w3.org validation page and correct any errors it finds. With luck that will solve it for you - please post back if you try this.

  9. Kandreou,

    I viewed your page source. It lacks the EditURI link that needs to be there. I suspect your issue is the one mentioned by home-ion. It's likely the theme you're using does not include the call to the wp_head() function.

    Please check this link...

    http://josephscott.org/archives/2009/04/wordpress-theme-authors-dont-forget-the-wp_head-function/

  10. jb6262:

    <?php wp_head(); ?> is there, right before </head>

    What else can I check?

  11. FWIW, just downloaded the app (to a 3G) and did a test post -- one line of text and a photo -- publishing (via Wi-Fi) to a self-hosted site running WP 2.8.3 and things worked fine.

    The two problems I had were mainly to do with my ignorance or poor documentation:

    1) Got error message on app -- seemingly directing me to edit a php file; bad idea -- which I was about to do until I learned about adjusting the Remote Publishing "Writing" settings (admin>settings>writing);

    2) Didn't know how to publish from app until I searched this forum's FAQ (set Status to Published then tap Save on the post screen you're taken back to).

  12. @kandreou
    Well something is preventing the RSD link from being included. I did a view source for http://www.idtg.org/ and found no RSD link in the HTML. It needs to have a link to the RSD, which in your case is http://www.idtg.org/xmlrpc.php?rsd. All of the other obvious things check out okay so I suspect that is the problem at this point.

    @rumschiff
    All of the basic things checkout for your blog so I suspect this is a problem with the iPhone app finding the RSD link. John has already changed this, those improvements should go into the next version of the app.

    @pab1953
    What error message did you get that indicated you should edit a PHP file? The UI is getting some changes to make things simpler and more obvious, hopefully those will be part of the next release.

  13. @josephscott
    I don't know what's wrong but I got tired of trying to figure it out so I just manually added <link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.idtg.org/xmlrpc.php?rsd" /> to my header and it worked.

  14. To share my revelation:
    What worked for me while I had all the problems mentioned above and checked everything in the FAQ:

    Switch back to the default Wordpress Theme (blue and white)
    Register your blog in the Iphone
    Switch back to your personal theme
    Go back to your Iphone: no error, everything is working.

    @jb6262 Do you know if we can have any soon basic editing capabilities like the ones above this reply form?

  15. @davidruzicka
    In your case your site does have the RSD link, but probably wasn't getting picked up do the fragile way in which the app was looking for it. This has been improved and the next version of the app will do a much better job of finding the RSD link.

  16. I havr to same problems in my blog http://www.apneaimages.com/blog

    @kandreou
    Where you add "<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.idtg.org/xmlrpc.php?rsd" /> "?

    I iam not a coder but in wich file and place?

  17. @lambis

    In your case it'll be <link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.apneaimages.com/blog/xmlrpc.php?rsd" />

    You need to edit the file header.php of your template and add that line after the last <link>
    Just be careful because you could screw up your template if you edit it incorrectly. I would recommend, however, that you follow the advice given here first before trying to edit your template, especially since you're not very comfortable with html & php.

  18. @kandreou

    Thanks.. I have try it but its dosent work :-( have try to to instaal the default theme same same..
    I have wordpress 2.8.3.

    Wich adive you mean.. have i miss something?

  19. @lambis -
    Your error is that XML-RPC requests (http://www.apneaimages.com/blog/xmlrpc.php) are being blocked. They return an HTTP 403 Forbidden error. This might be a mod_security problem, it's mentioned in the FAQ.

  20. @joseph..

    Hmm... i have try (as good as i can) but its still not working.
    Had not found a .htaccess file so i have create a .htaccess.txt and put follow there

    <Files xmlrpc.php>
    SecFilterInheritance Off
    </Files>

    Still not working and i dont know how i can fix this issue.

  21. @lambis -
    Something on the host is preventing XML-RPC requests. You'll probably need to talk to your hosting provider to get help sorting out why.

  22. Guys. After hours of twisting myself into pretzle shapes trying to get this app to work, I was told by my servicep
    provider that they have the service blocked for security reasons. I recommend calling your provider after trying a few of the suggested fixes Good luck.

  23. EVERYONE! HERE IS THE ISSUE!

    so the code

    <link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://example.com/xmlrpc.php?rsd" />

    is generally located in people's index.html file, the main page for their blog template.

    If you simply copy and paste that into the <head></head> section of your header file, it will fix the problem.

    This has been tested on three blogs and passed all three times.

  24. i have no idea why that didnt wrap....

  25. WordPress automatically inserts that RSD link line in the HEAD section of your HTML.

  26. When I tried to validate my self hosted blog this morning all I got were time-outs. I tried various ways of entering my url but that didn't make a difference. I just tried it again a couple of minutes ago and it connected to my blog after about 20 seconds without any problems at all. Is it possible that there are just time-out errors and that's all they are?. By the way, myblogname.com was the url that it wanted. It didn't need http or www, etc. Works great now.

Topic Closed

This topic has been closed to new replies.


About this Topic