Forums

Has anyone got this app working for a SELF-HOSTED blog?

  1. Like a few others, this app doesn't seem to want to work for me. Anyone HAS got it working on a self-hosted blog? Care to talk us through the steps (since the app has no instructions).

    Thanks!

  2. Sam,

    In what manner does yours fail? Mine hangs ...

    Best

    Julian.

  3. I use it for one self-hosted (running 2.7.x), while my other one does not work (running 2.6.x). What version is yours?

  4. I'm self-hosted on WP 2.6.5

    I just downloaded the WordPress iPhone App today. I added my blog and it told me I had to enable XML-RPC - new blog, hadn't set that up yet, so I did. It authenticated and everything, then saved and went back to the main app screen and ... hung.

    I have tried uninstalling the iPhone App and reinstalling, same result. I've tried three different WiFi networks and 3G in case it was a local network issue.

    My webhost deploys WP for me, they haven't upgraded to 2.7.1 yet, so I don't know if that will fix things and I don't know when I'll be able to try. Would really like to be able to post easily from my iPhone, include photos, etc.

    I also haven't checked all related topics, but I figured my experience might help the dev team if anyone's reading and this is still an open issue.

    -Josh
    illuminerdi.com

  5. Sorry for the quick update, but I just got my webhost to upgrade me to 2.7.1 - should have checked, they switched their deployment app.

    And guess what ... 2.7.1 works with the app. I just tested posting something new with an image. All is well.

    I guess there is some issue with 2.6.5 definitely, and maybe 2.6.x in general? Looks like those versions are supported, so ... weird.

  6. I am using 1.2.1 with WP 2.7.1. I installed it myself on my home machine, then installed it myself on my service provider. I can navigate and edit my posts and pages and comments.

  7. It partially works with 2.7.1 for me. Categories don't work at all. Everything else mostly works, with glitches here and there..

  8. I'm running 2.7.1 self-hosted and haven't been able to get the app to recognize it. I get what seems like a hang, but results in a message about being unable to find the xmlrpc. I've tried switching to the default theme and adding a php line to the header file as described by another user, but no luck.

  9. One thing to check... for self-hosted...

    In the admin "console" under Settings --> Writing...

    Look for a checkbox with a label "XMLRPC" and text like this: Enable the WordPress, Movable Type, MetaWeblog and Blogger XML-RPC publishing protocols.

    Make sure that is on and try again...

  10. I've got 2.7.1 and the XMLRPC checkbox checked, still not working...

  11. I'm having trouble getting it to work on a self-hosted blog also.

    But here's the thing: Even though I've got the XMLRPC checkbox checked, I don't have the relevant line of markup in my source code.

    A bug in WordPress itself? i'm using 2.7.1...

  12. Hmmm... Two things -

    1. What is the web address of any of these self-hosted blogs?

    2. From a troubleshooting perspective, the best approach perhaps is for you to temporarily let me have a username / password to your self-hosted blog. Then change back after I've tried to connect via my simulator and XCode and checked on a few things... Anyone game? I basically need access to your admin console and the ability to "sign in" from the iPhone app... I promise to do no harm...

    I have a self-hosted blog at http://www.iphonedevblog.johnbickerstaff.com/wordpress and it does work fine with the application, so there must be a combination of settings that will work...

    If anyone is willing to try this - send the temp username / password to john(at)johnbickerstaff(dot)com.

  13. @jb6262 I'm sure you're aware how fishy it sounds to be asking people to provide their username/password to any site.

  14. A most excellent point!

    Let me state that I'm officially working on the app for Automattic and am posting to the forum here at their request. I also assume that anyone doing this would first change their password to something simple and then change it back when I'm done...

    Didn't mean to create suspicion, but I also neglected to state that I'm officially engaged by WP to work on developing the app...

    I've done a lot of support in the past and find that beyond a certain point, exchanging posts or e-mails consumes much more time that just looking at things... As there can be too many variables to easily pin down.

    Setting up a wordpress.com site just for testing would (of course) be easy and non risk, as it's not someone's original site, but to quickly pin down issues on self-hosted blogs would probably require this... I'd like to help eliminate other's frustration, but troubleshooting from posts and e-mails becomes very difficult...

    I appreciate your pointing out this concern and will go back to some other posts to state that I'm working for Automattic on the iPhone application - perhaps that will reduce the concern. Of course - no requirement - just an option for those who are interested...

  15. http://iphone.forums.wordpress.org/topic/troubleshooting-help?replies=2#post-443

    Some more info here on the troubleshooting support question, and the point made by spamboy...

  16. Thanks, @jb6262!

  17. i have a self-hosted blog and everytime i create a post with a picture, the space for the picture comes up, but it doesn't seem to upload the actual photo. i look in my ~/blog/wp-content/uploads directory, where the link that is created in the blog entry points to and, indeed, no images are uploaded. any ideas how to fix that?

  18. Can you upload images normally via the edit post screen in wp-admin? If not then there's probably something that needs to be changed on the server to support it. First thing to check is that wp-content/uploads is writable by your web server.

  19. I'm running 2.7.1 self-hosted and haven't been able to get the app to recognize it. I get what seems like a hang, but results in a message about being unable to find the blog. I've enabled the Writing Settings for xml rpc, but no luck. Has anyone gotten this to work yet?

  20. It works for me, but it's horribly broken. I can't add the characters: < > " ' so I can't add links or images. All of those characters just disappear when I publish the post. It's very frustrating as the problem as persisted through 2.6, 2.7, and 2.8.

  21. not working for me at all, cannot add my blog.... I jsut created a new topic, but I have done everything I can think of to try and fix it

  22. So I'd tried every solution I could find on this forum, paying particular attention to this thread. I had a self-hosted blog, jetantonio.com with a fresh 2.8 install and no plugins and the default theme. WP reinstalls, iphone reinstalls, .checking .htaccess, checking XMLRPC, all that didn't work. It would just hang.

    What got past the hanging was installing wordpress in a subdirectory. I installed in a folder called /blogster and BAM no hangs! I could also post and preview with no problems!

    HOWEVER, I wasn't able to upload photos. I had a similar problem as livethisdream. It would post a broken image. When I investigated my root directory, it turns out my phone had created a /wordpress directory and uploaded the files there. And so I ended up renaming my /blogster folder to /wordpress.

    So in short: for me, at least, installing Wordpress 2.8 in a subdirectory called /wordpress fixed the hang and the picture uploading issues.

    Hope this helped.

    EDIT: This might be helpful - http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    -Jet

  23. I cannot get this to work it just hangs with "...could not find your blog. ..." (RayOnStorage.) using WP 2.8 self hosted blog, latest iPhone WP app, and iPhone 3.0 with a 3G phone.

    I tried prefixing my blog with WWW, checked out the XML-RPC, tried deactivating all my plugins, tried using the default theme, tried all this and it still didn't work.

    A couple of points for the dev team:
    1) it would be nice if the "save" button actually saved the blog information and there was another button to attempt to login that way I would have to re-type my blog login info each time I tried it. All this re-typing has made this a frustrating experience for me

    2) it would be nice if the app had some way to turn on "debug mode" and would email the data somewhere so that a) some progress could be made to fix the problem, b) some sort of hope could be instilled that progress was actually being made to fix the problem. Rather than having to supply your login credentials to somebody.

    3) ditto for WP rather than having to edit .PHP text files.

    4) There must be at least 4 different threads on this problem all of which have different snippetts of advice, troubleshooting and hints - all of which haven't helped me but wouldn't it be nice if all the threads could be intertwined and we could see all the info at one time...

  24. I am having the same problem on a self-hosted blog. It takes the blog set up info, reads the name of the blog, goes back to the main screen and I get the spinning wheel forever. I've tried re-installs, and a few of the other tricks mentioned here, but no luck.

    Any new info?

  25. This still fails with Iphone app 3.0, WP 2.8.1, with XML enabled...

  26. So in a form of desperation, I tried adding a trailing slash to the web URL, added www. in front of it and now it works?!

  27. I still can't get wordpress to work on my iphone for either of my two blogs. I have checked the XML setting, tried all versions of with http://www., without, with trailing slash, without, and with http:// and without. Every time I try to add the blog, I get the infinitely spinning wheel.

    The two blogs are http://beckyanddaniel.com/knitting/ and http://beckyanddaniel.com/blog/
    The second one is a brand new blog, with the defaul theme, and I tried deactivating all plugins. So I can't imagine that the blog settings are the problem. I don't get the XML error, so that is not the problem.

    I was really looking forward to having this app when I travel to Spain next week - in fact, it's the whole reason I switched my blog to wordpress.

    I use yahoo webhosting, so I am stuck with their settings and version 2.6.2 (I think - am I wrong, is there a way to upgrade on yahoo??) Will the iphone app simply not work with this version?

    I would really appreciate any advice anyone has as I really want to be able to blog my trip. I am not super tech savvy, but I have tried as to look at all the forums and try all the tips people mentioned .

  28. Having the same problem as a number of posters.

    Self-hosted wordpress blog version 2.8.2
    iPhone app v 1.21.1

    Get the spinning wheel and can't find blog error message when trying to add blog.
    I've switched to the default theme, deactivated all plugins with no luck.
    I've entered my blog address with www. in front and / at the end. No luck

    Going to http://daveolson.ca/xmlrpc.php?rsd results in "WordPress http://wordpress.org/ http://daveolson.ca"

    I'm stumped... any ideas?

  29. okay... weird. I just disable my wireless on my iPhone and I was able to connect with 3G.

Topic Closed

This topic has been closed to new replies.


About this Topic