Forums

Getting "NSXMLParserErrorDomain Error 9" when adding blog

  1. For some inexplicable reason, I am getting the "SXMLParserErrorDomain Error 9" error when trying to add any of my blogs in the WordPress for iPhone app, version 1.21.1 (supposedly 1.3, but it reports itself as 1.21.1). I am running iPhone OS 3.1 (Build 7C97d). After I dismiss the dialog box, I get taken back to the blog listing page, where the loading spinner next to the blog's name will spin endlessly.

    I've deleted and reinstalled the app, but I'm still getting the error.

    The blog I'm trying to add is: http://atinyblip.com; hosted by WordPress and redirected by an own domain. I've never had any problems previously, so I suspect this is caused by OS 3.1.

  2. I didn't get Error 9 today when I tried again to add blogs in the app. What I did was I chose "10 recent posts" instead of "50 recent posts" which I'd usually choose. The blog was added successfully.

    But once I start picking "20 recent posts", etc, Error 9 will come up.

    I duplicated this symptom by adding another blog. Same thing: only the "10 recent posts" setting worked.

Topic Closed

This topic has been closed to new replies.


About this Topic